1. bobrock4's Avatar
    Hi all, this is my first message here.

    I'm trying to install Google Chrome on a tablet not very famous on which there's Android 4.2.2.

    It takes me to Play Store and I choose to install. It comes a window about some of its functionalities and then, in the end of the window, the list of compatible devices is empty...there's not my device listed there. The installation ends here because the installation botton doesn't start after the clic.

    Do you know what could it happen?

    Thanks and Ciao
    10-13-2014 08:12 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Are you looking on Google Play Store on your tablet, or on a computer browser? Does the tablet have Google Play Store? Not all devices are certified for Google Play.

    If you have Google Play Store on your tablet, then do a search for Chrome. If it doesn't show up, then for some reason, your tablet is not compatible. It can be difficult to find out why.
    bobrock4 likes this.
    10-14-2014 02:15 AM
  3. bobrock4's Avatar
    Hi B. Diddy,

    I went to Google Chrome App from a browser on tablet. This way has not worked, so I have tried, after your message, to go to the Play Store from tablet app and and then there I have been able to install Chrome.

    Thanks for your help.

    B. Diddy likes this.
    10-15-2014 05:48 AM

Similar Threads

  1. Do you use phone when it is placed on the table?
    By acsurfer in forum General News & Discussion
    Replies: 2
    Last Post: 10-13-2014, 07:38 PM
  2. Replies: 0
    Last Post: 10-13-2014, 07:31 AM
  3. Why won't my S3 Mini turn on?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-13-2014, 07:30 AM
  4. Replies: 0
    Last Post: 10-13-2014, 06:51 AM
  5. Has anyone else seen the new material design for Google play games?
    By Kyoshiro82 in forum Legacy Android & Other OS's
    Replies: 0
    Last Post: 10-13-2014, 06:19 AM