1. Chrispyshrimp's Avatar
    I've had this N9100 for a good while and I've never gotten the Google play store app to do anything, I've yet to download a single app, I've gone thru the works of quick fixes, clear cache, clear data, force stop, install updates, factory reset, I've logged in and out several times in my email, google, and chrome, nothing has helped. I've looked it up this device is compatible with Google Play, but it never gives me anything more that "Server Error" when I open the app. The provider is probably to blame, anyone heard of Kroger I-Wireless? That's the carrier, and they've been of no help at all. if anyone can help, I'd be retarded happy, I've got a list of apps to get when it's fixed. Thanks.
    01-17-2015 05:09 PM
  2. Rukbat's Avatar
    Connect to Google Play with a web browser. (You'll be asked to log into your Google account at some point in this process - use the account on your phone.) Find the app you want to install and wait for a line to come up with the fact that the app is compatible with your device. Click the Install button, click the OK button and the app should be installed to your device. (If you have more than one device on that account, there's a dropdown before you click the OK button to tell it which device to install the app to, then click that Install button, then the OK button.)

    If you still get a server error connecting to Google Play with a browser, it's your internet provider - contact their tech support. (Play Store should work on mobile data regardless of your internet provider, though, because you're using your cellular carrier's internet connection.)
    01-17-2015 07:23 PM
  3. James_Watson's Avatar
    As I know, access to google service including play store was banned by some government.
    So, as the ambassador suggested above, you try to access Play Store via web browser. https://play.google.com/store/
    If you can view store via browser, your problem should resulted from the Play Store app. Then you may get this reinstalled. Otherwise, you have to contact your internet provider.
    01-22-2015 02:17 AM
  4. James_Watson's Avatar
    Can we get these two APKs from Google official website?
    01-22-2015 09:29 PM
  5. christopher neils's Avatar
    Well, that's something weird I have ever heard okay did you tried signing up a new account and then tried putting that account over to the device. I would say sometimes it happens because of the google account. So, better to try it again by signing up a new account also I would advise you to try clearing the cache and the data stored by the download manager app. You can do that by heading over to the settings>application manager>swipe left to all>Look out for the download manager> Tap over it >Force stop the application and then tap over the clear cache and the data. Once done again try using Google PlayStore to download app and if once again this time things doesn't works out for you I would say it's so called the problem with the carrier not because of the device. And you may need to give the customer support people call about this one, and in the mean time you can head over to alternatives of Google PlayStore there are actually a number of them available which you can try ! See if this works out for you ...
    01-22-2015 09:40 PM

Similar Threads

  1. How do I get my Google Now cards to come back?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 10-22-2015, 06:08 AM
  2. Replies: 0
    Last Post: 01-17-2015, 04:43 PM
  3. Verizon disable apps option
    By kami8586 in forum Samsung Galaxy Note 4
    Replies: 1
    Last Post: 01-17-2015, 03:49 PM
  4. Replies: 1
    Last Post: 01-17-2015, 03:20 PM
LINK TO POST COPIED TO CLIPBOARD