1. dodgylegs's Avatar
    In Google Calendar on my PC Desktop for example, events go back to May 2010 (and further back, obviously) - yet on my Phone Calendar (Jorte) events don't go back that far, or in the Google Calendar on my Desire.

    Is there a setting I'm missing for this?

    Thanks Peeps x
    12-13-2010 05:17 AM
  2. Gekko's Avatar
    12-13-2010 05:31 AM
  3. dodgylegs's Avatar
    Thanks - this fix worked btw

    1. From the home screen hit menu and go to Settings - Accounts & Sync.
    2. Turn off the Background Data and Auto-sync.
    3. Switch to Airplane mode to disable phone and GPS (because if you get a call or sms during the process, it corrects the time), then re-enable Wi-Fi so you can sync.
    4. Go to Settings - Date & Time.
    5. Turn off Automatic then Set Date to your earliest appointment year (e.g. 1/1/97) and hit set.
    6. Restart phone.
    7. Go to Settings - Applications.
    8. Select Manage Applications and choose All.
    9. Find Calendar in the applications list, select it and choose Clear Data (it will warn you about losing all files just hit OK).
    10. Do the same for Calendar Storage.
    11. Go to the Calendar application. Choose Menu - More - Calendars and select All calendars. Make sure each calendar type is checked.
    12. Go back into Settings - Accounts & Sync.
    13. Select the Google account, then tap Sync Calendar to sync. Do not sync gmail or contacts.
    14. Be sure the date it lists for the last sync is the date you selected, and you may want to hit sync once or twice more to be certain the sync was completed.
    15. Once sync has completed for the year selected, choose Settings - Date & Time. Change the date to Jan 1 of the following year (e.g. 1/1/98). Complete steps 12 - 14 for the new year.
    16. Repeat step 15 for each year until the present year.
    17. Once complete go to Settings - Date & Time and select Automatic.
    18. Go to Settings - Accounts & Sync and turn on Background Data and Auto-sync if desired.
    12-13-2010 06:53 AM