1. AC Question's Avatar
    When i go on the YouTube app on my phone it just says "Please check your network connection" i press the Retry button right under it because my wifi bar is at full strength and it does nothing, i restart my phone and router multiple times trying to fix this problem and i can't go on Google either it just says "Can't load search results" and they stopped at the same exact time, but i can go on Tumblr so I am extremely confused.
    Please help
    07-05-2015 03:16 PM
  2. itguyjax8430's Avatar
    When i go on the YouTube app on my phone it just says "Please check your network connection" i press the Retry button right under it because my wifi bar is at full strength and it does nothing, i restart my phone and router multiple times trying to fix this problem and i can't go on Google either it just says "Can't load search results" and they stopped at the same exact time, but i can go on Tumblr so I am extremely confused.
    Please help
    Welcome to Android Central!

    Try going in to your phone settings, applications, all apps, find the YouTube app and clear the data. That should reset the app and may fix the issue.
    07-08-2015 09:15 AM
  3. tylergbond's Avatar
    If you look at the wifi signal bars and they are not blue or green you can do this (on rooted devices only) ... go to files... system... etc... find file labled hosts in etc.. delete hosts. This also fixes issues connecting to google apps

    Sent from my ASUS Transformer Pad TF300T using Tapatalk
    07-10-2015 04:48 AM
  4. khaled Esheh's Avatar
    Try to check the time settings on your mobile.
    Kamaljit Taheem likes this.
    05-22-2016 06:47 AM
  5. richard newman2's Avatar
    Hello, just wanted to say that I had this issue on a galaxy core prime and clearing all data did the trick for me. I tried to clear the cache first with no luck. Hope this helps.
    06-20-2016 04:51 PM
  6. CatsInvent99's Avatar
    Whenever i go to my YouTube app in my android phone, Most of the video that i click has the messege ' Connection to server lost Tap to retry ' but when i click retry it keeps doing the same thing, Even my Google Play Store doesn't work keep saying ' Unfortunately, Google Play Store has stopped. My phone is rooted
    10-13-2016 10:23 AM
  7. J Cee's Avatar
    Clearing the cache for youtube worked for me!
    11-01-2016 04:08 PM
  8. Wolf Playz's Avatar
    Im totally going through the same thing WHAT DO I DO?!
    11-05-2016 09:55 PM
  9. B. Diddy's Avatar
    Im totally going through the same thing WHAT DO I DO?!
    Welcome to Android Central! Did you already try clearing You'Tube's app cache and data, as suggested above?
    11-06-2016 01:20 AM
  10. Filee's Avatar
    That method does work but now i cant connect to the internet i mean its just loading and loading and loading.Please help me.
    12-05-2016 03:28 PM
  11. darlin18's Avatar
    Had the same issue. What worked for me was when I changed the date and time settings on my phone to automatic date and time and automatic timezone.
    12-05-2016 06:44 PM
  12. Olioak's Avatar
    Well I did have this issue on my S7 Edge I cleared the Data and Cache but nothing happened but I did delete a Youtube Channel on one of my Google Emails and deleting that Email from the Google Accounts fixed the issue for me.
    12-29-2016 10:44 PM
  13. Jamie720's Avatar
    This morning I had the same problem so I signed out of the app on my s7 edge, the main video feed appeared but when I tried to sign back in it came up with the same error. I also tried to clear the data and the cache. Is there anything else I can do?
    01-07-2017 05:19 PM
  14. B. Diddy's Avatar
    Welcome to Android Central! Does this happen on both wi-fi and mobile data?
    01-08-2017 01:27 AM
  15. erezs1's Avatar
    Welcome to Android Central! Does this happen on both wi-fi and mobile data?
    Hi,
    For me it occurs only when I'm on mobile connection, if I sign out of my account youtube is back. also I'm able to work with my account with mobile data through the browser.
    Tried erasing cache, data, reinstalling youtube and earlier versions, nothing works...
    Any help is appreciated.
    Thanks
    Erez
    02-10-2017 08:00 AM
  16. B. Diddy's Avatar
    @erezs1, welcome to Android Central! Try going to Settings>Mobile Networks>Access Point Names​, select your main APN and edit it, and disable IPv6.
    azriladha likes this.
    02-10-2017 10:29 AM
  17. azriladha's Avatar
    Hye guys. If your utube apps have problem with connection. (No connection). Try to logout your acc. Tht work with my android.
    04-11-2017 01:46 PM
  18. Ximu's Avatar
    If your background data is restricted
    Turn it off. Its worked for me.😊
    06-08-2017 08:33 AM
  19. Emma Sivak's Avatar
    Try turning WiFi off then wait a minute then back on works for me. What phone do you have?
    06-18-2017 12:12 AM

Similar Threads

  1. GS4 White Blocks On Lock Screen
    By Firestorm421 in forum Ask a Question
    Replies: 2
    Last Post: 07-08-2015, 09:15 AM
  2. How do I delete/sort auto-complete email addresses?
    By AC Question in forum Samsung Galaxy S3 Mini
    Replies: 1
    Last Post: 07-08-2015, 08:10 AM
  3. HELP!!! How can I retrieve deleted bookmarks on Stock browser?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 07-08-2015, 08:07 AM
  4. How do I log into the forum?
    By AC Question in forum Android Central Community
    Replies: 3
    Last Post: 07-05-2015, 05:24 PM
  5. Replies: 1
    Last Post: 07-05-2015, 03:18 PM
LINK TO POST COPIED TO CLIPBOARD