1. tyrelian's Avatar
    So for a little over a month now I've been trying to update angrybirds over 3g, 4g, and wifi. Downloading is fine but once it starts to install everything goes haywire, a message even pops up saying "unsuccessful installation, unknown reason 18" any help would greatly be appreciated
    03-17-2011 03:50 PM
  2. inphoenix's Avatar
    uninstall and reinstall.
    03-17-2011 04:56 PM
  3. penk's Avatar
    Unmount the SD card, upgrade/install again.

    03-18-2011 05:34 AM
  4. DevilInPgh's Avatar
    No, still won't install.
    03-22-2011 04:19 PM
  5. midmofan's Avatar
    Hallelujah! Success at last! The solution for the update problem and at least some of the installation problems (like angry birds rio) is as follows:

    First, hook your phone to a computer with a usb cable - need to have your phone in "disk drive" mode. Most likely your phone will at first say "charging only." you will have to click on this to pull up a screen that allows you to change it to "mount as disk drive." Note: this may take several attempts. If your computer does not recognize the phone as being hooked-up at first, unplug it and try again.

    Now, open the new drive that will appear on your computer (which, of course, is actually your phone's sd card).

    Next, locate the file folders named ".android_secure" (it should be near the top of the listings).

    Click on and open up this ". android_secure " folder and look for a file named "smdl2tmp1.asec"

    Delete it! Destroy it! Kick it out of your life! It's what is causing the problems!

    Unplug your phone. Phone will say something like "preparing sd card." It could take a bit but after that you can update all the apps including those on your sd card and angry birds and download Rio hassle free.

    This, IMO, is much better than the suggestions that involve deleting the android_secure file altogether since you DO NOT have to move your apps off of the sd card and then back on again for it to work!

    Credit goes to "the Engineer" who, near as i can tell, was the first to post a version of this fix. As there a a whole bunch of threads on this issue, please pass the fix on.
    03-24-2011 12:13 AM