1. solo1's Avatar
    About a couple of months ago Angry Birds stopped installing on my SD card ... My solution was to unmount ... download ... install ... re-mount ... then move to SD card ... Now with Amazon ... Angry Birds RIO won't install at all if the SD isn't mounted (or seen) ... Does anyone know of a work-a-round ... Unrooted EVO 4G
    03-22-2011 01:49 PM
  2. apaq's Avatar
    This is happening to me also. It is driving me nuts.
    03-22-2011 03:00 PM
  3. apaq's Avatar
    I deleted the contents in .android_secure folder on the sd card and it worked. I do not think it will screw anything else up but I saved the folder before I deleted the stuff.
    03-22-2011 04:12 PM
  4. solo1's Avatar
    My Android_secure folder is empty ... I am sure WE aren't the only ones having this problem, but I cannot find the solution anywhere or can't understand why Angry Birds decided to only install directly onto the SD card.
    03-23-2011 10:21 AM
  5. solo1's Avatar
    The " unable to install " solution below worked well for me.

    Hallelujah! Success at last! The solution for the update problem and at least some of the installation problems (like angry birds rio) is as follows:

    First, hook your phone to a computer with a usb cable - need to have your phone in "disk drive" mode. Open the new drive that will appear on your computer (which, of course, is actually your phone's sd card).

    Next, locate the file folders named ".android_secure" (it should be near the top of the listings).

    Click on and open up this ". android_secure " folder and look for a file named "smdl2tmp1.asec"

    Delete it! Destroy it! Kick it out of your life! It's what is causing the problems!

    Unplug your phone. Phone will say something like "preparing sd card." It could take a bit but after that you can update all the apps including those on your sd card and angry birds and download Rio hassle free.

    As there a a whole bunch of threads on this issue, please pass the fix on.

    Sent from my Evo - so there!
    edw371, yingthaiaz and timinsocal like this.
    03-23-2011 05:45 PM
  6. edw371's Avatar
    I have been having download and installation problems for weeks with my Droid Incredible. The fix was to unmount my SD card and then update all of my apps. Deleting this file (smdl2tmp1.asec) from the .android_secure folder solved everything!! Thanks for the tip solo1 via midmofan.

    Does anyone know what this file is; malware, bad download file, android software problem, etc??? It would be nice to know so whatever I did I won't do it again. Thanks.
    03-23-2011 09:14 PM
  7. Cappurnikus's Avatar
    Removing smdl2tmp1.asec worked for me as well. I am also interested in knowing what its purpose is.
    03-24-2011 10:16 AM