1. Hardcase's Avatar
    Here is a quirky question. Some application is messing up the brightness settings on my phone every time I take it off a docking station. This happens on my desktop and my car dock. When I pull my phone off, the brightness goes down to zero. The Power Widget indicates that the brightness should be set on automatic. But, when I go into the settings and look at it, even though the automatic box is checked, the phone says brightness is set to the lowest setting.

    I have it set for automatic brightness. I thought maybe the sensor was wonky, but have cleaned the area and tested it in other settings. The sensor appears to be working correctly.

    I do have ToggleSettings, but all of the brightness settings are set for automatic on that, too.

    Short of uninstalling every program on my phone, are there any suggestions. I know the obvious one is a program is doing it, but which one. I checked my car dock settings and my desktop dock settings -- and every other program that messes with brightness.

    Thanks for the collective wisdom from the forum.

    My Droid 2 is not rooted and no funky mods have been made.
    04-13-2011 08:23 PM
  2. srkmagnus's Avatar
    Start by checking the apps that are running. Menu > Settings > Applications > Running Services. From there, go into each app that is running and check it's settings.

    This is the only alternative I can think of before wiping and re-installing each app back to the phone to pinpoint the problem. Hope this helps.
    04-13-2011 10:10 PM
  3. FreudSlipped's Avatar
    ToggleSettings seems to be a likely culprit. It has plenty of settings and rules to change things up. Have you tried clearing the app data and cache, then deleting it?
    ToggleSettings does have a Google group. The most recent post is in reference to a problem a bit on the opposite side of the fence from yours; His brightness setting is supposed to be 0 in certain circumstances but, it ends up going to 40% instead.
    04-13-2011 11:02 PM
  4. Hardcase's Avatar
    I figured it out. It was not a dock issue it was a power issue. In Battery Manager and then Battery Mode I has selected "Maximum battery saver." in the info screen it says that when not connected to a charger it dims the display. Thus, this was the nasty culprit. The phone is now set to "performance mode." Problem solved.

    On a side note, I figured it out when I turned my car off and the screen dimmed while the phone was still in the dock. That got me thinking about power settings. At work, I tested the theory by just plugging in and unplugging the phone. The assumption that it had to do with a dock was a false one. Since my phone is almost always in a dock (car or desk), it was a logic leap that missed its target.

    So, it was not a third party app, it was Battery Manager built into the Droid 2.

    Thanks for the suggestions. They got me thinking more creatively and set me on the path to question my assumptions.
    04-15-2011 06:09 PM
  5. FreudSlipped's Avatar
    I appreciate your follow up post with results and happy you found the culprit. Never having touched a Droid 2, I had no idea that Maximum battery saver settings existed. LOL
    04-15-2011 11:54 PM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD