1. anon(10170251)'s Avatar
    Hello all!

    Since a while I'm testing UAE4ALL2 and UAE4ARM Amiga emulators for Android.
    Lots of questions came up using and comparing them in several months and I hope to find some answers to them in this forum.
    Also it seems there are still some bugs and things that need to be improved or at least I want to know if other users have similar problems with their emulators.

    The versions I tested are UAE4ALL2 and UAE4ARM
    I mostly played GODS and SUPER CARS II which turned out to be best for use with the emulators.

    Here's some 'report' of testing them...


    Has no stereo separation and collision detection setting

    Autofire only available through control presets, not definable for custom control buttons

    Autofire buttons and normal fire buttons exist separately (shortly tapping autofire buttons doesn't trigger fire)

    Autofire 'medium' is in fact 'heavy' and 'heavy' doesn't do anything

    Adding 0,5 MB slow ram causes Speedball 2 to crash when 'loading game'

    What exactly is 'vsync'?


    Lower performance in lots of parts of many demos

    Slightly lower performance with lots of games especially when games are accessing Amiga disks

    No additional button size setting like in UAE4ALL2 (see both emulators, device configuration's on screen keyboard size)

    Autofire 'medium' and 'fast' are both the same ('fast')

    When using the dpad as mouse, mouse speed 0,25 does nothing, only from 0,5 on the mouse speeds are supported

    Virtual keyboard permanently changes from visible/invisible when about to enter a name for a custom configuration file

    Playing Gods 'fast copper' setting causes background colour to change to green in some frames

    When port0 and port1 are both set to 'none' and there are defined
    two custom buttons for each 'mouse button left' (button 'A')
    and 'mouse button right' ('button B'):
    If you tap button 'A', no left mouse click is triggered,
    port0 is suddenly automatically set to 'nubs as mouse' and only now
    tapping button 'A' again triggers a left mouse click.
    The same with button 'B' and port1:
    If I tap button 'B' port1 now is set to 'nubs as mouse' and tapping
    button 'B' only now really triggers a right mouse click!

    When running 'World of Commodore Amiga' demo from Sanity:
    The first effect (zoom of logo) is accelerated with 'fast copper' on.

    In menu (chosing directory/file) some unicode characters (Ü for example) are not supported

    'JIT' slows down emulation instead of improving performance


    No manual

    Amiga disks always not write protected

    Device configuration's left mouse click setting 'hold at the same spot' seems not to work sometimes or conflicts with 'tap delay' setting

    Don't understand device configuration's 'relative mouse movement', 'video settings' and 'multiple touch events per video frame'

    Device configuration's 'on screen keyboard/button images size' is always one level smaller than it should be (large is in fact medium)
    Only if you use UAE4ALL2's button size setting, large is really large (UAE4ARM does not have this option, so 'medium' size buttons are the largest with that emulator)

    When playing the game 'GODS':
    If player positioned in the right part of the screen looking to the right or positioned in the left part of the screen looking to the left:
    Autofire triggers fire correctly (no pauses between firing)
    If player positioned in the right part of the screen looking to the left or positioned in the left part of the screen looking to the right:
    Autofire triggers 3 times fire - pause - 3 times fire - pause...

    Floppy drive speed x 2/8 etc. slows down emulation significantly

    That's it.

    Finally, some information about my Phone:

    Samsung Galaxy J1 (J100H)
    Device: j13g
    Board: sc7727s
    Hardware: sc8830
    Processor: ARMv7 Processor rev 5 (v7l)
    Instruction sets: armeabi-v7a, armeabi
    CPU features: swp half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt
    CPU hardware: sc8830
    Cores: 2
    Clock speed: 768 MHz - 1200 MHz
    Resolution: 480 x 800 pixel
    Density: 240 dpi (hdpi)
    Refresh rate: 60.001 Hz
    RAM: 452,9 MB
    Android: 4.4.4 KITKAT, API level 19
    Kernel: Linux, armv7l, 3.10.17-1042529
    Android runtime: Dalvik 1.6.0
    Not rooted

    Thanks for reading, hope to get some positive reactions...
    03-19-2017 08:23 AM

Similar Threads

  1. How do i attach a screenshot to ask a question?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-19-2017, 05:11 AM
  2. Replies: 2
    Last Post: 03-18-2017, 07:03 PM
  3. Email question.
    By alarsen7 in forum Google Pixel & Pixel XL
    Replies: 2
    Last Post: 03-18-2017, 04:09 PM
  4. Replies: 0
    Last Post: 03-18-2017, 02:18 PM
  5. Dark Theme question.
    By bandofbrothers2112 in forum Samsung Galaxy S7 edge
    Replies: 4
    Last Post: 03-18-2017, 11:04 AM