1. atomD21's Avatar
    Has anyone had the speedtest app stop working after the newest update? Mine lets me click begin test and then does nothing, making the Force Close dialog pop up after a minute.
    04-19-2011 04:22 PM
  2. jackmei2's Avatar
    I just tried it out and it worked fine for me on a few tests.
    04-19-2011 05:01 PM
  3. skiddingus's Avatar
    I have the same problem. It freezes and force closes as soon as you hit "start test" on both of my Fascinates running Froyo. I loved that app until yesterday's update.
    04-19-2011 05:07 PM
  4. Blennidae's Avatar
    I had the same problem with the force closing. I uninstalled and reinstalled it from the market and it seems to be working now. However doing so it lost the record of all my previous speed tests. Oh well. I preferred the old version to the new one as well. I probably should have waited to hear if there were any issues before upgrading.
    04-19-2011 06:22 PM
  5. atomD21's Avatar
    Update: The uninstall reinstall combo worked for me. They screwed something up...
    04-19-2011 08:28 PM
  6. skiddingus's Avatar
    Reinstall didn't work for either of my phones. Still force closing on "begin test"
    04-19-2011 08:44 PM
  7. starbiker99's Avatar
    Working fine on my SC 2.9.2 Fascinate and my wife's stock one.
    04-19-2011 10:40 PM
  8. atomD21's Avatar
    I spoke too soon. I uninstalled and restored my backup of the older version.
    04-19-2011 10:59 PM
  9. RUSH's Avatar
    I found out that prior to doing a speed test - first update "data profile", you should then get a better performance. (Connection speed wise)

    If at anytime you experience any (glitches) in an app after an update, either clear data, and /or cache - or uninstall /reinstall the application in question.
    04-20-2011 10:17 AM