11-16-2015 12:23 PM
692 ... 89101112 ...
tools
  1. snrb_labs's Avatar
    A small note to follow up on what I just posted... I have (somewhat happily) discovered that if I plug in a wired headset into the 1/8" mini jack, then everything works perfectly with "factory default" GrooVe IP settings (no "Audio Mode Fallback", no "Audio Processing"). Obviously what has happened is that the incoming audio is routed to the earbuds (instead of the speakerphone) which eliminates the feedback echo.

    So... if the speakerphone issue on the Intercept can be solved (I'd prefer using the app without the earbuds), then I would be thrilled. For now I'll keep the wired earbuds handy for incoming(/outgoing) VoIP calls.

    Thanks in advance for your consideration.

    cheers.
    Unfortunately we've been unable to find any solution for the Intercept. The closest we've gotten is sound coming out the ear speaker but then the mic stops functioning.
    07-15-2011 07:10 AM
  2. UWPVIOLATOR's Avatar
    Alright having problems with Echo and loudness for the receiver of the call. When I turn down mic gain the echo goes away but my voice becomes to low to hear. Then if I lower speaker volume echo slightly goes away but then I can barley hear them.

    I have a Droid INC and would like some advice on how to exactly setup the settings. Also if you could talk on the phone with me to test settings as I don't have another phone to test with.
    07-15-2011 10:48 AM
  3. snrb_labs's Avatar
    Alright having problems with Echo and loudness for the receiver of the call. When I turn down mic gain the echo goes away but my voice becomes to low to hear. Then if I lower speaker volume echo slightly goes away but then I can barley hear them.

    I have a Droid INC and would like some advice on how to exactly setup the settings.
    I'd lower both mic gain and speaker volume. Don't only lower one or the other. A combination of both should maintain audible voice and reduce echo. You can also try enabling both incoming and outgoing audio processing in the GrooVe IP troubleshooting settings.
    07-15-2011 11:00 AM
  4. UWPVIOLATOR's Avatar
    I'd lower both mic gain and speaker volume. Don't only lower one or the other. A combination of both should maintain audible voice and reduce echo. You can also try enabling both incoming and outgoing audio processing in the GrooVe IP troubleshooting settings.
    I have messes with the setting to much is there a way to reset them? If not what should be on and what levels should be default?
    07-15-2011 11:19 AM
  5. xur17's Avatar
    First of all - I love the app. I bought it within ten minutes of setting up my new phone. The voice quality seems to be pretty good. Better than my n900 via sip.

    I have two wifi AP in my house to cover both floors. If I walk between the two floors during a call (which actually happens a decent amount), when it decides to switch to the other AP it drops the call (the GV icon in the notifications bar goes red for a few seconds, and then goes green when it reregisters).
    - Edit: This might actually be out of your control since the wifi icon temporarily goes white and then back to green (like it is re-establishing the connection to google). The issue mentioned below is still valid though.

    Also, when this happens (also quite possibly anytime a call is disconnected due to the internet connection) I have to completely exit and restart groove ip or I when I attempt to adjust the volume on my phone (in a media player, or the ringer volume) the in-call volume is instead adjusted.
    07-15-2011 11:45 AM
  6. snrb_labs's Avatar
    I have messes with the setting to much is there a way to reset them? If not what should be on and what levels should be default?
    -2 mic gain and 0 speaker volume are the default. In troubleshooting the default is to have all the checkboxes unchecked.
    07-15-2011 11:56 AM
  7. snrb_labs's Avatar
    First of all - I love the app. I bought it within ten minutes of setting up my new phone. The voice quality seems to be pretty good. Better than my n900 via sip.

    I have two wifi AP in my house to cover both floors. If I walk between the two floors during a call (which actually happens a decent amount), when it decides to switch to the other AP it drops the call (the GV icon in the notifications bar goes red for a few seconds, and then goes green when it reregisters).
    - Edit: This might actually be out of your control since the wifi icon temporarily goes white and then back to green (like it is re-establishing the connection to google). The issue mentioned below is still valid though.

    Also, when this happens (also quite possibly anytime a call is disconnected due to the internet connection) I have to completely exit and restart groove ip or I when I attempt to adjust the volume on my phone (in a media player, or the ringer volume) the in-call volume is instead adjusted.
    Hi,

    Don't think anything can be done about moving between floors. But, are you using version 1.1.8 of the app? That should re-sign in properly. But we haven't done much testing with a connection drop during a call, will take a look.
    07-15-2011 11:58 AM
  8. xur17's Avatar
    Hi,

    Don't think anything can be done about moving between floors. But, are you using version 1.1.8 of the app? That should re-sign in properly. But we haven't done much testing with a connection drop during a call, will take a look.
    Yep, it's version 1.1.8. It re-signs in fine, but in the process of doing that it kills the call. On my Nokia phone, when I would switch between the two access points, the call would just drop out for a few seconds, and then continue again once it was connected to the new one. - Actually I just tested a sip connection, and the call also dropped out for me. This is definitely an android thing.
    07-15-2011 12:30 PM
  9. 711eri's Avatar
    Hello there, i am on a samsung instinct VM, got the app to work, but it echos, now the other line can not hear any voice, and it is on a very long delay. I have play around with all the functions on the app to get it to this point, but this is the best i can get it to? Help please!
    07-15-2011 03:46 PM
  10. snrb_labs's Avatar
    Hello there, i am on a samsung instinct VM, got the app to work, but it echos, now the other line can not hear any voice, and it is on a very long delay. I have play around with all the functions on the app to get it to this point, but this is the best i can get it to? Help please!
    Hey, WiFi or 3G? Which settings have you tried and in what combination?
    07-15-2011 03:49 PM
  11. 711eri's Avatar
    Hey, WiFi or 3G? Which settings have you tried and in what combination?
    Hello there, I am using 3g.my current setting areoutgoing audio process on, incoming audio process on.audio routing on, audio mode feedback on,mic buffer is on medium, I believe those are the only things I have played with. I would definitely appreciate the help. Thanks
    07-16-2011 02:31 PM
  12. snrb_labs's Avatar
    Hello there, I am using 3g.my current setting areoutgoing audio process on, incoming audio process on.audio routing on, audio mode feedback on,mic buffer is on medium, I believe those are the only things I have played with. I would definitely appreciate the help. Thanks
    Turn off audio routing. I'd try increasing the mic buffer to x-large. You can also change the gain settings to reduce echo. Lowering the mic gain and speaker volume. The app requires at least 90kbps upload and download to function properly. The speed and quality of your 3G connection will play a very big role in your call quality. Any latency will cause delay.
    07-16-2011 04:22 PM
  13. 711eri's Avatar
    Turn off audio routing. I'd try increasing the mic buffer to x-large. You can also change the gain settings to reduce echo. Lowering the mic gain and speaker volume. The app requires at least 90kbps upload and download to function properly. The speed and quality of your 3G connection will play a very big role in your call quality. Any latency will cause delay.
    Hey there, so i did as you said and it seemed to get better, there was no echo on the other end, its semmed like no delay, the volume was good, only thing was that the person on the other end could not hear me now. I check upload speed and came in at 109. I tried to play with the settings some more and seems to have made it worse again. Very choppy on other end, delay, and still can not hear on other end. thanks
    07-17-2011 09:29 AM
  14. 711eri's Avatar
    Hey there, so i did as you said and it seemed to get better, there was no echo on the other end, its semmed like no delay, the volume was good, only thing was that the person on the other end could not hear me now. I check upload speed and came in at 109. I tried to play with the settings some more and seems to have made it worse again. Very choppy on other end, delay, and still can not hear on other end. thanks
    Sorry to bug you, but was just wondering if you had any more suggestions on how to get the app to work? Thank you in advance.
    07-18-2011 02:32 PM
  15. snrb_labs's Avatar
    Sorry to bug you, but was just wondering if you had any more suggestions on how to get the app to work? Thank you in advance.
    Hi, it seems like you're on the edge for network. I'm thinking a lot of the issues are network related. Are you able to connect to a wifi access point and try it? We can figure out which settings work best when connected to WiFi since that will eliminate network problems.
    07-18-2011 03:05 PM
  16. Scooter_In_MN's Avatar
    Newbie question. I just signed up for Goggle Voice because I travel a lot. Does it use the WiFi by default when its enabled for calls or do i have to specify some how? I have Sprint and its not clear how to call with my Sprint account vs. the Goggle account.
    07-19-2011 04:52 AM
  17. mudd77's Avatar
    snrb_labs,

    I have been using the GrooVe IP app for awhile now and like it a lot. I am having one issue though. On pretty much all incoming calls my phone only rings once and then goes to voice mail by the time I pick it up. When I call the person back they say that the phone rang 5 or more times. I have played with all of the app settings and even forwarded the appropriate ports listed on your website and still no luck. Any suggestions? Like I said before, I really like the app and for my outgoing calls I am not experiencing any issues. Thanks in advance.

    Set-Up:
    Phone: LG Optimus V
    Use GrooVe IP app over wifi only (25Mbs down / 1Mbs up)
    In my Google Voice account, I have call forwarding set to Google Chat and do not have calls forwarded to my mobile phone.
    No power saving mode (when the screen turns off) used.
    Currently have the Audio Routing, Audio Mode Fallback and the the Incoming & Outgoing Audio Processing boxes checked.


    UPDATE:
    After some more testing, it seems that it is indeed the screen timing out on my phone that is causing me to miss my calls. I just had multiple people call me with the screen left on and everything worked fine. Hmmmm, now I need to figure out a way around this, as I don't won't to leave my screen on all the time.
    07-19-2011 11:57 AM
  18. snrb_labs's Avatar
    snrb_labs,

    I have been using the GrooVe IP app for awhile now and like it a lot. I am having one issue though. On pretty much all incoming calls my phone only rings once and then goes to voice mail by the time I pick it up. When I call the person back they say that the phone rang 5 or more times. I have played with all of the app settings and even forwarded the appropriate ports listed on your website and still no luck. Any suggestions? Like I said before, I really like the app and for my outgoing calls I am not experiencing any issues. Thanks in advance.

    Set-Up:
    Phone: LG Optimus V
    Use GrooVe IP app over wifi only (25Mbs down / 1Mbs up)
    In my Google Voice account, I have call forwarding set to Google Chat and do not have calls forwarded to my mobile phone.
    No power saving mode (when the screen turns off) used.
    Currently have the Audio Routing, Audio Mode Fallback and the the Incoming & Outgoing Audio Processing boxes checked.


    UPDATE:
    After some more testing, it seems that it is indeed the screen timing out on my phone that is causing me to miss my calls. I just had multiple people call me with the screen left on and everything worked fine. Hmmmm, now I need to figure out a way around this, as I don't won't to leave my screen on all the time.
    Hi,

    Go into your battery/power profile and change your wifi to never sleep. By default it's likely going to sleep when the screen turns off.
    07-19-2011 01:53 PM
  19. mudd77's Avatar
    Hi,

    Go into your battery/power profile and change your wifi to never sleep. By default it's likely going to sleep when the screen turns off.
    Yeah, I had already done that when I first got my phone. Anyway, I'm fine with leaving the screen on for now when I am at home. I can just turn the brightness setting all the way down to conserve battery. Thanks.
    07-20-2011 10:11 AM
  20. snrb_labs's Avatar
    Yeah, I had already done that when I first got my phone. Anyway, I'm fine with leaving the screen on for now when I am at home. I can just turn the brightness setting all the way down to conserve battery. Thanks.
    Ok. No problem.
    07-20-2011 09:16 PM
  21. Koui's Avatar
    I'm curious, is there a way to disable the 'search contacts' dialog box when pressing the contacts button? The on screen keyboard pops up every time and I'd rather use the scroll bar to find who to call. Thanks.
    07-21-2011 11:23 PM
  22. snrb_labs's Avatar
    I'm curious, is there a way to disable the 'search contacts' dialog box when pressing the contacts button? The on screen keyboard pops up every time and I'd rather use the scroll bar to find who to call. Thanks.
    You can hit the back button to get rid of the keyboard. That's about the only option right now.
    07-22-2011 08:41 AM
  23. Koui's Avatar
    You can hit the back button to get rid of the keyboard. That's about the only option right now.
    Thanks, that's what I've been doing. An option in Miscellaneous settings to disable the search in a future revision of GVIP would be nice, but if I'm the only user that's requested it, it's no biggie.
    07-22-2011 09:00 AM
  24. snrb_labs's Avatar
    Thanks, that's what I've been doing. An option in Miscellaneous settings to disable the search in a future revision of GVIP would be nice, but if I'm the only user that's requested it, it's no biggie.
    Will write it down. Should be easy enough I think.
    07-22-2011 10:01 AM
  25. xur17's Avatar
    I have been having trouble with the audio latency in the call being bad (random 4 second pauses and stuff). I finally figured out that this was caused by my wifi. I tried pinging my phone, and noticed that the latency was increasing and becoming a lot more "jittery" when the screen turned off (probably due to some power saving mode).

    The leave screen on button works well for me (yes I have the leave wifi on when screen off setting on). As long as the screen is on, I get ~2ms pings. It would spike up to as high as 4000ms when the screen turned off.

    Just a hint for people in case they are having trouble. This is on a TMobile Nexus S.
    07-22-2011 11:17 AM
692 ... 89101112 ...

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD