11-16-2015 12:23 PM
692 ... 910111213 ...
tools
  1. snrb_labs's Avatar
    I have been having trouble with the audio latency in the call being bad (random 4 second pauses and stuff). I finally figured out that this was caused by my wifi. I tried pinging my phone, and noticed that the latency was increasing and becoming a lot more "jittery" when the screen turned off (probably due to some power saving mode).

    The leave screen on button works well for me (yes I have the leave wifi on when screen off setting on). As long as the screen is on, I get ~2ms pings. It would spike up to as high as 4000ms when the screen turned off.

    Just a hint for people in case they are having trouble. This is on a TMobile Nexus S.
    Most HTC phones have the same issue with WiFi. That's why we added the keep screen alive checkbox
    07-22-2011 11:21 AM
  2. xur17's Avatar
    Most HTC phones have the same issue with WiFi. That's why we added the keep screen alive checkbox
    I haven't had any issues yet, but does anyone had a problem with their face bumping buttons when the screen is left on?
    07-22-2011 12:25 PM
  3. xur17's Avatar
    Does Groove IP include echo cancellation code? When I talk to another person, they hear an echo of themselves a few seconds after they talk. I tried turning the volume down, but this didn't help (even when I had it quiet enough that I could barely hear the other person on the line).

    edit: Here's a post by the guys that made csipsimple about how to enable echo cancellation: http://code.google.com/p/csipsimple/...ail?id=119#c38
    07-23-2011 01:00 PM
  4. snrb_labs's Avatar
    Does Groove IP include echo cancellation code? When I talk to another person, they hear an echo of themselves a few seconds after they talk. I tried turning the volume down, but this didn't help (even when I had it quiet enough that I could barely hear the other person on the line).

    edit: Here's a post by the guys that made csipsimple about how to enable echo cancellation: Issue 119 - csipsimple - Echo problems tracking issue - SIP application for Android devices - Google Project Hosting
    You can reduce echo by lowering the mic gain and speaker volume. It's a combination of both that will do it.

    We are working on integrating the speex echo canceler, it's the same one that I believe csipsimple uses.

    The new android api's that allow you to use the device echo canceler aren't available until Honeycomb.
    07-23-2011 04:15 PM
  5. pacolococt's Avatar
    I love this app and was well worth the $4. I haven't had any major problems on the Optimus V yet but I do have a couple of questions. When I have my phone idle (screen is off etc.) and I receive a call through my GV number to my cell the majority of the time it will do a half ring and then go right to voice mail so I can see that I missed a call but don't have time to answer it. If I have the screen active it rings on my cell right away like it should. This isn't because the wifi is low. I click a button to activate the screen and I have full bars on wifi so that isn't the problem and I could be standing right next to my router and it would do the same thing. Is there any solution to this? Once I call the person back everything is fine but I would like to know someone is calling me sooner then right when it is going to voicemail. Also talking with 3g data instead of wifi is very difficult as there is a significant delay but I'm sure that is more on Virgin then your app. Thanks for any help in advance.
    07-24-2011 12:10 AM
  6. pacolococt's Avatar
    snrb_labs,

    I have been using the GrooVe IP app for awhile now and like it a lot. I am having one issue though. On pretty much all incoming calls my phone only rings once and then goes to voice mail by the time I pick it up. When I call the person back they say that the phone rang 5 or more times. I have played with all of the app settings and even forwarded the appropriate ports listed on your website and still no luck. Any suggestions? Like I said before, I really like the app and for my outgoing calls I am not experiencing any issues. Thanks in advance.

    Set-Up:
    Phone: LG Optimus V
    Use GrooVe IP app over wifi only (25Mbs down / 1Mbs up)
    In my Google Voice account, I have call forwarding set to Google Chat and do not have calls forwarded to my mobile phone.
    No power saving mode (when the screen turns off) used.
    Currently have the Audio Routing, Audio Mode Fallback and the the Incoming & Outgoing Audio Processing boxes checked.


    UPDATE:
    After some more testing, it seems that it is indeed the screen timing out on my phone that is causing me to miss my calls. I just had multiple people call me with the screen left on and everything worked fine. Hmmmm, now I need to figure out a way around this, as I don't won't to leave my screen on all the time.
    Woops should have read the previous page before posting lol. Seems that I am not the only one with this problem. Hopefully there is a solution coming as leaving the screen on is not a good idea for me. Also where is the option to not have wifi sleep on this phone? I cannot find a power/battery profile. Sorry first smartphone.
    07-24-2011 12:19 AM
  7. pacolococt's Avatar
    I found the wifi sleep policy under Home, Menu, Settings, Wireless & Network, Wi-Fi Settings
    Click the Menu button and select "Advanced". I changed to never and the phone still doesn't ring until it is going to voicemail but if I leave the screen on its perfect. Very weird.
    07-24-2011 12:58 AM
  8. snrb_labs's Avatar
    I found the wifi sleep policy under Home, Menu, Settings, Wireless & Network, Wi-Fi Settings
    Click the Menu button and select "Advanced". I changed to never and the phone still doesn't ring until it is going to voicemail but if I leave the screen on its perfect. Very weird.
    Generally HTC phones have that issue, but you don't have a HTC phone. Where no matter what the setting in yoru power profile the wifi still goes into a power saving mode when the screen is off. There are a few apps on the market that claim to fix the issue. Might be worth trying one of those out. Think there is a free one called WiFi Fixer. Don't have any personal experience with any of them though.
    07-24-2011 10:10 AM
  9. xur17's Avatar
    You can reduce echo by lowering the mic gain and speaker volume. It's a combination of both that will do it.

    We are working on integrating the speex echo canceler, it's the same one that I believe csipsimple uses.

    The new android api's that allow you to use the device echo canceler aren't available until Honeycomb.
    The third bullet point in this post mentions the new audio mode: MODE_IN_COMMUNICATION that is available in Android 3.0, and as a private api on some android 2.3 devices (a couple people said it works on the Nexus S devices). This is supposed to make the device use the hardware echo cancellation. I would be interested to see if this would fix the wifi issue too (having to keep the screen on to make a call).

    I'm not sure how hard it is to implement this, but if you need someone to test it, I am more than willing to.
    07-24-2011 10:29 AM
  10. snrb_labs's Avatar
    The third bullet point in this post mentions the new audio mode: MODE_IN_COMMUNICATION that is available in Android 3.0, and as a private api on some android 2.3 devices (a couple people said it works on the Nexus S devices). This is supposed to make the device use the hardware echo cancellation. I would be interested to see if this would fix the wifi issue too (having to keep the screen on to make a call).

    I'm not sure how hard it is to implement this, but if you need someone to test it, I am more than willing to.
    The in communication audio mode won't fix the wifi issue. That would get fixed by the high perf wifi lock. We added support for that wifi lock already, but it's a 3.0 api. We still try and get the lock on any gingerbread device as well.

    We won't be trying to change the audio mode for a little while, at least till after the next update.
    07-24-2011 10:52 AM
  11. pacolococt's Avatar
    Generally HTC phones have that issue, but you don't have a HTC phone. Where no matter what the setting in yoru power profile the wifi still goes into a power saving mode when the screen is off. There are a few apps on the market that claim to fix the issue. Might be worth trying one of those out. Think there is a free one called WiFi Fixer. Don't have any personal experience with any of them though.
    Thanks for the help. Wifi fixer did nothing to help. I then tried an app called advanced wifi lock. It seems that it may have fixed the problem. I called my GV number with the screen off and it rang within the first 2 rings on my cell. Anyone else using the optimus v may want to try this app. If this is only a temporary fix I will let everyone know. Thanks again.
    07-24-2011 03:04 PM
  12. snrb_labs's Avatar
    Thanks for the help. Wifi fixer did nothing to help. I then tried an app called advanced wifi lock. It seems that it may have fixed the problem. I called my GV number with the screen off and it rang within the first 2 rings on my cell. Anyone else using the optimus v may want to try this app. If this is only a temporary fix I will let everyone know. Thanks again.
    Thanks for the update!
    07-24-2011 03:57 PM
  13. knightshade's Avatar
    Purchased and started to play with it.

    Couple of minor things that I emailed in about (and got a reply within an hour):
    - Dialpad button doesn't toggle to "Hide" like the default dialer
    - Wired Headset mute button doesn't toggle mute when using Groove IP

    Overall - pretty happy with the app.
    There is a delay when using it - but I have a huge number of conference calls that I connect to and only listen.
    This looks to be a good way to save minutes.
    07-25-2011 09:37 AM
  14. EwanG's Avatar
    Thanks for the help. Wifi fixer did nothing to help. I then tried an app called advanced wifi lock. It seems that it may have fixed the problem. I called my GV number with the screen off and it rang within the first 2 rings on my cell. Anyone else using the optimus v may want to try this app. If this is only a temporary fix I will let everyone know. Thanks again.
    I notice that the listing mentions that it can use up battery if used all the time. How bad does it appear to be in your use?
    07-26-2011 12:54 AM
  15. cherryblossom's Avatar
    I've had this app for a little while and definitely think it's a great one. I use Google Voice VoIP constantly, so this is perfect for me.
    07-26-2011 01:19 AM
  16. dchawk81's Avatar
    Newbie question. I just signed up for Goggle Voice because I travel a lot. Does it use the WiFi by default when its enabled for calls or do i have to specify some how? I have Sprint and its not clear how to call with my Sprint account vs. the Goggle account.
    Assuming you kept them separate, Google via Groove will use WiFi if it's connected. If you tick the settings box in Groove, 4G will be used when WiFi is off and if 4G is off then 3G will be used. If you're on 2G (it works on roaming too, I just tried it), that's what will be used. If you leave the box unticked, it will only connect if you're on WiFi. Google Voice by itself without Groove uses the mobile voice network, which isn't 2G, 3G, 4G, or WiFi.

    Now that is how the connection itself is made.

    As for choosing which system to use to place a call, if you don't enable Groove as the default system for all calls in the settings, a little popup will let you choose when you dial with the main dialer or you can use the Groove app dialer for Groove calls. If you do enable Groove as the default, then it will automatically use Groove when you use the main dialer and the Groove app dialer.
    07-26-2011 03:52 AM
  17. dchawk81's Avatar
    Is it possible to allow the user to choose whether inbound calls are mobile network or Groove just like outbound?
    07-26-2011 07:00 AM
  18. snrb_labs's Avatar
    Is it possible to allow the user to choose whether inbound calls are mobile network or Groove just like outbound?
    The only setting for that is the call forwarding setting in your google voice account (google.com/voice). If you forward to google chat, GrooVe IP will receive it. If you forward to your cell, your mobile network will receive it. If you forward to both, both will ring. In the next update we've made a change so the GrooVe IP incoming call screen shows on top of the native one. But that will only work if your phone still has a data connection (or WiFi) when on a mobile phone call
    07-26-2011 07:33 AM
  19. dchawk81's Avatar
    The only setting for that is the call forwarding setting in your google voice account (google.com/voice). If you forward to google chat, GrooVe IP will receive it. If you forward to your cell, your mobile network will receive it. If you forward to both, both will ring. In the next update we've made a change so the GrooVe IP incoming call screen shows on top of the native one. But that will only work if your phone still has a data connection (or WiFi) when on a mobile phone call
    I kinda got that by good ol' fashioned trial & error. I did manage to see a Groove overlay every so often but it was a bit of a fluke...I believe it happened when I was first signed in, because subsequent incoming calls would go straight to the default incoming screen without the overlay or simulring.

    I want incoming to be VoIP all the time unless I have zero data connectivity in which case I'll take the network as a backup system. If that's what you mean by "on top of" then that would be perfect.
    07-26-2011 07:53 AM
  20. cizastro's Avatar
    I've heard of some phones having issues with speakerphone. I was looking into getting a cheap Huawei Ascend so that I could take this phone on overseas trips and was wondering if anybody has used GrooveIP with a Huawei Ascend. If anybody could weigh in I'd greatly appreciate it.
    07-26-2011 06:15 PM
  21. dchawk81's Avatar
    I had a major issue a bit ago. A call came in...but instead of an answer button next to an ignore button, all I had was an ignore button the size of both. Is that because it was my mother?

    In all seriousness, that's a huge problem. If it wasn't my mother I'd have been more frustrated than I was...and possibly screwed out of a customer. Any idea what would cause that?

    Another issue I'm having is with Bluetooth. It doesn't connect properly, but I have no idea how or why.
    07-27-2011 11:35 AM
  22. snrb_labs's Avatar
    I had a major issue a bit ago. A call came in...but instead of an answer button next to an ignore button, all I had was an ignore button the size of both. Is that because it was my mother?

    In all seriousness, that's a huge problem. If it wasn't my mother I'd have been more frustrated than I was...and possibly screwed out of a customer. Any idea what would cause that?

    Another issue I'm having is with Bluetooth. It doesn't connect properly, but I have no idea how or why.
    The ignore button comes up first when Google voice sends the call. The answer button appears when signalling is completed. Generally those two steps happen very quickly and you don't notice the intermediate step. But if signalling fails you could get only the ignore button, after a few seconds the call will drop. It can happen if the person calling hangs up right after Google Voice sends the initial incoming call message.
    07-27-2011 11:44 AM
  23. dchawk81's Avatar
    Well she didn't hang up. She rang through to voice mail and left a message.

    What exactly do you mean when you say "signalling"?
    07-27-2011 11:46 AM
  24. snrb_labs's Avatar
    Well she didn't hang up. She rang through to voice mail and left a message.

    What exactly do you mean when you say "signalling"?
    Generally on a voip call there are a few different types of traffic. Voice traffic is the most obvious but there's also call control and signalling. For each call, signalling information is exchanged. Like notifying the other side that a call is being initiated. Then some negotiation on ports and codecs. Without looking at logs I don't know what caused your incoming call to fail.
    07-27-2011 12:08 PM
  25. dchawk81's Avatar
    Oh okay. I got the ringtone and the screen, just not the answer button. I don't know if that helps narrow it down at all.
    07-27-2011 12:12 PM
692 ... 910111213 ...

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD