11-16-2015 12:23 PM
692 ... 1112131415 ...
tools
  1. dchawk81's Avatar
    We're playing around with what we can do for the dual incoming call issue. The problem is the native call system will ring as soon as it gets a call. So can't really control when it takes focus. Might be able to reduce the time before GrooVe IP comes back on top. Also thinking of adding a config or an option so you can go back to the native screen if you don't want to pick up from GrooVe IP.

    We're looking at the call connect delay. There's a bunch of different possible causes. So there is some chance we'll be able to influence it. If it's completely caused by delays on the Google side or latency then there's not much we can do. Should know more as we look more into it. But again it's a tricky problem because it doesn't happen on every network or every device.

    And I appreciate your feedback. I know we won't always make decisions that everyone agrees with but it helps to get different view points. We try and pay close attention to what our users are telling us.
    Is there perhaps a way to get the native dialer to use GrooVe's protocols, or is it totally locked down? Personally, I wouldn't even mind if GrooVe was made to replace the native dialer for all calls. Maybe I'm not alone. Perhaps you could get away with making GrooVe a complete dialer replacement app, assuming it's technically possible. You could charge more for it too, especially if it's slicker than anything else on phones by default.

    For the connection issue, can you make a menu option to eliminate the outgoing rings entirely for those having the problem? I would think then you'd just hear silence until the other person speaks. It could go under Troubleshooting like the other "if you're having problems" settings. I don't know what you could do for incoming though, since the recipient is expected to talk first.

    Just throwing some ideas out there, without having a clue what's actually codeable.
    08-02-2011 09:07 AM
  2. snrb_labs's Avatar
    Should have posted this on Friday when the update actually came out. But change log for 1.2.0 is below.

    1.2.0:
    - Echo canceler option
    - Config to disable updating the native call log
    - Obtain high perf wifi lock only during a call. Option to always obtain while app is running
    - Add call filtering options (include number, exclude numbers, exclude prefix)
    - Fix GT-P1010 and Samsung Galaxy I9003. Requires Synchronize Voice option enabled
    - Show GrooVe IP incoming call screen on top of native incoming call screen as long as device maintains data connection
    - Bug fixes
    08-02-2011 09:25 AM
  3. wch_one's Avatar
    Can you detail what ringer conflict you are having? If you have calls forwarded to both your cell number and to google chat there's no way to avoid google voice sending the incoming call to both. If your device maintains it's data connection what should happen is GrooVe IP ring first, then the native phone system will begin ringing. Then after 2 seconds GrooVe IPs incoming call screen should come back on top. If your data disconnects when the native phone system is in use then GrooVe IP will be disconnected and won't continue ringing.
    Yup, that's issue I'm having. Disabling GV forwarding to the cell phone number won't work for me, since the lag with 3g is too much for me, and data coverage isn't reliable enough when out and about. In my experience, both ringers go at the same time but slightly offset, so there's a loud cacophony -- not good when I'm in public. There are times, like when I'm in an area with poor 3g or wi-fi service, where even if I could answer with GrooVe IP, I wouldn't want to, because the sound quality wouldn't be good enough. Having to answer it within the 2-second window to use the cell voice network isn't a useable solution.

    For my usage, it would be ideal to be able to choose when I go to answer the phone -- and also not have the dual ringer, of course, but I realize there may be technical roadblocks with that.


    Another feature that would be useful is to have GrooVe IP turn on only when the phone is in particular wi-fi networks. For example, I'd like to use it at home, but not when I'm at the office (the wi-fi signal is weak there and I have dropped calls over IP) or at a coffee shop.


    Edit: one more thing - it would be nice to have an option to disable the GrooVe IP ringer entirely. Right now, since I can't use it to receive calls, I've configured Google Voice to not forward calls to my Google Chat account. But this means I can never answer calls on my computer. What would be better is to still forward the calls to Google Chat, but configure it so GrooVe IP doesn't ring.

    Also, I just tested receiving calls forwarded to both GC and my phone number. For me, first the GrooVe IP ringer went for a couple seconds, and it gave me the option to answer with GrooVe IP. Then both ringers went, and the native phone answer screen took over. So it seems to be doing the reverse of what it's supposed to. I have a Virgin Mobile LG Optimus V.
    08-02-2011 11:02 AM
  4. snrb_labs's Avatar
    Yup, that's issue I'm having. Disabling GV forwarding to the cell phone number won't work for me, since the lag with 3g is too much for me, and data coverage isn't reliable enough when out and about. In my experience, both ringers go at the same time but slightly offset, so there's a loud cacophony -- not good when I'm in public. There are times, like when I'm in an area with poor 3g or wi-fi service, where even if I could answer with GrooVe IP, I wouldn't want to, because the sound quality wouldn't be good enough. Having to answer it within the 2-second window to use the cell voice network isn't a useable solution.

    For my usage, it would be ideal to be able to choose when I go to answer the phone -- and also not have the dual ringer, of course, but I realize there may be technical roadblocks with that.


    Another feature that would be useful is to have GrooVe IP turn on only when the phone is in particular wi-fi networks. For example, I'd like to use it at home, but not when I'm at the office (the wi-fi signal is weak there and I have dropped calls over IP) or at a coffee shop.


    Edit: one more thing - it would be nice to have an option to disable the GrooVe IP ringer entirely. Right now, since I can't use it to receive calls, I've configured Google Voice to not forward calls to my Google Chat account. But this means I can never answer calls on my computer. What would be better is to still forward the calls to Google Chat, but configure it so GrooVe IP doesn't ring.

    Also, I just tested receiving calls forwarded to both GC and my phone number. For me, first the GrooVe IP ringer went for a couple seconds, and it gave me the option to answer with GrooVe IP. Then both ringers went, and the native phone answer screen took over. So it seems to be doing the reverse of what it's supposed to. I have a Virgin Mobile LG Optimus V.
    There is a ringtone prefix in the app, you can set that to silent and then GrooVe IP won't have any audible ringtone.

    For the last issue where only the native screen showed, were you connected to WiFi? Don't believe the VM network can do voice and data at the same time.

    Will take a look at adding some WiFi network preferences.
    08-02-2011 12:40 PM
  5. Cyrus's Avatar
    Same problem with the HTC Touch Pro 2 - app keeps crashing after opening. Let me know if you find a solution.
    Has anyone with Touch Pro 2 gotten the app to work? Kindly let me know if it works and what you did. Wanted to be sure it works before I bought the app.

    TIA
    08-02-2011 02:23 PM
  6. wch_one's Avatar
    There is a ringtone prefix in the app, you can set that to silent and then GrooVe IP won't have any audible ringtone.

    For the last issue where only the native screen showed, were you connected to WiFi? Don't believe the VM network can do voice and data at the same time.
    I didn't find anything about a ringtone prefix, but in Settings->Audio/Echo Settings->Ringtone Override, I did find a way to make it silent. It actually was already set to Silent, so I'm not sure why they were both ringing -- but they were. I was connected to wi-fi when this happened.

    Will take a look at adding some WiFi network preferences.
    Great - that would be really useful.
    08-02-2011 03:53 PM
  7. snrb_labs's Avatar
    I didn't find anything about a ringtone prefix, but in Settings->Audio/Echo Settings->Ringtone Override, I did find a way to make it silent. It actually was already set to Silent, so I'm not sure why they were both ringing -- but they were. I was connected to wi-fi when this happened.



    Great - that would be really useful.
    Sorry I meant Ringtone Override. Not sure why I put prefix. By default, if it's never been set it will use the ringtone set for the system. Once you open the setting it will use whatever is set.
    08-02-2011 04:01 PM
  8. shobuddy's Avatar
    Is there a way to disable this app? Even though I'm exited out of the app, everytime I go into my native dialer, groove ip starts up and gives me the option to use it.
    08-03-2011 03:15 PM
  9. snrb_labs's Avatar
    Is there a way to disable this app? Even though I'm exited out of the app, everytime I go into my native dialer, groove ip starts up and gives me the option to use it.
    What version of the app do you have? Also what do you have the built in dialer preference set to?
    08-03-2011 03:23 PM
  10. shobuddy's Avatar
    What version of the app do you have? Also what do you have the built in dialer preference set to?
    Thanks! Duh, the built in dialer preferences did the trick. Not sure what version I have, where would I check?
    08-03-2011 03:26 PM
  11. snrb_labs's Avatar
    Thanks! Duh, the built in dialer preferences did the trick. Not sure what version I have, where would I check?
    If you haven't updated in the last week you won't have the latest. You can get updates from whichever market you purchased from. The help screen will show the version number at the top. Latest is 1.2.0
    08-03-2011 03:42 PM
  12. shobuddy's Avatar
    Thats where I had looked and my help screen does not show the version anywhere.
    08-03-2011 06:38 PM
  13. snrb_labs's Avatar
    Thats where I had looked and my help screen does not show the version anywhere.
    You've got an old version then. We added the app version to the top of the help screen a few versions ago.
    08-03-2011 06:44 PM
  14. dchawk81's Avatar
    Any luck cracking the connection delay problem?
    08-08-2011 03:16 AM
  15. snrb_labs's Avatar
    Any luck cracking the connection delay problem?
    Made one change that seems to reduce delay throughout the call by about 100-200 ms. That will be in the next update.

    Also found some android api's that instantiate the speaker and mic that are taking about 200 ms on slower devices. We may be able to move that initialization so it's not happening at connect. But that will require a lot more rework.
    08-08-2011 12:41 PM
  16. dchawk81's Avatar
    Maybe between those two it'll be more user friendly. Looking forward to it!
    08-08-2011 01:41 PM
  17. snrb_labs's Avatar
    Version 1.2.1:
    - New accessibility option to allow the Search button to hang up calls (under miscellaneous->accessibility)
    - Option to break out missed call notifications so each missed call is a new notification with caller id instead of just the missed call count
    - Allow + to be dialed from the GrooVe IP dialer
    - Add more options for dialing from the native dialer
    - New echo canceler option to auto detect the echo tail setting
    - Add images to the menu buttons
    08-10-2011 10:23 PM
  18. dchawk81's Avatar
    Made one change that seems to reduce delay throughout the call by about 100-200 ms. That will be in the next update.
    Is this a menu/configuration option in the latest update or is it "automatic" ie hardcoded?
    08-11-2011 03:20 AM
  19. snrb_labs's Avatar
    Is this a menu/configuration option in the latest update or is it "automatic" ie hardcoded?
    It's automatic. Not a config.
    08-11-2011 05:52 AM
  20. dchawk81's Avatar
    Hmm. Well calls themselves are better but the initial connection delay still makes this app unusable. When I call someone, they say hello twice and I don't hear the first one. Same thing happens for inbound calls. This can frustrate some people and make them hang up prematurely.

    By comparison, Skype is 100% seamless. When the person I call picks up, it's immediately connected and we're talking as if it's any normal phone call.
    08-11-2011 06:48 AM
  21. snrb_labs's Avatar
    Hmm. Well calls themselves are better but the initial connection delay still makes this app unusable. When I call someone, they say hello twice and I don't hear the first one. Same thing happens for inbound calls. This can frustrate some people and make them hang up prematurely.

    By comparison, Skype is 100% seamless. When the person I call picks up, it's immediately connected and we're talking as if it's any normal phone call.
    We still have the one other change planned. But again that will only reduce about 200ms. Skype controls both end points, gives them more flexibility and control.
    08-11-2011 01:00 PM
  22. dchawk81's Avatar
    I figured as much. I'm thinking this app won't really fit my needs, but I'll wait and see what that change does.
    08-11-2011 01:04 PM
  23. xur17's Avatar
    I like the auto tail setting feature. I have a quick question about it though - does that vary based on connection latency, or based on the phone (or both)?

    Also, can the other person hear the beep used to setup the echo tail?
    08-11-2011 06:43 PM
  24. snrb_labs's Avatar
    I like the auto tail setting feature. I have a quick question about it though - does that vary based on connection latency, or based on the phone (or both)?

    Also, can the other person hear the beep used to setup the echo tail?
    It's based on both. The other person, in most cases, will not hear the beep. If the beep bothers you, at the end of each call the detected echo tail is reported. You can use that to switch to the correct manual setting.
    08-11-2011 06:53 PM
  25. xur17's Avatar
    It's based on both. The other person, in most cases, will not hear the beep. If the beep bothers you, at the end of each call the detected echo tail is reported. You can use that to switch to the correct manual setting.
    I just did a few quick tests, and I couldn't hear the beep on the other end - it doesn't bother me, so I'll just leave it on.

    Two quick questions - does turning on echo cancellation increase the latency in the call? Does checking the post processing box along with the echo cancellation box increase latency anymore than just having echo cancellation on?

    Also, I think I found a bug - I am on a Nexus S, and when playing around with the echo cancellation settings, I noticed that if I mute the call in the Groove IP app, and end the call without unmuting it, it will remain muted for my next call (this also causes the automatic tail detection to fail). If I toggle the mute on then off, it is fixed though.
    08-11-2011 07:08 PM
692 ... 1112131415 ...

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD