11-16-2015 12:23 PM
692 ... 25262728
tools
  1. ed w's Avatar
    I have a stock Galaxy Note 2 from AT&T. I am using V.1.3.10 of Groove IP. Almost all of my phone calls have been terrible. I am getting frustrated as I want this work, but again yesterday on a call to my boss at work, she could not hear me very well. Very choppy audio. I have tried different settings but I can't seem to improve the quality. I even deleted the app and tried a competitor but the calls were no better. So I found this site and I re-downloaded Groove IP. Like I said, I want this to work.
    My Wifi connection is great,sitting right next to my router: 20.96 Mbps down, 11.3 up and 29ms ping. (courtesy of Speedtest.net).
    What do you suggest that I try and adjust first? Is there something that I need to definitely change in the stock settings? Anything on the phone?
    07-01-2013 03:48 PM
  2. snrb_labs's Avatar
    I have a stock Galaxy Note 2 from AT&T. I am using V.1.3.10 of Groove IP. Almost all of my phone calls have been terrible. I am getting frustrated as I want this work, but again yesterday on a call to my boss at work, she could not hear me very well. Very choppy audio. I have tried different settings but I can't seem to improve the quality. I even deleted the app and tried a competitor but the calls were no better. So I found this site and I re-downloaded Groove IP. Like I said, I want this to work.
    My Wifi connection is great,sitting right next to my router: 20.96 Mbps down, 11.3 up and 29ms ping. (courtesy of Speedtest.net).
    What do you suggest that I try and adjust first? Is there something that I need to definitely change in the stock settings? Anything on the phone?
    I'd recommend doing a clean install (uninstall the app, restart the device, then download and install the app) and enable Keep Screen On. Make sure your advanced android WiFi settings have WiFi set to stay connected always and WiFi optimization is off.
    07-02-2013 08:55 AM
  3. miguelco01's Avatar
    I have a nexus 4 with paranoid ROM and recently i started experiencing problems with groove ip. Incoming calls does not ring until the call has almost gone to voice mail, i went into the settings and check partial wake lock and high perf wifi lock, restarted the phone, etc and it didn't help at all.

    I decided to sign google hangouts off from my pc and the problem was fixed right away!!!

    I really need to have google hanouts on my pc on all the time, how can i have this solved?
    07-23-2013 10:13 AM
  4. snrb_labs's Avatar
    I have a nexus 4 with paranoid ROM and recently i started experiencing problems with groove ip. Incoming calls does not ring until the call has almost gone to voice mail, i went into the settings and check partial wake lock and high perf wifi lock, restarted the phone, etc and it didn't help at all.

    I decided to sign google hangouts off from my pc and the problem was fixed right away!!!

    I really need to have google hanouts on my pc on all the time, how can i have this solved?
    I've never run into that before. When I use Google Hangouts I get the call on both my phone and the laptop at the same time. Does the issue come back if you sign into hangouts? Does it make a difference if your phone screen is on or off when the call comes in?
    07-23-2013 12:18 PM
  5. miguelco01's Avatar
    I've never run into that before. When I use Google Hangouts I get the call on both my phone and the laptop at the same time. Does the issue come back if you sign into hangouts? Does it make a difference if your phone screen is on or off when the call comes in?
    Sorry, I forgot to mention it only happened when the phone screen is off.
    edit: Actually I just sign back into hangouts on my pc and the problem seems to be gone . Thanks for your suggestions I will keep you updated in case it happens again!
    07-23-2013 12:30 PM
  6. snrb_labs's Avatar
    Sorry, I forgot to mention it only happened when the phone screen is off.
    edit: Actually I just sign back into hangouts on my pc and the problem seems to be gone . Thanks for your suggestions I will keep you updated in case it happens again!
    If it's only happening when the phone screen is off it's likely a power saving state on the device. The lock settings in GrooVe IP should help with that as long as the rom you are using implements them.
    07-23-2013 12:33 PM
  7. andy o's Avatar
    I have a nexus 4 with paranoid ROM and recently i started experiencing problems with groove ip. Incoming calls does not ring until the call has almost gone to voice mail, i went into the settings and check partial wake lock and high perf wifi lock, restarted the phone, etc and it didn't help at all.

    I decided to sign google hangouts off from my pc and the problem was fixed right away!!!

    I really need to have google hanouts on my pc on all the time, how can i have this solved?
    If this happens only on WiFi, it is a known problem with the N4, in which notifications come delayed, sometimes by minutes, and which may have been fixed in 4.3, but oddly enough the AOSP JSS build only has the fixed activated, not the OTA build. See here Wifi network connectivity issues and a possible fix - xda-developers

    When you turn on the screen sometimes, do you instantly get some notifications as if they just arrived?
    07-29-2013 08:49 AM
  8. Epiclectic's Avatar
    I've used my Epic flashed to cricket for years at $45/month. To cut this bill, I've recently gone Full Voip: installed talkatone (sms & wifi calls) & groove IP (3g/4g calls) , then ported my number over to google voice on thursday night. Porting completed yesterday at 7pm. (FWIW, I'm using freedompop hotspot for 3g/4g connection & normal wifi at home).

    I now realize that I should have installed and activated Gvoice on my phone before dropping cricket. (Since i'd been calling using my gvoice # for weeks, I didn't realize it was a separate app for android, needed to integrate sms).

    Now when I try to install Gvoice app on my Epic, after singing in with my gmail acct, the next screen says "This phone's number" and a long blank. There's a button beneath to "add this phone", which then tries to send a normal sms to gvoice service , to verify my phone #. Since I've ported my # over, there's no carrier service to do this. So it fails.

    All the google voice support says they "require a new number from new carrier " to forward to my gvoice #, which kinda defeats the purpose of the VOIP-only All-data system.

    So, my question is, since I was able to flash my own phone to cricket, can I now reprogram my android so it shows my number instead of that long blank when activating gvoice? Or maybe program it to use an sms app as default, so it sends the text to verify my phone during that process? Is there any hope for the rebel alliance?

    I realize this is a complex issue, and I'm hoping to only get advice from those who have tried VOIP-only thru google voice. While I appreciate others' advice, we could spend weeks trading obtuse advice and explanations with zero progress.

    Holla if you've encountered this or know how to solve!

    Thanks a bunch , you tech-gurus!

    >_<
    08-03-2013 11:03 AM
  9. cirehawk's Avatar
    I have an HTC EVO 4G LTE with G-Voice and GrooveIP. How do I get my phone to ring when someone calls my Google Voice number? To be clear, I want the call to come through GrooveIP, not forwarded (via G-Voice) to my cell phone number.
    08-23-2013 08:19 PM
  10. snrb_labs's Avatar
    I have an HTC EVO 4G LTE with G-Voice and GrooveIP. How do I get my phone to ring when someone calls my Google Voice number? To be clear, I want the call to come through GrooveIP, not forwarded (via G-Voice) to my cell phone number.
    To receive calls in GrooVe IP you need to forward calls to Google Chat
    08-23-2013 08:23 PM
  11. cirehawk's Avatar
    I was doing that but it was ringing earlier in the day. It's working now, so maybe it took a bit to replicate. I have a another question though. I use G-Voice for work purposes. I give the number to customers and set it to ring both my desk and cell. For calling out to customers, there are 2 different PBX's. Some customers have, for example, numbers like (area code) 228-xxxx. Others have (area code) 982-xxxx numbers. Is there a way to setup GrooveIP so that when using my native dialer to call any number in those ranges, it will dial using GrooveIP?
    08-23-2013 10:11 PM
  12. cirehawk's Avatar
    To receive calls in GrooVe IP you need to forward calls to Google Chat
    Thanks, that's what I was doing but it wasn't working earlier. It is now. Another question though. At work I have customers that are on two different PBX's. While some have numbers of (area code) 228-xxxx, others have numbers of (area code) 982-xxxx. Is there a way to configure GrooveIP so that whenever I dial a number within those ranges from my native dialer, it uses GrooveIP to dial?
    08-23-2013 10:17 PM
  13. snrb_labs's Avatar
    Thanks, that's what I was doing but it wasn't working earlier. It is now. Another question though. At work I have customers that are on two different PBX's. While some have numbers of (area code) 228-xxxx, others have numbers of (area code) 982-xxxx. Is there a way to configure GrooveIP so that whenever I dial a number within those ranges from my native dialer, it uses GrooveIP to dial?
    Hi,
    You can use the inclusion filters in GrooVe IP. If it's certain contacts then you can just include them. Or you can setup a regex filter.
    08-25-2013 05:44 PM
  14. cirehawk's Avatar
    Hi,
    You can use the inclusion filters in GrooVe IP. If it's certain contacts then you can just include them. Or you can setup a regex filter.
    Yeah, the inclusion of certain numbers is easy but it's not just certain numbers. So it looks like regex is the way to go but I've never used regex. I'm trying to do some crash learning from Youtube, but it may be a bit before I'm versed enough to make a working filter.

    Edit: I've had success setting up a regex filter that filters on one prefix within the said area code. Now I just need to figure out how to combine the 2nd prefix (i.e. 982 OR 228).
    08-26-2013 10:05 PM
  15. snrb_labs's Avatar
    Yeah, the inclusion of certain numbers is easy but it's not just certain numbers. So it looks like regex is the way to go but I've never used regex. I'm trying to do some crash learning from Youtube, but it may be a bit before I'm versed enough to make a working filter.

    Edit: I've had success setting up a regex filter that filters on one prefix within the said area code. Now I just need to figure out how to combine the 2nd prefix (i.e. 982 OR 228).
    I'm not the best with regex. We use this site to test any regex RegExr. A few examples that are close to what you want are (\+44|\+1|1|\+45)[0-9]+(?:\.[0-9]*)? will match anything starting with +44, +45, +1 or 1 and (\+90|05)[0-9]+(?:\.[0-9]*)? will match anything starting with +90 or 05
    08-27-2013 10:06 AM
  16. kgptzac's Avatar
    I'm currently having a problem with voice quality over wifi. In my apartment I sit right by my router with full wifi signal. Whenever I make a call the other side sounds really choppy. Now if I switch to 4G connection the sound quality is much better. My network isn't congested when I tested so I'm wondering if there's something wrong with the app handling wifi traffic that would cause degraded sound quality?
    08-31-2013 04:38 PM
  17. snrb_labs's Avatar
    I'm currently having a problem with voice quality over wifi. In my apartment I sit right by my router with full wifi signal. Whenever I make a call the other side sounds really choppy. Now if I switch to 4G connection the sound quality is much better. My network isn't congested when I tested so I'm wondering if there's something wrong with the app handling wifi traffic that would cause degraded sound quality?
    Most likely something on your device is going into a power saving state. Try enabling Keep Screen On from the troubleshooting settings to see if that works.
    08-31-2013 04:46 PM
  18. ExtraE's Avatar
    I downloaded GrooVE IP about a week ago. I made one phone call with no problem. It did seem to be draining my battery. Before I installed the app I was getting 18 hrs after the install it's less then 10 hrs. I decided to uninstall it until I had time to mess with the settings. With the app uninstalled it is like parts of the app are still there. What can I do?

    Posted via Android Central App
    09-11-2013 05:33 PM
  19. snrb_labs's Avatar
    I downloaded GrooVE IP about a week ago. I made one phone call with no problem. It did seem to be draining my battery. Before I installed the app I was getting 18 hrs after the install it's less then 10 hrs. I decided to uninstall it until I had time to mess with the settings. With the app uninstalled it is like parts of the app are still there. What can I do?

    Posted via Android Central App
    When you uninstall the app there's nothing left of it on your device. We don't save anything to the sdcard.
    09-12-2013 01:33 PM
  20. itsbeensaid's Avatar
    First off I am poor. That being said -- I own a ZTE Z990G (merit?) Android version 2.3.5, running what I believe is Kernel.

    I use Groove Ip Pro. I've toyed with all of the settings, experimenting with Troubleshooting, Mic, Speaker, Buffers, Screen Time outs, etc. Uninstall/Clear/Re-install from default settings. But my problem remains. As the call goes on both parties get further and further away (increasing DELAY up to 15-20 seconds). Absolute absurdity. Currently configuring my task/battery apps so that my screen stays active.. I need every little feature/setting that helps--I imagine my processor is to blame? Wifi signal is strong. I use Audio Processing, however with the Synchronize Voice doesnt seem to have any bearing on call quality/delay. Partial Wake Lock and High Perf Wifi Lock are ON, Airplane mode is on to ensure Wifis uninterruption. I've often had issues with no ear-piece sound (calls come from Side speaker next to the F'in mic)- So I use Audio Rerouting + Audio Mode Fallback (I even have a lite app called "earpiece" to ensure in-ear calls. PLEASE HELP..I'm only using this app because I cant afford to pay my phone bill. I'd keep using it if it werent so goddamn inconvenient. Help is appreciated.
    09-12-2013 05:14 PM
  21. snrb_labs's Avatar
    First off I am poor. That being said -- I own a ZTE Z990G (merit?) Android version 2.3.5, running what I believe is Kernel.

    I use Groove Ip Pro. I've toyed with all of the settings, experimenting with Troubleshooting, Mic, Speaker, Buffers, Screen Time outs, etc. Uninstall/Clear/Re-install from default settings. But my problem remains. As the call goes on both parties get further and further away (increasing DELAY up to 15-20 seconds). Absolute absurdity. Currently configuring my task/battery apps so that my screen stays active.. I need every little feature/setting that helps--I imagine my processor is to blame? Wifi signal is strong. I use Audio Processing, however with the Synchronize Voice doesnt seem to have any bearing on call quality/delay. Partial Wake Lock and High Perf Wifi Lock are ON, Airplane mode is on to ensure Wifis uninterruption. I've often had issues with no ear-piece sound (calls come from Side speaker next to the F'in mic)- So I use Audio Rerouting + Audio Mode Fallback (I even have a lite app called "earpiece" to ensure in-ear calls. PLEASE HELP..I'm only using this app because I cant afford to pay my phone bill. I'd keep using it if it werent so goddamn inconvenient. Help is appreciated.
    Hi,

    Try increasing the speaker buffer size to large or x-large.
    09-12-2013 05:26 PM
  22. Teamer Connery's Avatar
    They have added text to groove ip. Big thank you... I don't need gvoice anymore. However it doesn't ring when I receive a text. I mean the incoming call ringtone setup works great but I see no option for a text ring tone....Help please
    10-05-2013 01:29 PM
  23. snrb_labs's Avatar
    They have added text to groove ip. Big thank you... I don't need gvoice anymore. However it doesn't ring when I receive a text. I mean the incoming call ringtone setup works great but I see no option for a text ring tone....Help please
    You can set the incoming SMS tone via the app miscellaneous->notifications settings.
    10-05-2013 07:40 PM
  24. JonK's Avatar
    Hello, I just started experimenting with groove ip and so far it is working great. Call quality is excellent (on my end at least; need to start testing with other people) and incoming calls ring quickly (faster than when the call is forwarded to my mobile number even). I have run into one glaring issue. I discovered the issue while experimenting to see if handoffs from wifi->cell network (or vice versa) were possible. While I understand hand-offs are not supported yet I discovered another issue. Sorry if this has already been posted, this thread is very long. Here are the steps to reproduce:

    Connect to wifi
    Receive a call in groove ip (i used skype to call my gv number)
    During the call, turn wifi off
    -The call drops (as expected) and groove ip is signed out
    -Phone connects to cell network
    -Groove ip signs back in
    Try calling gv number again
    -The call is not received in groove ip

    It seems like after a dropped call, even though groove signs back in, it will not receive any more calls. I must exit groove and start it back up. Is this a known issue? Is anyone else able to reproduce it? A side note question, is it planned or even possible to support hand-offs for calls?
    10-13-2013 10:48 AM
  25. snrb_labs's Avatar
    Responded to your email.
    10-14-2013 07:08 PM
692 ... 25262728

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD