11-16-2015 12:23 PM
692 ... 7891011 ...
tools
  1. HeidiLynn's Avatar
    Most likely what's happening is your phone is putting the WiFi into a power saving mode when the screen turns off. If you want to keep that behavior but still make calls you can go into the GrooVe IP troubleshooting settings and check "Keep Screen Alive"

    Alternatively you can change your phones battery/power profile so WiFi never sleeps.
    Thank you for getting back to me so quickly. Both of those settings are already set to "Keep Screen Alive" and Wi-Fi Sleep Policy is already set to "Never". I was reading in another thread to disable automatic sync, but made a couple of calls this morning and it doesn't seem to have done the trick either. It's truly frustrating that I cannot get this to work.

    Do you or anyone else have any recommendations?

    Thanks again!
    ~Heidi
    06-28-2011 10:39 AM
  2. JayMSY's Avatar
    Any way to disable the automatic bluetooth with the current version? So far this app is a LOVE/HATE relationship for me on my DroidX. Almost to the point I might go back to GVMyNumber.

    As I have stated before the phone audio plays through my car stereo via the MP3 input and not through the regular bluetooth like the phone itself.

    The way the PHONE default dailer acts is if the Radio is on and a call is placed it mutes all audio and places the phone audio ON. Even if I am listening to Pandora with my phone connected via Bluetooth.

    The way GrooveIP works on my Droid X is all audio is routed through the car stereo MP3 option meaning if I call comes in I have to switch the car stereo input from Radio/Sat/Whatever to MP3.

    And here's the really "FUN" part...If I disable "bluetooth" on the GrooveIP app the audio does not go back to routing through the phone speaker. The ONLY way the GrooveIP audio is routed through the Droid X phone speaker at the top of "Motorola" is IF BLUETOOTH IS COMPLETELY DISABLED on the phone!!!! THAT is unacceptable because it means I can't listen to streaming radio, or any audio with my phone and use your app!

    I'm really about to my wits end with this. This is the only reason why I have not "rated" the app on the market...make it work for me like it SHOULD and I'll give it plenty of stars! :-)
    06-28-2011 03:52 PM
  3. snrb_labs's Avatar
    Any way to disable the automatic bluetooth with the current version? So far this app is a LOVE/HATE relationship for me on my DroidX. Almost to the point I might go back to GVMyNumber.

    As I have stated before the phone audio plays through my car stereo via the MP3 input and not through the regular bluetooth like the phone itself.

    The way the PHONE default dailer acts is if the Radio is on and a call is placed it mutes all audio and places the phone audio ON. Even if I am listening to Pandora with my phone connected via Bluetooth.

    The way GrooveIP works on my Droid X is all audio is routed through the car stereo MP3 option meaning if I call comes in I have to switch the car stereo input from Radio/Sat/Whatever to MP3.

    And here's the really "FUN" part...If I disable "bluetooth" on the GrooveIP app the audio does not go back to routing through the phone speaker. The ONLY way the GrooveIP audio is routed through the Droid X phone speaker at the top of "Motorola" is IF BLUETOOTH IS COMPLETELY DISABLED on the phone!!!! THAT is unacceptable because it means I can't listen to streaming radio, or any audio with my phone and use your app!

    I'm really about to my wits end with this. This is the only reason why I have not "rated" the app on the market...make it work for me like it SHOULD and I'll give it plenty of stars! :-)
    About the only thing I can do is add a checkbox to disable bluetooth completely for GrooVe IP. The bluetooth in andriod isn't really all that complicated, it amounts to calling a method to start bluetooth streaming when the bluetooth button on the app is pressed. As far as I've found there's no way for us to influence where it plays. When you de-select bluetooth we call the method to stop streaming through bluetooth. Don't know why it doesn't work properly on the DX with your car. But as I said before, I'll add a checkbox to completely disable bluetooth in the app into the miscellaneous settings.

    Just added the toggle, if you want the new apk shoot me an email at snrb.labs@gmail.com
    06-28-2011 04:51 PM
  4. JayMSY's Avatar
    Thanks. I'll hit ya up tomorrow as I am walking out the door for the evening. It's really an awesome app, just extremely frustrating for me in how it works with the Kia Soul radio and its bluetooth operation.

    Not sure if this helps but when I have the phone bluetooth sync'd with the Kia radio all phone call audio is routed as I stated above and the audio for podcasts/streaming radio/whatever is done through the MP3 selection on the radar. I'm just at a loss as to why the GrooveIP app can't use the regular...it may be because it can't and is forced to use the mp3 audio input. That would explain a few things.

    I do think that the checkbox to disable bluetooth completely for the GrooVe IP app would be a way to go for me and people who might have this issue.
    06-28-2011 08:15 PM
  5. snrb_labs's Avatar
    ‎1.1.8 is up on the android market
    - Fix a reconnect issue
    - Add a setting to disable Bluetooth in GrooVe IP
    - Default Bluetooth to on if a device is sync'd
    06-28-2011 09:44 PM
  6. rubydreamer's Avatar
    I'm curious, is there any news on improvements in how this works on the Samsung Galaxy Tab line?

    I'm using a Verizon one, mostly for the realistic Data Plan options, and would absolutely LOVE to hook up with this if it works right.

    I was previously looking at Line2, since it had texting as well, but if this works well, the one time $4 vs $10 a month will win out. (It also looks like I could get basic texting, for $5 a month, legit from Verizon)

    Hope to hear about progress on tablet functionality...

    Another thought, a basic website which lists the known devices that work, and provides FAQ like help to get the ones that are "sticky" to work right. And of course the devices that have been reported to NOT work with GrooVe IP.
    06-28-2011 11:17 PM
  7. snrb_labs's Avatar
    I'm curious, is there any news on improvements in how this works on the Samsung Galaxy Tab line?

    I'm using a Verizon one, mostly for the realistic Data Plan options, and would absolutely LOVE to hook up with this if it works right.

    I was previously looking at Line2, since it had texting as well, but if this works well, the one time $4 vs $10 a month will win out. (It also looks like I could get basic texting, for $5 a month, legit from Verizon)

    Hope to hear about progress on tablet functionality...

    Another thought, a basic website which lists the known devices that work, and provides FAQ like help to get the ones that are "sticky" to work right. And of course the devices that have been reported to NOT work with GrooVe IP.
    I haven't heard of any problems with the Verizon Galaxy tab. The only Galaxy tab anyone has reported problems with is the GT-P1010 WiFi only device, believe it's not sold by the carriers. Actually had feedback saying it works well on the other Galaxy tab devices.

    We have hired someone to redo our webpage. But the big issue with listing configs for individual devices is we really don't have access to all of them. We've been thinking of creating an area where individual users could report what settings they use on their device.
    06-29-2011 06:50 AM
  8. Mean Dean's Avatar
    Hey there... just got my first Android phone, an LG Optimus V (Virgin Mobile), and put GrooVe IP on it. I love the way the program works, but when I speak to my dad (who is on Verizon), an odd thing happens. After the conversation is over, he receives a voicemail containing the conversation we just had! This was cute the first time, but it's starting to get annoying Any solutions?
    06-29-2011 10:28 AM
  9. bocksmj's Avatar
    Hello! I just purchased this App and its working great for me so far... i have 1 question though! I use GV also, and have it set up to ask me each time i call whether to use GV# or my personal #. So, here's what happens... not sure if its a GV error or Groove? I go to contacts, click on name to call someone. Pop up box asks if i want to call with Google Voice or without Google Voice. Then it asks me if i want to use GrooVe IP or Mobile Network. Then it asks me if i want to call with Google Voice or without Google Voice again. It doesn't matter which option i pick the first time, because it asks me again and that's the one that it picks up. Have you experienced this yet? Thanks in advance!!

    Matt
    06-30-2011 05:42 PM
  10. snrb_labs's Avatar
    Hello! I just purchased this App and its working great for me so far... i have 1 question though! I use GV also, and have it set up to ask me each time i call whether to use GV# or my personal #. So, here's what happens... not sure if its a GV error or Groove? I go to contacts, click on name to call someone. Pop up box asks if i want to call with Google Voice or without Google Voice. Then it asks me if i want to use GrooVe IP or Mobile Network. Then it asks me if i want to call with Google Voice or without Google Voice again. It doesn't matter which option i pick the first time, because it asks me again and that's the one that it picks up. Have you experienced this yet? Thanks in advance!!

    Matt
    The issue is you have multiple "phone" apps. What happens is when you make a call from the native dialer android sends it to each app that's registered as able to make calls. The first app notified displays it's pop-up asking native network or the app. If you choose native network, android then sends it to the next app, and so on. Not sure why it asks you twice though.
    06-30-2011 07:49 PM
  11. danielbritt's Avatar
    The issue is you have multiple "phone" apps. What happens is when you make a call from the native dialer android sends it to each app that's registered as able to make calls. The first app notified displays it's pop-up asking native network or the app. If you choose native network, android then sends it to the next app, and so on. Not sure why it asks you twice though.
    Do you have the Google Voice app installed on your Android? There could be a conflict if both are running and/or on the phone.
    07-02-2011 08:52 PM
  12. gluggle314's Avatar
    I am making a trip to Europe in September. I planned on bringing my wifi tablet and using Groove IP to make calls over wifi back to the United States. Would there be any fees associated with this?
    07-05-2011 11:40 AM
  13. kimberlyinmn's Avatar
    I am making a trip to Europe in September. I planned on bringing my wifi tablet and using Groove IP to make calls over wifi back to the United States. Would there be any fees associated with this?
    I think that there are fees, but pretty low ones. Here's a link to videos that answer questions about Google Voice. They have one for international calling.

    Google Voice - Features
    gluggle314 likes this.
    07-05-2011 11:48 AM
  14. kimberlyinmn's Avatar
    I think that there are fees, but pretty low ones. Here's a link to videos that answer questions about Google Voice. They have one for international calling.

    Google Voice - Features

    Hmmmm... although maybe not. You'll be calling from your U.S. number while in Europe to a U.S. number. (I'm thinking and typing.) I'll let one of the "professionals" answer this one.
    gluggle314 likes this.
    07-05-2011 11:51 AM
  15. kimberlyinmn's Avatar
    07-05-2011 12:02 PM
  16. snrb_labs's Avatar
    I am making a trip to Europe in September. I planned on bringing my wifi tablet and using Groove IP to make calls over wifi back to the United States. Would there be any fees associated with this?
    Hi,

    Calls made through the app to numbers in the US or Canada are free. We do have many people in Europe using the app successfully. But depending on where you are you could run into firewall problems or Google Voice doing IP filtering.
    gluggle314 likes this.
    07-05-2011 01:24 PM
  17. wch_one's Avatar
    I've installed GrooVe IP and it's working pretty well, except for a couple of issues. From what I've read earlier in this thread, these issues might have something to do with the fact that I've also installed the official Google Voice app.

    The first issue is that, when I make outgoing calls via the regular phone dialer app, it asks the following:
    (1) Call with Google Voice or without Google Voice? [select Google Voice]
    (2) Call with GrooVe IP or Mobile Network? [select Mobile Network]
    (3) Call with Google Voice or without Google Voice? [select Google Voice]
    Then it finally makes the call.

    I have Google Voice configured to ask me whether to call with Google Voice or without -- and then it asks me twice, once before the GrooVe IP prompt, and once after. This is annoying but not necessarily a show stopper. I realize that others have had this same issue.


    The second issue is a bigger problem. When I get incoming calls, my phone rings with two ringers simultaneously: one of them is GrooVe IP, and the other seems to be the phone's regular ringer (or is there a special Google Voice app ringer?). Because they're both ringing at once, I can't really choose which one to answer -- both apps seem to be competing to be the prompt that shows on screen, but I can't control which one. This makes GrooVe IP useless for incoming calls for me.

    My workaround was to go to the Google Voice configuration webpage and disable incoming calls to my Google Chat account, which is what GrooVe IP uses. Now my incoming calls can't be answered with GrooVe IP. This is really a less-than-optimal solution because (1) I can't receive calls to my computer at all, and (2) I still would like to be able to take incoming calls, at least when I'm on wifi.


    I had a couple emails with the developer about these issues, and this where things are now. Is anyone else out there using the official Google Voice app in conjunction with GrooVe IP, and if so, do you have the same problems?
    07-06-2011 12:17 PM
  18. alc2077's Avatar
    Hi, I have you app installed on both my sammy galaxy tab & evo and both work great! question;

    I am planning on making a switch to Virgin Mobile when the MOT triumph launches on the 19th & plan to use the groove ip app as my primary dialer, my only concern is will the data speeds of VM be fast enough to handle my calls clearly since this is a voip call? is there a minimum data speed needed in other for the groove ip app to handle calls clearly on a 3G network? Thanks in advance
    07-06-2011 01:44 PM
  19. rotnerl's Avatar
    I've installed GrooVe IP and it's working pretty well, except for a couple of issues. From what I've read earlier in this thread, these issues might have something to do with the fact that I've also installed the official Google Voice app.

    The first issue is that, when I make outgoing calls via the regular phone dialer app, it asks the following:
    (1) Call with Google Voice or without Google Voice?
    (2) Call with GrooVe IP or Mobile Network?
    (3) Call with Google Voice or without Google Voice?

    I have Google Voice configured to ask me whether to call with Google Voice or without -- and then it asks me twice, once before the GrooVe IP prompt, and once after. This is annoying but not necessarily a show stopper. I realize that others have had this same issue.


    The second issue is a bigger problem. When I get incoming calls, my phone rings with two ringers simultaneously: one of them is GrooVe IP, and the other seems to be the phone's regular ringer (or is there a special Google Voice app ringer?). Because they're both ringing at once, I can't really choose which one to answer -- both apps seem to be competing to be the prompt that shows on screen, but I can't control which one. This makes GrooVe IP useless for incoming calls for me.

    My workaround was to go to the Google Voice configuration webpage and disable incoming calls to my Google Chat account, which is what GrooVe IP uses. Now my incoming calls can't be answered with GrooVe IP. This is really a less-than-optimal solution because (1) I can't receive calls to my computer at all, and (2) I still would like to be able to take incoming calls, at least when I'm on wifi.


    I had a couple emails with the developer about these issues, and this where things are now. Is anyone else out there using the official Google Voice app in conjunction with GrooVe IP, and if so, do you have the same problems?
    I have the exact same issue. Can anyone help?
    07-07-2011 10:21 PM
  20. snrb_labs's Avatar
    Hi, I have you app installed on both my sammy galaxy tab & evo and both work great! question;

    I am planning on making a switch to Virgin Mobile when the MOT triumph launches on the 19th & plan to use the groove ip app as my primary dialer, my only concern is will the data speeds of VM be fast enough to handle my calls clearly since this is a voip call? is there a minimum data speed needed in other for the groove ip app to handle calls clearly on a 3G network? Thanks in advance
    You'll need at least 90 kbps upload and download speed to get decent voice.
    07-12-2011 09:29 PM
  21. snrb_labs's Avatar
    I have the exact same issue. Can anyone help?
    You can go into the Google Voice app and tell it to never ask for phone calls. That will stop it from asking at all. Not sure what causes the double asking. What happens is android goes through each app that's registered as being able to handle phone calls. It sends the call to that app and that app then shows you a pop-up asking to confirm. If you select mobile network the call goes back to android and android is supposed to send it to the next app on the list or finally the mobile network. For some reason it seems to be sending the call to the google voice app again.
    07-12-2011 09:31 PM
  22. TechT's Avatar

    The second issue is a bigger problem. When I get incoming calls, my phone rings with two ringers simultaneously: one of them is GrooVe IP, and the other seems to be the phone's regular ringer (or is there a special Google Voice app ringer?). Because they're both ringing at once, I can't really choose which one to answer -- both apps seem to be competing to be the prompt that shows on screen, but I can't control which one. This makes GrooVe IP useless for incoming calls for me.

    My workaround was to go to the Google Voice configuration webpage and disable incoming calls to my Google Chat account, which is what GrooVe IP uses. Now my incoming calls can't be answered with GrooVe IP. This is really a less-than-optimal solution because (1) I can't receive calls to my computer at all, and (2) I still would like to be able to take incoming calls, at least when I'm on wifi.
    Having the conflict issue as well. Typically, both ringers go off simulateously, Groove usually shows up first, answering there gives no connection and leaves voice ringing with no apparent way to answer. Hanging up with Groove and answering Voice/Native app on the following screen, the call typically disconnects on the phone (caller may get voicemail).

    Adjusting the google voice settings to "always" as you suggest fixes the dial out issue, but not this one. I can disable forwarding to the carrrier cell number to correct this. But, if I do that and go out of the data network, I can't get incoming calls or dial out from my google voice number. Alternatively, I can disable call forwarding to chat in GV and lose the incoming call capability with Groove. Neither solution is great.

    This is additionally complicated by Groove not working with my car's bluetooth (silence both ways). This isn't surprising because the car (2007 BMW 328) bluetooth is finicky, but odd since it does work with the Voice/Native dialer. Since I need bluetooth to use the phone hands free while driving, it means that if I have Groove working for incoming calls (forwarding to chat only), I can't use the phone in the car.

    This effectively limits Groove to a VoIP outbound solution (while not driving) for me.

    The selection screen for outbound calls is perfect. Would it be possible to implement something similar for inbound calls? Or maybe a way to easily toggle the Voice forwarding setting between chat and the cell carrier number from Groove?
    07-13-2011 08:46 AM
  23. snrb_labs's Avatar
    Having the conflict issue as well. Typically, both ringers go off simulateously, Groove usually shows up first, answering there gives no connection and leaves voice ringing with no apparent way to answer. Hanging up with Groove and answering Voice/Native app on the following screen, the call typically disconnects on the phone (caller may get voicemail).

    Adjusting the google voice settings to "always" as you suggest fixes the dial out issue, but not this one. I can disable forwarding to the carrrier cell number to correct this. But, if I do that and go out of the data network, I can't get incoming calls or dial out from my google voice number. Alternatively, I can disable call forwarding to chat in GV and lose the incoming call capability with Groove. Neither solution is great.

    This is additionally complicated by Groove not working with my car's bluetooth (silence both ways). This isn't surprising because the car (2007 BMW 328) bluetooth is finicky, but odd since it does work with the Voice/Native dialer. Since I need bluetooth to use the phone hands free while driving, it means that if I have Groove working for incoming calls (forwarding to chat only), I can't use the phone in the car.

    This effectively limits Groove to a VoIP outbound solution (while not driving) for me.

    The selection screen for outbound calls is perfect. Would it be possible to implement something similar for inbound calls? Or maybe a way to easily toggle the Voice forwarding setting between chat and the cell carrier number from Groove?
    Not sure a selection screen is possible since the setting would have to be changed in your Google Voice account. The best way right now would be to add a shortcut to the Google Voice webpage on your device. And change the checkboxes. We are looking into trying to hide the native incoming call screen if the same call is also coming into GrooVe IP. But that would rely on hidden undocumented apis and isn't guaranteed to work on all devices.
    07-14-2011 09:09 AM
  24. Space Ghost's Avatar
    speaker fix here for app , is this what the options do?
    https://jira.skype.com/browse/JSA-81

    Basically the call you guys are making to `AudioManager::setSpeakerphoneOn(false)` fails because you first need to set `AudioManager::setMode(MODE_IN_CALL)`. If you don't, setSpeakerphoneOn will just silently fail

    call to AudioManager::setMode into PcmHost::_setVoiceRoute
    Thanks! Will take a look. If you have an intercept you can enable incoming & outgoing audio processing. Enable the audio mode fallback. And in a call turn speakerphone on then off. If it works, I'll do it all programatically. Many phones don't like the MODE_IN_CALL, so might have to add another checkbox or something.
    I have the Samsung Intercept too (signed up for Virgin just yesterday to lock in prices) and was intrigued by the Groove IP app... so I bought the app today and have had nothing but trouble so far. (Should have checked the Internets first I 'spose!)

    Using Groove IP with all settings at default values (btw... you should consider having a restore default settings button!), I'm getting only audio via the speakerphone... not when the call is initiated, only after the call is picked up. Once the call is connected, the "Speaker" button on the Dialer screen does not seem to function - it is permanently stuck in speakerphone mode. This creates an echo for the person on the other end... the person talks, the audio goes out the speakerphone, gets picked up by the mic and then is echoed back down the line. :sad trombone:

    So I found this thread and the above post in particular. I enabled incoming & outgoing audio processing in the Troubleshooting settings... as well as the "audio mode fallout". When a call comes in (or goes out) and is connected, the audio is routed through the ear speaker (yay!), but the mic seems to be permanently on mute (boo!). Nothing I say on my end is transmitted back to the person on the other end. Ugh.

    Any love here?

    cheers.
    07-14-2011 11:36 PM
  25. Space Ghost's Avatar
    I have the Samsung Intercept too (signed up for Virgin just yesterday to lock in prices) and was intrigued by the Groove IP app... so I bought the app today and have had nothing but trouble so far. (Should have checked the Internets first I 'spose!)

    Using Groove IP with all settings at default values (btw... you should consider having a restore default settings button!), I'm getting only audio via the speakerphone... not when the call is initiated, only after the call is picked up. Once the call is connected, the "Speaker" button on the Dialer screen does not seem to function - it is permanently stuck in speakerphone mode. This creates an echo for the person on the other end... the person talks, the audio goes out the speakerphone, gets picked up by the mic and then is echoed back down the line. :sad trombone:

    So I found this thread and the above post in particular. I enabled incoming & outgoing audio processing in the Troubleshooting settings... as well as the "audio mode fallout". When a call comes in (or goes out) and is connected, the audio is routed through the ear speaker (yay!), but the mic seems to be permanently on mute (boo!). Nothing I say on my end is transmitted back to the person on the other end. Ugh.

    Any love here?

    cheers.
    A small note to follow up on what I just posted... I have (somewhat happily) discovered that if I plug in a wired headset into the 1/8" mini jack, then everything works perfectly with "factory default" GrooVe IP settings (no "Audio Mode Fallback", no "Audio Processing"). Obviously what has happened is that the incoming audio is routed to the earbuds (instead of the speakerphone) which eliminates the feedback echo.

    So... if the speakerphone issue on the Intercept can be solved (I'd prefer using the app without the earbuds), then I would be thrilled. For now I'll keep the wired earbuds handy for incoming(/outgoing) VoIP calls.

    Thanks in advance for your consideration.

    cheers.
    07-15-2011 01:01 AM
692 ... 7891011 ...

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD