1. milleniumdroid's Avatar
    Ok, so basically I took the LDX APK that somebody shared on Reddit and I decided to decrease the minimum API level from 26 to 19. I installed it on my main phone (CAT S41, Nougat, API 24) and it crashes after blinking the splash screen for a split second. I'm genuinely surprised that it even got this far. Put the mod apk on my first Android device (Lenovo A369i w/ LOS14.1) and it behaved exactly as on my main phone. When I installed the APK on my Galaxy Tab S3 (stock SE9 Oreo), it just threw out an alert that I need to update to the latest software to run LDX. Of course, although the APK is supposed to run on API19 after my tweak, it gives the dreaded "app not installed" when I try to get it running on a KitKat based Alcatel Idol X+ I pulled out of storage...

    This may seem pointless, but if you are a tech geek like me it is cool to get an app to do at least SOMETHING on unsupported devices and operating systems.

    Here is a link to my APK if you're interested in trying it on your device:
    https://archive.org/details/LinuxOnDexBetaMODAPK
    11-13-2018 03:47 PM
  2. dude9946's Avatar
    Thanks for sharing the APK!
    milleniumdroid likes this.
    11-13-2018 03:59 PM
  3. Rukbat's Avatar
    Ok, so basically I took the LDX APK that somebody shared on Reddit and I decided to decrease the minimum API level from 26 to 19 ...Of course, although the APK is supposed to run on API19 after my tweak
    Not exactly. That change just allowed it to install without barfing. But if the app uses a function that was introduced in API 26, just changing the minimum API level won't add that function.

    Reducing the API level works - very rarely. If the dev accepts the default level in AS, but the app doesn't use anything later than an earlier level, it will work. If it uses something introduced at the minimum level ... it just won't.
    ManiacJoe and milleniumdroid like this.
    11-14-2018 01:34 PM
  4. milleniumdroid's Avatar
    Not exactly. That change just allowed it to install without barfing. But if the app uses a function that was introduced in API 26, just changing the minimum API level won't add that function.

    Reducing the API level works - very rarely. If the dev accepts the default level in AS, but the app doesn't use anything later than an earlier level, it will work. If it uses something introduced at the minimum level ... it just won't.
    I know. This was just a fun experiment that I decided to share .
    11-15-2018 05:01 AM

Similar Threads

  1. What should I choose between the LG V30 and LG G7 ThinQ?
    By Hypnotic47 in forum General Help and How To
    Replies: 1
    Last Post: 01-09-2019, 08:39 AM
  2. Replies: 7
    Last Post: 11-19-2018, 03:49 PM
  3. Why can't I hear my sister when I ring her but she can hear me
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 11-14-2018, 02:01 PM
  4. can i talk and listen to bluetooth speaker at same time
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-13-2018, 04:33 PM
  5. I want my text notification to ring / alarm until I turn it off.
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-13-2018, 04:30 PM
LINK TO POST COPIED TO CLIPBOARD