11-19-2016 11:59 AM
101 123 ...
tools
  1. Phil Nickinson's Avatar
    Now that we're allowed to talk about things ... I've yet to get the Verizon Galaxy S7 to connect with Android Auto. Not sure if it's a VZW connection thing (they have that damned "connect as installer" crap going on) or if it's like with the GS6 a year ago and things are just kinda wonky for a while.

    All I get on my Pioneer 4100 once the AA app kicks on (I have to manually switch to something other than the pure "charging" mode) is "ERROR."

    Will advise.
    03-08-2016 11:38 AM
  2. flyboy06's Avatar
    I've ordered the T-Mobile variant and am very interested to know if it's supported.
    03-09-2016 02:58 AM
  3. allen832008's Avatar
    I can confirm that this does not work for me either on Verizon model sg7.
    03-09-2016 07:17 AM
  4. lfaitas's Avatar
    I also have a galaxy S7 european version and its not working with my Pioneer AVH-X8700BT either.
    I tried both the Android Auto and the Mirrorlink option but none work.
    I also have an iphone 6s and it works fine with the same system.
    When i connect the s7 i get all sorts of errors. I can see that the android auto app starts in the background but nothing happens.. when i disconnect the cable and start the android app from the phone i get a crash report.
    I tried restarting both devices and tried with a samsung galaxy s6 but same problem.
    03-09-2016 11:16 AM
  5. daerik's Avatar
    I am connecting a Galaxy S7 Edge (SM-G935T) on a T-Mobile Network to an AVH-4100NEX (1.053) in a 2007 Mercury Grand Marquis. I can confirm that my connection was successful and I was able to use Google Maps, Spotify, and BeyondPod without error. Something different that I noticed with this phone was that I had to set a default setting the first time I plugged it into a computer, which I did prior to plugging it into my head unit. After plugging into my head unit, I had to press "Accept" on about 6 different permissions from phone logs, to messages, to media. Please note: I have USB Debugging turned on.

    Let me know if you have questions,
    Daerik
    03-09-2016 11:16 AM
  6. allen832008's Avatar
    Phil, I have been playing with this and was able to get Auto working on the Verizon SG7 by choosing MTP Media connection from notification tray. It's frustrating to have to do this every time the phone is connected, but this worked for me on multiple occasions today.
    03-09-2016 09:08 PM
  7. scott_0's Avatar
    Sprint S7e here, auto connects smoothly to my Pioneer 8100nex, after the initial setup and giving several permissions, its been smooth sailing
    03-10-2016 08:48 AM
  8. francoamerican5's Avatar
    I've tried all the connection settings from my VZW S7 when connected to my 4100NEX and all I get is a black screen. Once I did get the terms agreement, but none of the on screen buttons worked... Had my S6 still with me and loaded right up. Not sure if phone itself and/or Marshmallow.
    03-11-2016 08:13 AM
  9. Scott Brown15's Avatar
    Having the same issue with my S7edge too. Was trying again this morning and got the error message the AA couldn't connect now....Tried restarting phone and got the same error message. Have tried all of the advice above with no success. I have a 4100NEX.
    03-11-2016 10:14 AM
  10. Olytechy's Avatar
    I'm Having the same issue, S7 Edge on Verizon

    When I connect my phone to my NEX-4100 nothing happens, if I go to "Mobile Hotspot and Tethering" and I click "USB tethering" it quickly loads android auto and one of a few things happens. I get the typical "Android Auto Can't Connect" or a few times I tried I just got a black screen.

    I previously had the S6 Edge on TMobile with no issues. Very frustrated with my switch to Verizon so far...
    03-11-2016 04:34 PM
  11. vandeec5's Avatar
    I have the Pioneer Nex-4100. I've upgraded from ATT S6 to Verizon S7 and was able to get Android Auto to work on my Subaru. At first it didn't work but I did the following to get it to work.
    1. I've enabled "Developer Options"
    2. In the Developers Option under the USB Configuration options, I changed it from charging to MTP (Media Transfer Protocol).

    The only downside is that if I need to use Android Auto, I will keep having to repeat step #2.
    03-12-2016 01:44 AM
  12. pakistone24's Avatar
    I've t-mobile galaxy s7 edge and Honda Accord and was having same problems but didn't have any problems with gs6. USB debugging didn't help but I played with car system and it worked.

    After your phone is connected, In the car system go to settings, smartphone, Android auto, there you'll have all prior connected devices as well as an "unknown device" tap on that and make sure it is "enabled".

    Make sure phone's also connected through bluetooth. Hopefully that helps
    03-13-2016 01:45 PM
  13. Olytechy's Avatar
    I just tried this and it doesn't work for me. When I changed USB Configuration Options to MTP, the phone flickers and loads android auto, but then the head unit seems to freeze loading Android Auto and I notice the settings for USB Configuration reset back to default.

    I tried this over and over and got the screen to show up where I need to click to agree to use the Android Auto, but it was frozen and not responsive.

    Seems like this setting allows the phone to send just enough data to start the loading process on the deck, then it just locks up.

    So overall this solution isn't working for me...

    Hope they have an update soon.

    Mike
    03-13-2016 02:56 PM
  14. jschu22's Avatar
    Upon my very first connection, it wouldn't work but I think once Google Plap Services updated it's been fine. I'm not sure because that's how quickly the problem cleared up.

    Posted via the Android Central App
    03-14-2016 09:15 PM
  15. Phil Nickinson's Avatar
    So close, yet so far. :-/

    Verizon Galaxy S7 NOT working with Android Auto ...-gs7-vzw-android-auto.jpg
    03-15-2016 01:11 PM
  16. Olytechy's Avatar
    I had this exact same screen before, I also had it show the entire "click ok to continue" screen as well, just it was locked up so I couldn't click ok.

    So far no solution is working for me.
    03-15-2016 02:58 PM
  17. scott_0's Avatar
    are you guys using really long cables? I found my issue was a long usb extension cable, I eliminated it and I'm good now
    03-15-2016 04:32 PM
  18. Phil Nickinson's Avatar
    I'm getting closer. Actually got it to load up once. And then it froze. ...
    03-16-2016 09:39 AM
  19. Olytechy's Avatar
    I have a 3' extension behind the dash and then using the stock cable in the front. So not that long overall.

    I would take the unit out and test the stock cable directly into the back of the head unit but that is just a ton of work... That will be more of a last resort thing to try.

    Mike
    03-16-2016 10:47 AM
  20. scott_0's Avatar
    I have a 3' extension behind the dash and then using the stock cable in the front. So not that long overall.

    I would take the unit out and test the stock cable directly into the back of the head unit but that is just a ton of work... That will be more of a last resort thing to try.

    Mike
    give it a try man, the S7 is finicky with cable choice and length......
    03-16-2016 11:05 AM
  21. mpisani's Avatar
    Has anyone any luck yet? I see you got close but I don't know what steps you took. With my Galaxy S5 Android auto worked on my AVH4100-NEX no problem. I just picked up the Galaxy S7 Edge on Tuesday and I noticed today that I couldn't get AA to work. Like I said, if you could let me know what you did (please spell it out step by step), I'd appreciate it.

    Thanks,
    Matt
    03-17-2016 08:52 AM
  22. Scott Brown15's Avatar
    So, i was able to conduct a test. We are car shopping and looking at Hyundai's. I connected my S7 edge using the usb cable i use in my Tacoma and AA immediately connected with no issues. So, not that it helps solve our problem with the Pioneer 4100NEX, I can confirm my phone does in fact work with AA, the usb cable I have the phone likes. So it feels like a couple of things could be an issue: the usb wire to the back of the head unit, pioneer needs to update their firmware.

    I hope they figure this out soon, I absolutely love AA and miss it!
    03-17-2016 10:55 PM
  23. Phil Nickinson's Avatar
    Got it to connect this morning.

    Launched Google Maps.

    Everything froze.
    03-18-2016 09:38 AM
  24. vandeec5's Avatar
    I know the USB cables have to be plugged into a particular USB slot in the back of the head-unit also for it to work. (I have the Pioneer 4100-NEX)
    03-18-2016 05:34 PM
  25. vandeec5's Avatar
    Curious if you guys are running the latest firmware update for the head-unit (if applicable) also....
    03-18-2016 05:42 PM
101 123 ...

Similar Threads

  1. Auto Advance on native email app?
    By Rogie in forum Samsung Galaxy S7 edge
    Replies: 1
    Last Post: 08-22-2016, 01:07 AM
  2. How to enable usb debugging on s7 edge?
    By tirrorex in forum Samsung Galaxy S7 edge
    Replies: 19
    Last Post: 07-23-2016, 09:12 AM
  3. When will Android have a two-way sync with Outlook 2013?
    By GLeuschke in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 03-11-2016, 08:59 AM
  4. What Galaxy S6 themes use the least battery power?
    By AC Question in forum Samsung Galaxy S6
    Replies: 2
    Last Post: 03-09-2016, 08:46 AM
  5. S7 Edge Bootloader
    By AlbertHammondBootleg in forum Samsung Galaxy S7 edge
    Replies: 4
    Last Post: 03-08-2016, 11:50 AM
LINK TO POST COPIED TO CLIPBOARD