1. trafsta's Avatar
    I picked up a 2017 Ford Escape SE 2.0L AWD 201A + tow (w/o NAV) a few weeks ago and everything is working well (remote start/unlock/lock functions from Android phone even work well!), Android Auto is working well also EXCEPT I cannot reply to WhatsApp messages. I had the same issue on 2 different Escapes that I test drove prior to making my factory order a few months ago. When I get a message on WhatsApp a notification comes up on the Android Auto vehicle screen and I am able to tap it and it will read the message to me quite well. After reading the message it says to press the button on the steering well and say a command of "reply" in order to reply to that persons message. When I do this, it recognizes the reply command, however it says "This app is either not installed or needs to be updated" or something to that effect. I was hoping this issue would be solved 8+ weeks later after my initial test drives, but alas, it has not. I have the latest software available for Sync 3 (connected it to WiFi and checked 2 days ago) and I am running a Samsung Galaxy S7 on Bell Mobility (Canada) running Android 6.0.1. I have tried the latest stable/official release of WhatsApp and have also signed up for the Beta version that is delivered through the Beta section of the Play Store, but neither seem to work (same error message is said to me).

    Does anyone in the US or Canada currently have the Reply feature of WhatsApp working for them in Android Auto? Curious to hear about others users of WhatsApp in Android Auto on 2017 Escapes/Fusions.

    Thanks in advance.
    10-12-2016 06:49 AM
  2. Pedrore's Avatar
    I only have one contact that I regularly use WhatsApp with, but I know I used this feature last month and the reply function worked as it should (Canada, VW Golf, Nexus 5X with Bell). I keep my apps up to date, but nothing special otherwise.
    10-12-2016 01:15 PM
  3. trafsta's Avatar
    Thanks for the response Pedrore. Gotta wonder why mine is not working. All my apps are up to date also. Will be interesting to hear more responses from other people as well. Will somehow hopefully be able to get to the bottom of this
    10-12-2016 01:25 PM
  4. Ronan Frawley's Avatar
    Thanks for the response Pedrore. Gotta wonder why mine is not working. All my apps are up to date also. Will be interesting to hear more responses from other people as well. Will somehow hopefully be able to get to the bottom of this
    I have a 2017 Audi S3. Reply function worked well when using Android Auto with my Note 7. Now that I've switched to the Google Pixel XL, I get the same "not installed or updated" message you're getting.
    11-24-2016 12:22 PM
  5. trafsta's Avatar
    Only workaround that I have found that works with single contact chats (not group chats) is to hit the voice command button and say "Whatsapp <persons name>" and it will then let me send a message to that person via WhatsApp. But yeah the command "Reply" still does not work for me either.

    At least I'm not the only one
    11-24-2016 12:25 PM
  6. pedronev925's Avatar
    I get the same response... Reads the message out fine, asks if I want to reply then get not installed or needs updating. Running latest WhatsApp and AA In the UK

    Any ideas??
    06-09-2017 02:11 PM
  7. trafsta's Avatar
    I still haven't figured out why it is doing this Hopefully someone eventually does.
    06-12-2017 06:43 AM
  8. warrenmr's Avatar
    It is a known bug. You must have Google Hangouts installed for reply to work properly. Really. Hopefully this is fixed soon.
    06-14-2017 08:39 AM
  9. trafsta's Avatar
    That might explain it considering I have Hangouts disabled on my Galaxy S7. I will re-enable and try testing it out sometime (wife is driving my Android Auto card for next month or so, so might not be able to test it anytime soon). Thanks for the info warrenmr. Appreciated!
    06-15-2017 04:42 AM
  10. pedronev925's Avatar
    But what has hangouts got to do with WhatsApp not working properly?
    06-19-2017 09:48 AM

Similar Threads

  1. Can't turn off the do not disturb on my Droid Turbo. HELP
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 12-07-2017, 03:46 PM
  2. How many years do Android phones get OS updates
    By BlackZeppelin in forum General News & Discussion
    Replies: 24
    Last Post: 10-19-2016, 09:59 PM
  3. Replies: 2
    Last Post: 10-12-2016, 09:07 AM
  4. Move gallery to SD, blu Android 7.0 ll ?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-12-2016, 06:42 AM
  5. VoLte not working in LG G4 H818N
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-12-2016, 03:43 AM
LINK TO POST COPIED TO CLIPBOARD