1. hypnospastic's Avatar
    Recently, I have been experiencing some serious connectivity issues while using AA on my Galaxy Note8 connected via USB to my 2016 Honda Accord compatible head unit. I can connect to the head unit and launch AA however, and for an unknown reason, it suddenly loses connection. I have to unplug and plug back in the USB a few times for it to reconnect. After connecting, a few minutes pass and the connection fails.

    I purchased a new USB cable thinking that may have been the issue but it didn't fix it. I then had AA forget all cars and reconfigured it, that didn't work. I then completely removed AA and reinstalled it again, completing a fresh setup, no luck there either. I thought maybe my car USB port was malfunctioning however, I had it looked at by Honda and it is fine.

    I've also activated Developer Options/USB Debugging with no impact on my experience.

    I should note that, prior to upgrading to the Note8, I used a Galaxy S7Edge with absolutely no connectivity issues.

    Does anyone in the community have any suggestions? I've exhausted everything I can think of. Many thanks in advance. I love AA and the ability to have it on my car's displays.
    ruhban likes this.
    10-16-2017 08:26 PM
  2. Cody Hover's Avatar
    I am also experiencing the same issue with my pixel 2. The pixel 2 launches Android auto on my phone when I plug the USB into the car but the cars dashboard says phone not recognized. my iPhone worked fine with apple car play don't know why Android auto is not working I have a 2015 Hyundai sonata which supports both. also my pixel 2 will work with Bluetooth in my car and I can play music off my phone with Bluetooth but Android auto still won't work either way
    heliosue likes this.
    10-19-2017 11:24 PM
  3. Cody Hover's Avatar
    I also tried the usb debugging and that did not work as well
    10-19-2017 11:25 PM
  4. Rgrhodes09's Avatar
    I am having the same issue with my LG G6. Thanks for trying all the steps I had planned to take.... it is maddening since AA is so good when it works. For the record, and I am sure you are the same, I am at the current OS level (7.0).
    10-23-2017 07:31 AM
  5. greylock10's Avatar
    I was getting this exact error with AA on my LG G6. I tried a fair number of things (four different cables, reinstalling, rebooting, making sure the phone wasn't 100% charged) that various people suggested that didn't work, but finally switched to the second USB port in my 2017 Ford Escape.... The one in the center console, not the one on the dash. Now it works great, and I love it. But the frustration of getting it to work was hell.
    10-26-2017 07:34 PM
  6. hypnospastic's Avatar
    I am still experiencing the dropped connection issue. It worked seamlessly for an entire day. Yesterday, while trying to navigate to the airport, I connected, it was recognized and then the connection failed. It is maddening as AA is superb and I would much ra ther use it than just my phone. Afterall, my car's head unit is installed AA ready and it sucks not being able to use it.
    10-28-2017 06:33 PM
  7. hypnospastic's Avatar
    I will try and see if I can connect to my head unit via the other USB ports. I'm also due for an oil change next month and will bring it up again then too.
    10-28-2017 06:33 PM
  8. BobEmb's Avatar
    I had this problem with my ZTE Axon7 constantly disconnecting and it only stopped when I used the cable that was included with my phone. I tried several cables and spent waaay too much on a cable that I thought was high quality and it still disconnected. The only one that has consistently worked is the one that came with it. I hope this helps!
    11-01-2017 07:56 PM
  9. adz1966's Avatar
    Fixed mine in my 2018 Honda Civic Hatch. Was working fine then just wouldn't connect at all. Tried all above fixes, new cables, reset head unit and phone, nothing worked. Last night I remembered I am on the Google Maps beta, so I deleted that apps updates. I also found in my head units menu, a setting to restore Android Auto to default. Now it is working without any issues. I don't know which thing fixed it, but maybe someone else can try one fix at a time...
    11-22-2017 09:11 AM
  10. wckesq's Avatar
    Just started not working this afternoon in my 2017 Civic. Not recognized.
    umairbhatti1 likes this.
    11-27-2017 04:58 PM
  11. umairbhatti1's Avatar
    Sadly facing same issue. Have a 2017 vw golf se nav. I could connect my galaxy s7 easily but it just won't connect to my s9+. I've tried the different cables, restarting, reinstalling, clearing cache. It just won't work. It goes to a black screen like its about to start but then I see a message saying something like please make sure there isn't any permission that néed to be accepted. And then I get a connection failed message. I've tried again and again. It's really frustrating. Is it a car fault or the software android auto app on android 8.0???
    In the meantime I'd use mirrorlink but there's no google maps....

    Cant believe a fix hasn't been sent to all yet to remedy this situation. Anyone got any suggestions?
    06-30-2018 07:43 PM
  12. KrivoMT's Avatar
    I was having issues with VW Golf and OnePlus 5T. I disabled Google Maps beta and Google Play Services beta, enabled USB debugging and either of those fixed the issues by the looks of it. Android Auto connects everytime without issues and doesn't disconnect. It's only been over a day so need to see over coming week, but so far happy, as before it wouldn't connect and had to restart phone when plugged in to the car in order for it to work.
    07-21-2018 12:44 PM
  13. ruhban's Avatar
    I'm having similar issues. Plugged in and everything, I go to select AA on my car and it fades the screen as it usually does before in launches it. It brings up the navigation bar at the bottom (calls, music, maps, home, etc) and shows an animation for the rest of the UI. This animation gets repeated endlessly by the it. It's so frustrating because I've tried all sorts (forcing AA to stop on my phone, tried a new cable, restarting my phone, restarting the whole car after letting all the electronics switch off) but it keeps happening. The most annoying part is that it's random. Some days it will work flawlessly whereas other days it will carry on doing this. I'll post a link to a video later that should explain this properly.
    11-02-2018 09:11 PM
  14. ruhban's Avatar
    11-03-2018 07:18 PM
  15. hypnospastic's Avatar
    So now, all of the sudden, I am experiencing the disconnection issue in my 2018 Honda Accord EX-L. It worked fine from the day I bought my car in July 2018 and then this past Friday on our 250 mile journey the issue presented itself again numerous times. I thought it was a cable issue again so I tried the heavier, braided cord I charge my phone with and it worked fine for a good bit of our 250 mile trip home but it disconnected unexpectedly. It is so frustrating and needs addressed. Anyone else have any thoughts or possible solutions?

    FYI - I am using a Galaxy Note 9 and it is current on it's updates, as is AA and my car.
    12-26-2018 09:29 AM
  16. Easton091's Avatar
    What its worth, mine wouldn't connect last night either...
    12-26-2018 06:38 PM
  17. sswitzer's Avatar
    I just read this post that seemed to summarize solutions/discussions about this issue: How to Fix Connectivity Issues With Android Auto - Connected Car Life It is recent.

    EDIT: enabling USB debugging is working well for me... no disconnects in my last few outings.

    EDIT: no disconnects in the last 20+ trips... Highly recommend doing the USB Debugging change as described above.
    12-28-2018 11:57 AM

Similar Threads

  1. Kyocera Duraforce Pro system update stuck at 0% Android Nougat
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 08-16-2018, 01:51 PM
  2. Moto G 4 after software update, cannot connect to PC
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-11-2018, 01:15 PM
  3. should i use the auto backup on my galaxy s8
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-17-2017, 08:41 PM
  4. Can't get LG V30 to connect to wifi.
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-16-2017, 08:01 PM
  5. strange popups when connecting to charger
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-16-2017, 05:29 PM
LINK TO POST COPIED TO CLIPBOARD