1. Azothyran's Avatar
    I have the free version of GBCoid, which is a GameBoy and GameBoy Color Emulator. I was able to use the in game save function for a few hours. At one point my device locked up completely, so I had to yank my battery out and reset the device. Upon loading the emulator my ingame saves were gone. I tried creating a new save, closing down the emulator, and reloading it, but they were not kept.

    On the other hand, Gameboid, which is a GameBoy Advance emulator, handles ingame saves perfectly. Is this a flaw in GBCoid's coding or is something else at fault? I've noticed after doing a Google search that other people are having similar problems with gamesaves.

    Also, to be clear, I'm talking about ingame saves, not savestates.
    09-01-2010 10:44 AM
  2. SeeK's Avatar
    As far as I'm aware, the free versions of yongzh's emulators aren't supposed to keep save files at all, be they savestates or cartridge files. Weird that it did so initially, though.

    EDIT: Thinking carefully, I realized that I've never really tried cartridge saves on this emulator. I got the paid version pretty quickly after trying the free one.
    09-01-2010 11:57 AM
  3. Azothyran's Avatar
    Plus, the GBA emulator handles cartridge saves perfectly, so it isn't a limitation of the free version. As stated by the developer, you just can't use emulator live savestates.

    EDIT: I just checked my ROM folders and noticed that there are .sav files for my GBA games, but none are ever generated for my GBC games. I'm starting to wonder if this is a coding issue.

    EDIT 2: I received a response back from the dev. He didn't have in-game saves enabled. Apparently, the next update will allow you to do so.
    09-01-2010 02:58 PM