1. tmk 1's Avatar
    i factory reset my nexus 7 and the battery died mid reset. Now it just says "erasing". I read that factory resets can take a long time on the nexus but its been plugged in for a few days now and nothing has changed. I started it in bootloader and it said my files were corrupt. what should i do? how can i fix this?
    01-24-2017 01:39 PM
  2. dnafog's Avatar
    My Nexus 7 died in Mexico 2 years ago on the resort WiFi when I "updated a local news app"
    Bricked by software I've tried almost everything to fix it
    give up
    02-17-2017 02:22 AM
  3. anon(10250578)'s Avatar
    Have you tried reflashing the factory image?

    06-11-2017 03:54 PM
  4. anon(10250578)'s Avatar
    Have you tried reflashing your device via fastboot?
    06-11-2017 03:57 PM

Similar Threads

  1. Nexus 5X; Rebooted and no longer turns on
    By Laurent Duperval in forum Ask a Question
    Replies: 1
    Last Post: 03-03-2017, 06:52 AM
  2. What inspires you to cover Android and help run Android Central?
    By pkcable in forum General News & Discussion
    Replies: 1
    Last Post: 01-25-2017, 05:11 PM
  3. Help i cant get rid of this app
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 01-24-2017, 08:59 AM
  4. Replies: 1
    Last Post: 01-24-2017, 12:55 AM
  5. Nexus 5 Stuck After Factory Reset
    By JordanG97 in forum Google Nexus 5
    Replies: 0
    Last Post: 01-23-2017, 06:44 PM