1. chrisg_20's Avatar
    So I've scoured the internet for any answers to my question regarding Android Pay and found nothing. I'm wondering why Google Play Store is telling me, "Your device isn't compatible with this version."

    I have a Samsung Galaxy Prevail LTE, KitKat 4.4.4 and for whatever reason it informs me that my phone is incompatible but to my knowledge the requirement for Android Pay is 4.4 and above?

    If I google search Android Pay, google tells me it's already installed but I can't find it anywhere on my phone, when I click on that link it takes me to Google Wallet and then says I have to update Google Wallet and takes me to the play store page for Android Pay.

    Any ideas? Thanks
    10-24-2015 06:28 PM
  2. Kalnel's Avatar
    Isn't that phone a few years old? Only the Galaxy S6/S6 Edge/S6+ and the Note 5 (all released this year) running on Verizon, AT&T, Sprint, and T-Mobile work with it. All of those have Lollipop or newer and built-in Loop technology.

    Nope, sorry, I thought you were asking about Samsung Pay, not Android Pay.
    10-24-2015 06:53 PM

Similar Threads

  1. Looking for close up picts of silver g9287 my g928c no sam pay!
    By kuhns787 in forum Samsung Galaxy S6 edge+
    Replies: 2
    Last Post: 10-27-2015, 08:57 AM
  2. What Android Tablet is Best for Me?
    By Maria Baburkina in forum General Help and How To
    Replies: 1
    Last Post: 10-25-2015, 12:58 AM
  3. Replies: 1
    Last Post: 10-24-2015, 07:51 PM
  4. Chase Bank and Samsung Pay
    By climb in forum Samsung Galaxy Note 5
    Replies: 1
    Last Post: 10-24-2015, 04:11 PM
  5. Replies: 0
    Last Post: 10-24-2015, 01:32 PM
LINK TO POST COPIED TO CLIPBOARD