1. StoufferTheCat's Avatar
    I have the following:

    Nexus 5 - Running Android 6.0.1
    This was factory rest about two weeks ago. Not rooted, not unlocked. Just running the version of the software that was pushed out to this phone.
    The device has a pattern lock using the built-in to Android pattern system.

    Google Play App - Version 3.9

    I bank with First Direct here in the UK. I went through the process of adding the card to the app. So I started the process, half way through my bank was called who confirmed my ID and sent through a software push that completed the sign up.
    I've had emails from both Google Pay and First Direct confirming I am good to go.

    NFC is turned on. Android pay is set as the default payment type and "use default" is set to always.

    Attempt 1
    Generic PC component store. They didn't list "Android Pay" however I've been told I can use Android Pay wherever you can use contactless.
    There was a Barclaycard contactless terminal. I unlocked my phone, moved it to the terminal and nothing happened. I moved the device around, slowly, trying different positions and none of the green lights even flickered.
    I have one of the original Google bump cases for the phone (the ones that allow wireless charging to work through them, purchased from Google store, etc). I removed the phone from the case and still nothing.
    I ended up paying with card. My friend in the same store used his iPhone and Apple Pay - worked instantly.

    Attempt 2
    Costa coffee. This is actually listed as "use your Android Pay here" on the Android Pay website. Exactly the same experience. None of the green lights flickered, no amount of moving the device around the terminal got it to do anything. Tried after unlocking my phone.
    My wife used her contactless card to make the payment - this obviously just worked.

    Attempt 3
    Aldi supermarket. As above really. No amount of moving the Nexus 5 around could get the terminal to do anything - ended up paying with a card.

    So, firstly - what might I be doing wrong?
    Should I be attempting to make the payment without first unlocking the phone?
    Leaving the device inside the case. Although I tried also removing it from the case, should that be making a difference?
    Are there any other apps on a phone that can cause problems? The only other App that leaves anything obvious running is Lastpass but I cannot see that getting in the way. Are there any other potential apps that can cause problems?

    Is there a best way to test that NFC is actually working on my phone? I guess by the fact the lights on the payment terminal didn't even flicker and I'm not getting an error message it could be a hardware fault?

    Anything else anyone might be able to throw at me as a suggestion.

    06-26-2016 05:53 AM
  2. B. Diddy's Avatar
    Welcome back! Sorry for the really basic question, just want to be sure--are you certain NFC is turned on in the first place? Go to Settings>Wireless & Networks>More, and make sure the switch for NFC is on.
    06-26-2016 12:29 PM

Similar Threads

  1. Replies: 4
    Last Post: 07-20-2016, 06:15 AM
  2. Lock screen stays on when fingerprint scanner used.
    By Original Newk in forum Samsung Galaxy Note 4
    Replies: 1
    Last Post: 06-27-2016, 12:20 PM
  3. Replies: 1
    Last Post: 06-26-2016, 06:04 AM
  4. Unable to unlock password
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 06-26-2016, 04:46 AM
  5. Why does my phone shut off, to "Optimize apps?"
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 06-26-2016, 04:25 AM