1. Schlermie's Avatar
    I recently updated my AT&T Samsung Galaxy S5 to Android 6.0.1 (Marshmallow), and now Android Pay requires me to enter my backup password for unlocking the screen whenever I use it at a point of service, even if my phone is already unlocked. Previously, I only needed to unlock my phone, and Android Pay would work without needing any further credentials. How can I get it back to operating that way?
    09-17-2016 03:59 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Do you have Smart Lock on? If so, turn it off. If Smart Lock is on, and it automatically unlocks because of a Trusted Device, Trusted Location, etc., that may be when you'd still have to enter your backup password for Android Pay. I recall that being the case with my Zenfone 2. On my Nexus 6P, though, it isn't an issue, because I just use the fingerprint sensor, instead of Smart Lock.
    09-18-2016 02:39 AM
  3. mnorob's Avatar
    Have you found any solution to this? I have the same issue and have found lots of folks online with the issue but haven't found any solution yet. Very frustrating. Was working fine till 6.0.1 update. My smart lock is off.
    09-24-2016 08:55 PM
  4. B. Diddy's Avatar
    Welcome to Android Central! Maybe try going to Settings>Security>Clear Credentials​?
    09-25-2016 02:35 AM
  5. mnorob's Avatar
    My "clear credentials" is grayed out which is a whole other can of worms, so I'll work on that. Thanks.
    09-25-2016 05:23 PM
  6. mnorob's Avatar
    I followed every step I could find online to "clear credentials", but I never could. That option remains greyed out no matter what I do. I uninstalled android pay, reinstalled, reloaded card, etc. Still the same problem. Pay still asks for phone password at terminal. I got in touch with Google support via email and while initially responsive, I've heard nothing back from them in weeks. So anyways hopefully someone smarter than me can figure this out. Don't bother trying what I listed above because it didn't change anything.
    10-01-2016 12:01 AM
  7. B. Diddy's Avatar
    Do you use your phone for a corporate email account as well? If so, I wonder if the security policy from work might be causing these kinds of issues.
    10-01-2016 03:28 PM
  8. mnorob's Avatar
    I do. But it was never a problem with Lollipop. I also briefly removed my exchange account to try and "clear credentials" but that didn't work. Also interesting that doesn't seem that many are having the problem even though there are tons and tons of S5's out there. At least this isn't a super hot thread!
    10-05-2016 10:54 PM
  9. B. Diddy's Avatar
    Hmm, frustrating. I wish there was a Safe Mode where you could designate one of your installed apps to stay enabled ...
    10-06-2016 01:56 PM
  10. Schlermie's Avatar
    My "Clear credentials" button is also greyed out. Although I do read corporate email on my phone, I use an email client that doesn't require any of the corporate enterprise security certificates to be installed, so I don't think that's causing the problem. I could be wrong though. I'm working directly with the Google Support Team on this, but it's pretty slow going.
    10-10-2016 01:41 PM
  11. Schlermie's Avatar
    My comments about Android Pay being broken got escalated up through the Google Support Team as iterated through their team, but eventually, their final reply was useless:

    Thank you for contacting Google Payments service. Hope you are doing good.
    I understand that you've contacted us regarding the issue with the Android Pay app.
    I've checked with the specialists about the issue with the Android Pay app and they've confirmed that the back up password that you're being asked is working as it was intended. They've also confirmed that the back-up password is same as your Google Password.
    Please accept my sincere and unreserved apology for any inconvenience this may have caused you also for the delay.

    If you're still facing issue with the password or if you have any more questions, please reply to this email or let my team call you. We're happy to help.
    Ethan H
    The Google Support Team

    I replied to let them know this behavior only began with the recent OS update, and also pointed out that the backup password is NOT the same as my Google password, but regardless, it seems apparent they're not going to do anything about this. I left them with my comments that their new password requirement makes for a horrible, clumsy and sometimes unreliable interface.
    11-02-2016 11:03 AM
  12. Schlermie's Avatar
    My bad...I thought I had my Smart Lock turned off entirely during my testing, but I just noted I still had it enabled for a Bluetooth device. Once I disabled it for that device, now Android Pay is no longer asking me for my backup password at the NFC reader. I'm relieved to have this resolved.

    I also want to point out that after about eight exchanges with the Google Support Team, none of them ever once suggested this problem might have anything to do Smart Lock.
    Frank Szuch likes this.
    11-02-2016 11:13 AM
  13. mnorob's Avatar
    I have had a similiar experience with Google support. I am still getting passed around in their system and they email from time to time asking for the same info I have already given. After reading your post, I checked my smart lock again, and it's totally off so what resolved it for you isn't resolving it for me. I've pretty much given up. It was nice when it worked, but I'll just go back to swiping my card I guess. Thanks for the info.
    11-12-2016 03:04 PM
  14. Richard Harding's Avatar
    I had this problem because my Android Wear watch is a trusted device and keeps the phone open without needing to enter password. Android Pay apparently requires that a password be entered, and if this hasn't been done prior to checkout it will ask for it. I solved the problem with the following workaround:

    Go to Settings/Lock Screen and Security/Secure Lock Settings/secured lock time
    Set the lockout time for a relatively short interval such as 3 minutes

    Then, prior to entering the shop where you intend to use Android Pay, turn off the Bluetooth on your phone. This will temporarily disable the Smart Lock function, so that as you approach checkout, you will need to log on at the lock screen using your password. Having already logged on with your password, Android Pay will not request your password again at checkout. This has worked for me, and I just need to remember to turn on Bluetooth again when I'm done.
    11-05-2017 01:59 PM

Similar Threads

  1. Replies: 1
    Last Post: 09-18-2016, 09:17 PM
  2. Images in my phone memory
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-17-2016, 03:40 PM
  3. Replies: 0
    Last Post: 09-17-2016, 03:02 PM
  4. S7 got hot, now touch screen no longer works.
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-17-2016, 02:57 PM