1. beyondinfinity's Avatar
    I recently updated the OS of my Sony Xperia XZ premium and now it shows Android 9. When I connect my phone to a computer USB port it begins to charge but then stops charging and appears to disconnect on its own after a couple minutes sometimes less. Even though the cable is still connected. When I unplug it, then plug it back in, it starts charging again but will disconnect and stop charging after a few minutes again.

    The cable is new and it was charging my phone normally prior to the software update.

    Does anyone know how to fix this?

    I'm connecting to a Windows 10 desktop workstation if that is relevant.
    01-15-2019 01:34 PM
  2. SpookDroid's Avatar
    Does it have issues charging on a wall charger (not a computer port)? If not, maybe the USB mode needs to be changed, or you could try removing the phone's driver from your computer, plug it back in so it re-installs.
    Laura Knotek likes this.
    01-15-2019 02:36 PM

Similar Threads

  1. Help! Samsung Gear fit2 pro sensors stopped working
    By MsBlingberry in forum Samsung Gear Fit 2 Pro
    Replies: 2
    Last Post: 01-24-2019, 08:45 AM
  2. Replies: 3
    Last Post: 01-16-2019, 02:49 PM
  3. my tecno spark screen has stopped totally.
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-15-2019, 10:59 PM
  4. Paring both a watch and a headset to the phone
    By yserebro in forum Smartwatches (Non Android Wear / Wear OS)
    Replies: 1
    Last Post: 01-15-2019, 12:10 PM
  5. how do i add a philipine phone number to imo ?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-15-2019, 10:56 AM
LINK TO POST COPIED TO CLIPBOARD