1. khaos526's Avatar
    My phone will now only charge when plugged into the computer via USB since I got the update. How do I allow it to be able to transfer files rather than just to charge via USB? Can't seem to find that in the settings anywhere?

    I checked the Developer Options and have USB Debugging on, but there is no longer a USB Configuration option under there where I set it to MTP? So instead I saw the Default USB Settings and have that set to File Transfer, but nothing happens. Even downloaded USB drivers from the Samsung Website for the computer and nothing.

    Everything worked perfectly before the update and can't seem to figure out how to get file transfer between my S9 working again...
    03-19-2019 10:46 AM
  2. Rukbat's Avatar
    Pull down the notifications, tap the "Charging" notification and set that to MTP. It's one of the bugs that no one reported during the beta test. (Changing it in Developer Options should stick - sometimes it does, sometimes it doesn't.)
    03-19-2019 01:31 PM
  3. khaos526's Avatar
    See when I pull down the top Notification tab, I just see at the bottom Settings Slow Charging. Under that is Notification Settings.

    Clicking on the settings for the Charging just states how to make it charge faster if you want fast charging and that's it.

    Clicking on the Notification Settings just sows me App Badges, Do Not Disturb, LED and a few other unrelated things.

    So not sure why I'm not seeing what you mentioned (which I also saw how to guides online stating the same thing and I just don't see that option).

    Under the Developer Default USB Configuration as it's called now, the only option now listed (it had MTP before the update) is:
    Transferring Files
    USB Tethering
    Transferring images
    Charging Phone Only

    So I've tried the Transferring Files and it does nothing, much like all the others. It still is charging the phone though when I plug it in, but that's it...
    03-19-2019 03:20 PM
  4. khaos526's Avatar
    Update: Turns out all my cables suddenly aren't working right and can only charge. I was able today to test out my coworkers cable for his Note 9 and he was able to connect as it should. I tried his cable on my computer and sure enough it worked.

    No idea how 3 cables I've tried, 2 from the same company and my original from Samsung all no longer work, but that is the issue.

    Big thing with the Note 9, was that it tells you the cable isn't working properly, while my S9 doesn't mention that when I connect them...
    03-20-2019 01:00 PM
  5. ananabsemaj's Avatar
    I had this exact same problem but think I've cracked it. Note, I even tried different cables but no luck. Also, my device is a Samsung Galaxy A21S. I'm connecting to a Windows 10 PC.

    The issue was that I was connecting the phone to one of my FRONT PANEL USB ports. These are NOT USB3 so it's no surprise that the phone didn't recognize them.

    When I connected it to my monitor, which has an integrated USB hub - the phone connected no problem.

    I did leave the default USB option set to "Transferring Files" as that's what I always want but I expect the other options would work as well.

    Hope this helps someone else.
    11-05-2021 10:10 AM

Similar Threads

  1. My phone seems to be disintegrating before my eyes
    By rld082982 in forum Essential Phone
    Replies: 5
    Last Post: 05-03-2019, 12:57 PM
  2. Case comes with the Fold
    By icellphones in forum Samsung Galaxy Fold
    Replies: 3
    Last Post: 03-28-2019, 07:43 AM
  3. decided to go back to Pie
    By robinhelenehebert in forum Google Pixel 3 & Pixel 3 XL
    Replies: 3
    Last Post: 03-19-2019, 01:40 PM
  4. Having Issues With Your Fingerprint Sensor? Try this...
    By strikeIII in forum Samsung Galaxy S10 & S10+
    Replies: 11
    Last Post: 03-19-2019, 12:19 PM