08-11-2013 09:53 PM
237 12345 ...
tools
  1. dmau5's Avatar
    the thing is not recognizing that my phone is plugged in. My computer does but the swm doesnt. any suggestions?
    01-06-2011 08:13 PM
  2. xperiaz's Avatar
    Holy smokes I got it to work!!

    Here's what I did:


    -With Xperia x10 UNPLUGGED,
    -Went into Device Manager
    -Clicked on VIEW, clicked on SHOW HIDDEN DEVICES
    -Highlighted SEMC Mass Storage Device, clicked DELETE

    -Hooked up Xperia x10 to USB cable
    -FINALLY GOT THE OPTION TO CHOOSE MY DRIVERS AT THIS POINT!! (YAY!)
    -Directed Device Manager to x10a drivers I downloaded here.
    -Computer installed Sony Ericsson sa0101, underneath it said Sony Ericsson sa0101 ADB Interface Driver
    -Computer also installed SEMC Mass Storage Device AGAIN, but I clicked on and DISABLED IT
    -Went into SWM, ran and passed all diagnostics
    -Tried to install Backup and Restore apk by Sony Ericsson, got a No Free Space error
    -Long story short, I opened a DOS prompt, navigated to c:\AC_SWM
    -Changed the name of Backup and Restore.apk to bakup.apk and copied it INTO AC_SWM folder, NOT PAYLOAD folder
    -Typed in this command: adb install bakup.apk
    -SUCCESS!!
    -Went to Applications on my phone, and its there!!

    HOPE THAT HELPS!!

    (SORRY GB, EDITED OUT MY ORIGINAL TEXT)
    01-06-2011 09:02 PM
  3. Jerry Hildenbrand's Avatar
    This is wierd I know it worked before here is the error message details. I was trying to do the diagnostics to make sure it saw everything and this is what happens. Still getting the no space on phone error on my other pc. Phone has 10gig free and memory card has 13gig free
    <snip>.
    Captivate?

    Your second error is a .NET4 issue with your PC. You can try uninstalling and reinstalling .NET4 (per Microsoft).

    The first issue just happens sometimes. I can't recreate it, and 9 times out of 10 it's on a Captivate. Dig through the download thread, some have found a work around.

    Methinks ever1 is on vacation still??

    PC still doesnt recognize phone when hooked up in USB debug mode =(
    Busy with CES. Everyone with connection errors, please please please read the first posts in this thread. Everything you need to know is in there.
    01-06-2011 09:09 PM
  4. xperiaz's Avatar

    Everyone with connection errors, please please please read the first posts in this thread. Everything you need to know is in there.
    Bro, you didn't bother to read my previous posts detailing my exact problem. It's not like I just plugged it in and started complaining when it didn't work. I'm not going to rehash what I already explained before - it's moot anyway. All I can say is 'Thanks' for any help you would have given, if not for being so busy.

    One thing I realized, is I actually sideloaded apps without Sideload Wonder Machine. All you really need is the ADB.exe (Android Debug Bridge) and the proper drivers for your phone, and you can do it EASILY in a DOS prompt.
    01-08-2011 12:29 PM
  5. Williamjohanson12345's Avatar
    I have the xperia x10
    i have android 1.6
    all drivers are installed, i am in debugging mode
    i rebooted my computer (windows 7)
    it cant find my device.
    what do?
    01-10-2011 08:59 PM
  6. mherron54's Avatar
    Trying to get it rolling on a mac and keep getting errors.

    Phone is rooted.

    type bash menu.sh
    Select 1 - push app to phone
    finds my apk file

    says
    Pushing to phone...
    sudo: ./adb: command not found
    Pushed! You may need to reboot your phone to see the change.


    When I reboot, I see nothing.

    Then I tried 21 for the rooted phone

    I get Remounting /system to allow pushing of the app...
    sudo: ./adb: command not found

    Did you get the message 'Remount Succeeded' above? (y or n)


    I click N because I didn't get that message

    Then I see

    Please reboot into recovery mode and try again. echo Press enter when you are in recovery. read enterKey
    sudo: ./adb: command not found
    Pushing to system...
    sudo: ./adb: command not found

    Pushed! Thanks for using Sideload Wonder Machine.


    NO matter what I do, I can't seem to get it working.

    Thanks
    01-12-2011 03:18 PM
  7. zacharid's Avatar
    Hi, I downloaded the drivers .net 4 and I got SWM to work once, I have an xperia x10. I can't figure out why it only worked once tho and wont work again.
    01-13-2011 03:06 PM
  8. Tony.Booth.nz's Avatar
    Hi, I have triad all of the above to no avail. When I click on "GO" nothing happens -zero zilch nada. Running Windows 7 and trying to load to an HTC Desire. Any suggestions?
    TonyB
    01-14-2011 07:59 PM
  9. Jerry Hildenbrand's Avatar
    I can not help get the drivers for each particular phone installed. That is a Windows issue. Many device manufacturers (Sony Ericsson, Samsung) make this very difficult for the average user, and I feel your pain. To correct USB driver issues, you will need to contact your device manufacturer for installation help, or ask in the correct device section here in the forums.

    I can say that if you use an HTC device, installing HTC sync will install your drivers correctly. If you use a Nexus One, or a Nexus S, you will need to download your drivers from here and follow the installation procedure.

    If your drivers are installed correctly, the diagnostic tool will connect, and show your phone's software serial number. If this doesn't happen, it's because the drivers are not installed correctly. All this part of the application does is connect to the driver, and it's a yes/no situation -- as long as the USB diagnostic runs, the rest is up to your USB driver.

    @mherron54 -- sorry, but the Mac version was not written by me. I don't program for, or troubleshoot issues with a Mac. My advice? Check and make sure you have the latest version of Sun Java installed (you probably do), download the Android SDK, install the tools from the SDK manager once downloaded, then from the terminal:
    Code:
    <path-to-sdk>\tools\adb install <path\to\filename.apk>
    For Mac and Linux, it's actually easier to just use the SDK and the terminal on your computer.

    @zacharid, @Tony.Booth.nz -- please run the diagnostic tools and let me know the output of each.
    01-14-2011 08:38 PM
  10. Rockyusa's Avatar
    I have done communication test and all looks good. when I try to install the ap I receive error not enough memory to complete the install. working on samsung captivate. any ideias on how to work around this? It appears like ATT has set some limit on what can be on the phone. Help please I was installing adobe flash for android 2.1
    01-18-2011 05:00 PM
  11. angel_luck2004's Avatar
    HI..I have Xperia X10 and I got it work with SWM.

    Here is what needed..You need to have the drivers for the phone..{If you get the message that your drivers are up to date..do this..after you uninstalled the drivers donot connect your system to internet until you load the drivers from SEMC_Signed folder...this way system will not loaded the drivers automatically}

    You need to have .NET V4 loaded then load SWM.

    {FYI: Here is the issue : If I try to connect the phone and try to locate it using SWM now..The device cannot be find in SWM.}

    After all the above done{i.e..Drivers, .NET V4 and SWM} try to load SDK software now..When you load this SDK it detects the SWM{ADB} and tries to loaded some plugins..

    Once the SDK is loaded{I loaded all the versions, but I guess not required}
    try to run SWM again by connecting you phone..

    It will show you the device..It worked for me..
    01-19-2011 07:15 PM
  12. beachswt21's Avatar
    I've been on the fence on the best way to root my xperia x10. I found this app called easy root that would give me the option to unroot, which I want, but I've spent hours trying to get my phone connected and set up to use the sideload program and now I have one last error I dont know what to do with. All the diagnostics check out but when I go to download the apk it says: FAILURE [Install_failed_older_sdk]. I downloaded the sdk updates for 1.6. Is there something else you suggest.
    01-21-2011 02:24 AM
  13. drinkhere's Avatar
    i'm trying to install a app and this is what it tells me
    [INSTALL_FAILED_OLDER_SDK] someone please help i'm running a sumsung fascinate rooted 2.1
    01-29-2011 06:12 PM
  14. Jerry Hildenbrand's Avatar
    I've been on the fence on the best way to root my xperia x10. I found this app called easy root that would give me the option to unroot, which I want, but I've spent hours trying to get my phone connected and set up to use the sideload program and now I have one last error I dont know what to do with. All the diagnostics check out but when I go to download the apk it says: FAILURE [Install_failed_older_sdk]. I downloaded the sdk updates for 1.6. Is there something else you suggest.
    i'm trying to install a app and this is what it tells me
    [INSTALL_FAILED_OLDER_SDK] someone please help i'm running a sumsung fascinate rooted 2.1
    You're trying to install an app that's needs Froyo.
    01-29-2011 06:14 PM
  15. Zealot099's Avatar
    Holy smokes I got it to work!!

    Here's what I did:


    -With Xperia x10 UNPLUGGED,
    -Went into Device Manager
    -Clicked on VIEW, clicked on SHOW HIDDEN DEVICES
    -Highlighted SEMC Mass Storage Device, clicked DELETE

    -Hooked up Xperia x10 to USB cable
    -FINALLY GOT THE OPTION TO CHOOSE MY DRIVERS AT THIS POINT!! (YAY!)
    -Directed Device Manager to x10a drivers I downloaded here.
    -Computer installed Sony Ericsson sa0101, underneath it said Sony Ericsson sa0101 ADB Interface Driver
    -Computer also installed SEMC Mass Storage Device AGAIN, but I clicked on and DISABLED IT
    -Went into SWM, ran and passed all diagnostics
    -Tried to install Backup and Restore apk by Sony Ericsson, got a No Free Space error
    -Long story short, I opened a DOS prompt, navigated to c:\AC_SWM
    -Changed the name of Backup and Restore.apk to bakup.apk and copied it INTO AC_SWM folder, NOT PAYLOAD folder
    -Typed in this command: adb install bakup.apk
    -SUCCESS!!
    -Went to Applications on my phone, and its there!!

    HOPE THAT HELPS!!

    (SORRY GB, EDITED OUT MY ORIGINAL TEXT)
    I was wondering if you could tell me where to find the SEMC Mass Driver device, i can't seem to find it
    01-31-2011 06:08 PM
  16. MoneyAddyct's Avatar
    Hello. I ran through the troubleshooting section and I can tell you that my drivers are installed, the phone is in debugging mode, and mass storage isn't enabled. I then ran diagnostics and clicked on the test driver status. I received an unhandled exception with the following details:

    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.

    ************** Exception Text **************
    System.ComponentModel.Win32Exception (0x80004005): The system cannot find the file specified
    at System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo)
    at System.Diagnostics.Process.Start()
    at System.Diagnostics.Process.Start(ProcessStartInfo startInfo)
    at AC_SWM.frmDiag.Button1_Click(Object sender, EventArgs e)
    at System.Windows.Forms.Control.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
    at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
    at System.Windows.Forms.Control.WndProc(Message& m)
    at System.Windows.Forms.ButtonBase.WndProc(Message& m)
    at System.Windows.Forms.Button.WndProc(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


    ************** Loaded Assemblies **************
    mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
    ----------------------------------------
    AC_SWM
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Users/Justin/Desktop/AC_SWMv1.1_10_30_BETA/AC_SWM/AC_SWM.exe
    ----------------------------------------
    Microsoft.VisualBasic
    Assembly Version: 10.0.0.0
    Win32 Version: 10.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
    ----------------------------------------
    System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
    ----------------------------------------
    System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
    ----------------------------------------
    System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    ----------------------------------------
    System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    ----------------------------------------
    System.Runtime.Remoting
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
    ----------------------------------------

    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.

    For example:

    <configuration>
    <system.windows.forms jitDebugging="true" />
    </configuration>

    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.


    What does this mean?? Thanks!
    02-02-2011 01:49 AM
  17. MoneyAddyct's Avatar
    Update: I put the AC_SWM folder in C:\ and now I don't get an error message; however, it still says the device is offline.
    02-02-2011 05:11 AM
  18. MoneyAddyct's Avatar
    Update: I tried using a USB port connected directly to my motherboard and now I have the same device listed twice, one offline and one online. When I try to sideload an app I get the error message: More than one device and emulator....Now what?
    02-02-2011 11:08 AM
  19. AceLOD's Avatar
    hi all im new to the android world. i have an at&t samsung captivate with 2.1 update 1 and it is rooted. i am trying to load an apk on my phone with the use of the sideloader. i received a message stating: failure [install_failed_insufficient_storage]. i have 13gb of internal sd card , an external sd card of 4gb and 1.67gb of internal storage available. can someone please help?
    02-02-2011 11:16 PM
  20. trevshand's Avatar
    I've installed a few apps already and things are fine. However, now I'm trying to install one more and keep getting the error Failure[Install_Parse_Failed_No_Certificates]. How do fix this?
    02-03-2011 11:59 PM
  21. epicKA8's Avatar
    hey guys, i seem to have followed all the advice posted here,

    i got a inspire 4g from att, i'm still getting the "can't find 'payload\*.apk to install

    any suggestions or am i pretty much stuck and have to root it?
    02-16-2011 10:30 PM
  22. evaradar's Avatar
    Hello Everyone.

    I am using a Motorola Atrix 4G. I've installed the Motorola ADB drivers from Motorola, installed .Net Framework 4, extracted the beta version to my C: drive, set the phone to USB Debugging mode.

    After doing everything I get the following error (see attached image).

    I also get the following when I hit diagnostics:

    Code:
    
    
    
    See the end of this message for details on invoking 
    just-in-time (JIT) debugging instead of this dialog box.
    
    ************** Exception Text **************
    System.ComponentModel.Win32Exception (0x80004005): The system cannot find the file specified
       at System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo)
       at System.Diagnostics.Process.Start()
       at System.Diagnostics.Process.Start(ProcessStartInfo startInfo)
       at AC_SWM.frmDiag.Button1_Click(Object sender, EventArgs e)
       at System.Windows.Forms.Control.OnClick(EventArgs e)
       at System.Windows.Forms.Button.OnClick(EventArgs e)
       at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
       at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
       at System.Windows.Forms.Control.WndProc(Message& m)
       at System.Windows.Forms.ButtonBase.WndProc(Message& m)
       at System.Windows.Forms.Button.WndProc(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
    
    
    ************** Loaded Assemblies **************
    mscorlib
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
        CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
    ----------------------------------------
    AC_SWM
        Assembly Version: 1.0.0.0
        Win32 Version: 1.0.0.0
        CodeBase: file:///C:/Users/Emperuman/Desktop/AC_SWMv1.1_10_30_BETA/AC_SWM/AC_SWM.exe
    ----------------------------------------
    Microsoft.VisualBasic
        Assembly Version: 10.0.0.0
        Win32 Version: 10.0.30319.1 built by: RTMRel
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
    ----------------------------------------
    System
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.1 built by: RTMRel
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
    ----------------------------------------
    System.Core
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.1 built by: RTMRel
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
    ----------------------------------------
    System.Windows.Forms
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.1 built by: RTMRel
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    ----------------------------------------
    System.Drawing
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.1 built by: RTMRel
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    ----------------------------------------
    System.Runtime.Remoting
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
    ----------------------------------------
    
    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.
    
    For example:
    
    <configuration>
        <system.windows.forms jitDebugging="true" />
    </configuration>
    
    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.
    *Note the previous version works fine. Its only the beta. Am I doing something wrong here?

    Thanks
    03-09-2011 10:06 PM
  23. stephlynn0215's Avatar
    hi, im new to android phones, i just purchased the htc inspire a few days ago. im trying to figure out how to sideload apps. but i seem to be stuck at installing the driver. i found the link to the htc site which gives the link to download the driver, downloaded it, but when i run the diagnostics i cannot get my phone to show up. i dont understand what i did wrong?

    this is what shows up:

    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
    @ @
    @ checking Windows driver @
    @ @
    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

    adb server is out of date. killing...
    * daemon started successfully *
    List of devices attached



    You should see the serial number of your Android
    phone above. If so, your Windows USB driver is
    set up correctly. If you do not see a serial
    number above, the SWM will be unable to install
    applications until your Windows USB driver is
    set up correctly. Please see your phone
    manufacturers website for further instruction.

    Press any key to continue . . .
    03-10-2011 02:03 PM
  24. cr8dv8's Avatar
    Hey, this is a great program, and wanted to say thanks, but I have an issue that I can't seem to get past.

    Long story short - I had rooted my Motorola Charm, and accidentally uninstalled Android Marketplace. (Word of advice - never use uninstaller for root on a bus on a bumpy road.)

    i had gotten a vending.apk off the web, but when I went to use it, it came up with the older sdk failure - from reading here I see that I need an earlier version of vending.apk for my Eclair phone. I've downloaded a couple different ones, with no luck, I keep getting the older sdk failure message from SWM. Can anyone point me in the right direction?
    03-12-2011 07:02 PM
  25. fitznacio#AC's Avatar
    Question, since I am unable to get the Android SWM to recognize my phone when I perform the diagnostics should I uninstall the samsung driver's and Microsoft Net.framework file and the A_SWM and try again? I confirmed that the A_SWM was moved into the c:// root file, made sure the phone Samsung cappy was on debug mode however I have not having any luck. Is there anyone that has gotten past this roadblock?
    03-16-2011 11:05 AM
237 12345 ...
LINK TO POST COPIED TO CLIPBOARD