08-11-2013 09:53 PM
237 ... 23456 ...
tools
  1. aaronmig's Avatar
    hi, im new to android phones, i just purchased the htc inspire a few days ago. im trying to figure out how to sideload apps. but i seem to be stuck at installing the driver. i found the link to the htc site which gives the link to download the driver, downloaded it, but when i run the diagnostics i cannot get my phone to show up. i dont understand what i did wrong?
    . . .

    Any luck? I'm in the same boat...
    03-21-2011 03:19 PM
  2. omg_its_kerri's Avatar
    Hello Everyone.

    I am using a Motorola Atrix 4G. I've installed the Motorola ADB drivers from Motorola, installed .Net Framework 4, extracted the beta version to my C: drive, set the phone to USB Debugging mode.

    After doing everything I get the following error (see attached image).

    I also get the following when I hit diagnostics:

    Code:
    
    
    
    See the end of this message for details on invoking 
    just-in-time (JIT) debugging instead of this dialog box.
    
    ************** Exception Text **************
    System.ComponentModel.Win32Exception (0x80004005): The system cannot find the file specified
       at System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo)
       at System.Diagnostics.Process.Start()
       at System.Diagnostics.Process.Start(ProcessStartInfo startInfo)
       at AC_SWM.frmDiag.Button1_Click(Object sender, EventArgs e)
       at System.Windows.Forms.Control.OnClick(EventArgs e)
       at System.Windows.Forms.Button.OnClick(EventArgs e)
       at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
       at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
       at System.Windows.Forms.Control.WndProc(Message& m)
       at System.Windows.Forms.ButtonBase.WndProc(Message& m)
       at System.Windows.Forms.Button.WndProc(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
    
    
    ************** Loaded Assemblies **************
    mscorlib
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
        CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
    ----------------------------------------
    AC_SWM
        Assembly Version: 1.0.0.0
        Win32 Version: 1.0.0.0
        CodeBase: file:///C:/Users/Emperuman/Desktop/AC_SWMv1.1_10_30_BETA/AC_SWM/AC_SWM.exe
    ----------------------------------------
    Microsoft.VisualBasic
        Assembly Version: 10.0.0.0
        Win32 Version: 10.0.30319.1 built by: RTMRel
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
    ----------------------------------------
    System
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.1 built by: RTMRel
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
    ----------------------------------------
    System.Core
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.1 built by: RTMRel
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
    ----------------------------------------
    System.Windows.Forms
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.1 built by: RTMRel
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    ----------------------------------------
    System.Drawing
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.1 built by: RTMRel
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    ----------------------------------------
    System.Runtime.Remoting
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
    ----------------------------------------
    
    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.
    
    For example:
    
    <configuration>
        <system.windows.forms jitDebugging="true" />
    </configuration>
    
    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.
    *Note the previous version works fine. Its only the beta. Am I doing something wrong here?

    Thanks
    Any luck with this? I'm getting the same thing on my Inspire...
    03-27-2011 07:04 PM
  3. Jerry Hildenbrand's Avatar
    Any luck? I'm in the same boat...
    Any luck with this? I'm getting the same thing on my Inspire...
    Extract the entire SWM folder to your C drive. Not wherever you have it now.
    03-27-2011 07:38 PM
  4. dwade62's Avatar
    Hello Everyone.

    I am using a Motorola Atrix 4G. I've installed the Motorola ADB drivers from Motorola, installed .Net Framework 4, extracted the beta version to my C: drive, set the phone to USB Debugging mode.

    After doing everything I get the following error (see attached image).

    I also get the following when I hit diagnostics:

    Code:
    
    
    
    See the end of this message for details on invoking 
    just-in-time (JIT) debugging instead of this dialog box.
    
    ************** Exception Text **************
    System.ComponentModel.Win32Exception (0x80004005): The system cannot find the file specified
       at System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo)
       at System.Diagnostics.Process.Start()
       at System.Diagnostics.Process.Start(ProcessStartInfo startInfo)
       at AC_SWM.frmDiag.Button1_Click(Object sender, EventArgs e)
       at System.Windows.Forms.Control.OnClick(EventArgs e)
       at System.Windows.Forms.Button.OnClick(EventArgs e)
       at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
       at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
       at System.Windows.Forms.Control.WndProc(Message& m)
       at System.Windows.Forms.ButtonBase.WndProc(Message& m)
       at System.Windows.Forms.Button.WndProc(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
    
    
    ************** Loaded Assemblies **************
    mscorlib
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
        CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
    ----------------------------------------
    AC_SWM
        Assembly Version: 1.0.0.0
        Win32 Version: 1.0.0.0
        CodeBase: file:///C:/Users/Emperuman/Desktop/AC_SWMv1.1_10_30_BETA/AC_SWM/AC_SWM.exe
    ----------------------------------------
    Microsoft.VisualBasic
        Assembly Version: 10.0.0.0
        Win32 Version: 10.0.30319.1 built by: RTMRel
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
    ----------------------------------------
    System
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.1 built by: RTMRel
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
    ----------------------------------------
    System.Core
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.1 built by: RTMRel
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
    ----------------------------------------
    System.Windows.Forms
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.1 built by: RTMRel
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    ----------------------------------------
    System.Drawing
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.1 built by: RTMRel
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    ----------------------------------------
    System.Runtime.Remoting
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
    ----------------------------------------
    
    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.
    
    For example:
    
    <configuration>
        <system.windows.forms jitDebugging="true" />
    </configuration>
    
    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.
    *Note the previous version works fine. Its only the beta. Am I doing something wrong here?

    Thanks

    I've followed the same procedures as evaradar has said they did. The AC_SWM beta folder is extracted to my C drive.
    The files in the folder are:
    Payload
    AC_SWM
    adb
    AdbWinApi.dll
    AdbWinUsbApi.dll
    filecheck
    gpl
    loader
    README
    reloader
    usbdiag

    I'm getting the same error message as evaradar posted when I try to install an Angry Birds Rio APK. I also get the same message when I try the diagnostics.

    This is the error message:

    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.

    ************** Exception Text **************
    System.IO.DirectoryNotFoundException: Could not find a part of the path 'C:\AC_SWM\payload\to_install.apk'.
    at Microsoft.VisualBasic.FileSystem.FileCopy(String Source, String Destination)
    at AC_SWM.frmMain.btnChoose_Click(Object sender, EventArgs e)
    at System.Windows.Forms.Control.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
    at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
    at System.Windows.Forms.Control.WndProc(Message& m)
    at System.Windows.Forms.ButtonBase.WndProc(Message& m)
    at System.Windows.Forms.Button.WndProc(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


    ************** Loaded Assemblies **************
    mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
    ----------------------------------------
    AC_SWM
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Sideloader%20Wonder%20Machine%20AC_SWMv1.1_10_30_BETA/AC_SWM/AC_SWM.exe
    ----------------------------------------
    Microsoft.VisualBasic
    Assembly Version: 10.0.0.0
    Win32 Version: 10.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
    ----------------------------------------
    System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    ----------------------------------------
    System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    ----------------------------------------
    System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
    ----------------------------------------
    System.Runtime.Remoting
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
    ----------------------------------------
    System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
    ----------------------------------------

    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.

    For example:

    <configuration>
    <system.windows.forms jitDebugging="true" />
    </configuration>

    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.
    03-29-2011 01:03 AM
  5. Jerry Hildenbrand's Avatar
    AC_SWM
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Sideloader%20Wonder%20Machine%20AC_SWMv1.1_10_30_BETA/AC_SWM/AC_SWM.exe
    ----------------------------------------
    Look at the path of the file that's running, it translates to:
    C:/Sideloader Wonder Machine AC_SWMv1.1_10_30_BETA/AC_SWM/AC_SWM.exe
    It needs to be:
    C:/AC_SWM/AC_SWM.exe
    Open the zip file, and drag the whole AC_SWM folder to your C: drive, without renaming anything.
    dwade62 likes this.
    03-29-2011 01:18 AM
  6. dwade62's Avatar
    Look at the path of the file that's running, it translates to:


    It needs to be:


    Open the zip file, and drag the whole AC_SWM folder to your C: drive, without renaming anything.
    That did it!! I dragged it to the C drive as you said, instead of extracting it to the drive. I clicked on Angry Birds Rio and it installed perfectly.

    THANK YOU soo much!!
    03-29-2011 02:42 AM
  7. aa9vi's Avatar
    I tried everything AmsDiane said but I still get the INSTALL_FAILED_INSUFFICIENT_STORAGE error. I have AT&T.

    I installed the MOT drivers to the WinXP SP3 PC and they work. I am using AC_SWMv1.1_10_30_BETA.zip. I extracted the AC_SWM folder to C:\
    I copied the .apk to the C:\AC_SWM foler

    Phone is set to:
    USB Mass Storage
    Settings->Applications->Development->USB Debugging on

    phone is MB860 (Atrix)
    Android v 2.2.1

    btw, the Diagnostics on the SWM application show no errors also.

    what should I try now?
    03-30-2011 03:21 PM
  8. Seeky25's Avatar
    HTC Inspire. Also getting the insufficient storage message. I have 1.01 GB free phone memory, 7GB SD storage. The app isn't that big. Not sure what's up. I've tried charge only, mass storage and HTC sync connections. No dice. Any advice? Also not seeing any errors in diagnostics. Finding phone SN just fine.
    03-31-2011 10:29 PM
  9. nolito2010's Avatar
    i have a motorola backflip for att and when i run swm and it starts to install the app it gives me this:

    installing application

    624 kb/s <0 bytes in 1999519.003s>
    pkg: /data/local/tmp/to_install.apk
    Failure [install_failed_older_sdk]

    what does this mean? ive looked everywhere and i just cant find an answer
    04-02-2011 04:25 AM
  10. Jerry Hildenbrand's Avatar
    i have a motorola backflip for att and when i run swm and it starts to install the app it gives me this:

    installing application

    624 kb/s <0 bytes in 1999519.003s>
    pkg: /data/local/tmp/to_install.apk
    Failure [install_failed_older_sdk]

    what does this mean? ive looked everywhere and i just cant find an answer
    The app won't work with your version of Android.

    [install_falied_older_sdk] means you did everything right, but the app is for a newer build of Android than the one you're running on your phone.
    04-02-2011 12:56 PM
  11. Jerry Hildenbrand's Avatar
    I tried everything AmsDiane said but I still get the INSTALL_FAILED_INSUFFICIENT_STORAGE error. I have AT&T.

    I installed the MOT drivers to the WinXP SP3 PC and they work. I am using AC_SWMv1.1_10_30_BETA.zip. I extracted the AC_SWM folder to C:\
    I copied the .apk to the C:\AC_SWM foler

    Phone is set to:
    USB Mass Storage
    Settings->Applications->Development->USB Debugging on

    phone is MB860 (Atrix)
    Android v 2.2.1

    btw, the Diagnostics on the SWM application show no errors also.

    what should I try now?
    HTC Inspire. Also getting the insufficient storage message. I have 1.01 GB free phone memory, 7GB SD storage. The app isn't that big. Not sure what's up. I've tried charge only, mass storage and HTC sync connections. No dice. Any advice? Also not seeing any errors in diagnostics. Finding phone SN just fine.
    What does the file diagnostics say? Just to be sure you have everything in the right folders
    04-02-2011 12:57 PM
  12. aa9vi's Avatar
    jeesh... I figured out the solution...
    only put ONE app in the c:\ac_swm\payload folder!

    then install and it is successful!
    04-02-2011 09:29 PM
  13. dave9851's Avatar
    Keep getting a "adb is not recognized as an internal or external command, operable program or batch file."


    Help!
    04-11-2011 08:25 PM
  14. DroidXcon's Avatar
    Keep getting a "adb is not recognized as an internal or external command, operable program or batch file."


    Help!
    are you using the new ACSWM that was posted today?
    04-11-2011 08:27 PM
  15. dave9851's Avatar
    Yes I am. I have everything set up properly, but just get that error when I click install.
    04-11-2011 08:33 PM
  16. DroidXcon's Avatar
    Yes I am. I have everything set up properly, but just get that error when I click install.
    please hit the troubleshoot button, and check files
    04-11-2011 08:36 PM
  17. dave9851's Avatar
    please hit the troubleshoot button, and check files

    Already did, says everything is good.
    04-11-2011 08:56 PM
  18. DroidXcon's Avatar
    how about when you check drivers?
    04-11-2011 09:01 PM
  19. dave9851's Avatar
    how about when you check drivers?
    Yep, all is good. Just get that error when I try to install an app with the sideloader app. Everything is connected fine, have drivers, usb debugging on, .net framework, etc etc
    04-11-2011 09:08 PM
  20. Jerry Hildenbrand's Avatar
    Keep getting a "adb is not recognized as an internal or external command, operable program or batch file."


    Help!
    Already did, says everything is good.
    Yep, all is good. Just get that error when I try to install an app with the sideloader app. Everything is connected fine, have drivers, usb debugging on, .net framework, etc etc
    grab a screenshot of C:\AC_SWM\ contents and post it up. Something is missing.
    04-11-2011 09:38 PM
  21. dave9851's Avatar
    grab a screenshot of C:\AC_SWM\ contents and post it up. Something is missing.

    Same error when I type that in cmd. I'm a noob so I'm probably doing it wrong.
    04-11-2011 09:47 PM
  22. DroidXcon's Avatar
    Same error when I type that in cmd. I'm a noob so I'm probably doing it wrong.
    Check your pm inbox please

    Sent from my ADR6400L using Tapatalk
    04-11-2011 09:48 PM
  23. Jerry Hildenbrand's Avatar
    Same error when I type that in cmd. I'm a noob so I'm probably doing it wrong.
    Fair enough



    See if your folder looks like mine. Open My Computer, then C drive, then AC_SWM
    04-11-2011 09:51 PM
  24. dave9851's Avatar
    Yep I have every single one of those files.
    DroidXcon likes this.
    04-11-2011 09:54 PM
  25. Jerry Hildenbrand's Avatar
    Yep I have every single one of those files.
    Thanks to Dave, this is fixed. I inadvertently used an old scripts directory when i built the installer. The download links now have the correct scripts

    And it's not abusing the thanks button to thank him He saved me a huge headache by not just giving up
    04-12-2011 02:04 AM
237 ... 23456 ...
LINK TO POST COPIED TO CLIPBOARD