1. Android Central Question's Avatar
    My NVIDIA Shield and TV which is running AndroidTV recognize usb drive but gives me an error "corrupt, select to fix" which only takes me to a screen showing the drive has been ejected. The drive is recognized on pc just fine.

    Doesn't matter which way I format. The drive will work for a couple weeks, then one day it will give me this issue which can only be solved be a full reformatting.

    Anyone else have this issue?
    10-03-2021 07:07 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Does this happen with other USB drives as well?

    Please register on this forum, which will allow you to engage in discussion more easily, as well as post images. https://forums.androidcentral.com/as...community.html
    10-03-2021 12:48 PM
  3. bclasen1's Avatar
    Appreciate the quick reply.

    I plug hard drive into a ANDROID TV device, it says 'drive is corrupt, click to fix' and clicking takes me to a screen which just says the device is safely ejected.

    Yes, this happens periodically with both wall powered hard drives (like a WD Elements) and usb powered hard drives. It mostly happens when the hard drive is moved from being connected a PC to connect to android tv (NVIDIA SHIELD, or ANDROID TV running on a TV) but also happens when unplugging from SHIELD and plugging into TV. Safely ejecting before disconnection does not prevent the issue.
    Attempted Remedies: 1. Plugging into a PC, reformatting (all formats such as exfat, fat 32 etc attempted), and plugging back into Android TV.
    2. Rebooting Android TV (SHIELD and TV devices) and then plugging in hard drive.


    Android just decides, at some point, that its no longer corrupted (as in, I leave the hard drive unplugged for a week out of frustration, I plug it in, and voila it works for no reason). I have seen this issue posted around reddit and other such sites, and have yet to see anyone with a theory behind the actual issues. One person suggested its windows 10 because using a windows 8 device to reformat the device fixed the issue for them but that seems odd.

    Appreciate any ideas or theories.
    10-03-2021 07:11 PM
  4. B. Diddy's Avatar
    Have you tried cleaning the Shield's USB port? Use a can of compressed air to blow it out, and a small cotton swab dipped in rubbing alcohol to clean the contacts.
    10-03-2021 07:39 PM
  5. mustang7757's Avatar
    Welcome to AC!

    [I moved this to Android TV forums for specific traffic]
    10-03-2021 11:21 PM
  6. bclasen1's Avatar
    Appreciate the reply. I have attempted using different cables and blowing on the port but it did not solve the issue.
    10-06-2021 11:04 AM
  7. B. Diddy's Avatar
    Since it happens on different Android devices, and also happens with different USB drives, then I'm thinking that it's a bug with how USB drive support is implemented. You might try contacting NVIDIA support and see if they have any insight.
    10-06-2021 11:14 PM
  8. bclasen1's Avatar
    Ok. Appreciate it.
    B. Diddy likes this.
    10-07-2021 08:31 AM

Similar Threads

  1. Android Phone with a physical keyboard?
    By Kayza in forum Buyers Guides
    Replies: 10
    Last Post: 10-03-2021, 11:28 PM
  2. Delete trending searches from samsung galaxy j5 android phone
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 10-03-2021, 12:59 PM
  3. What is com.android.mms
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 10-03-2021, 12:55 PM
  4. Replies: 5
    Last Post: 10-02-2021, 09:11 PM
  5. Why my music disappear in my Android
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 10-02-2021, 12:54 PM
LINK TO POST COPIED TO CLIPBOARD