1. Melissa Slay's Avatar
    I have a W95 box and it was working fine. I unplugged it to move it and now it won't work. No red or blue light comes on. Also have 1 mxq pro and 1 mxq same problem. Any suggestions is this fixable
    08-13-2018 08:30 AM
  2. Rukbat's Avatar
    Check the outlet. Plug in a lamp or something.

    Move the box back and plug it into the outlet it used to be plugged into. (If it works there, but not in the new location, the outlet may be bad. Some things connect, some don't.)

    Make sure the wire isn't frayed, chewed on, etc. Moving it may have stopped it from working.
    08-13-2018 11:58 AM

Similar Threads

  1. Google pixel 2 xl pinkish hue to always on display only when in always on mode.
    By Android Central Question in forum Ask a Question
    Replies: 5
    Last Post: 08-14-2018, 08:51 AM
  2. Manager on the Alcatel Pulsemix will not download or update any apps. Please help
    By Android Central Question in forum Ask a Question
    Replies: 8
    Last Post: 08-14-2018, 05:27 AM
  3. Manager on the Alcatel Pulsemix will not download or update any apps. Please help
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 08-13-2018, 07:07 AM
  4. Battery drained in few hiurs after Android update
    By Android Central Question in forum Samsung Galaxy Note 8
    Replies: 1
    Last Post: 08-13-2018, 06:44 AM
  5. how to unlock phone if you did not put in a security pin when you restart
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 08-13-2018, 04:42 AM
LINK TO POST COPIED TO CLIPBOARD