1. T79phoenix's Avatar
    Hey guys. I'm needing some MAJOR help! The non-english speaking LG customer service individual was absolutely useless. I had my old LG G Watch R sent in for repair. I was pleasantly surprised to see that when I opened the box, they sent back a brand new LG G Watch R. I even had the privilege of removing the protective film off of it. I will say that this one came to me with 4.4.W.1 installed (which is the ancient version that was brought out years ago). And I would definitely like to get this thing updated to the newest version once these issues are worked out...

    Everything was great right out of the box until I attempted to get it synced up to my Turbo 2 (which was the same phone I had with my defective LG G Watch R). It goes through the initial pairing process and the big green check mark comes up saying it has been paired. As soon as it does that, the cloud logo with the line going through it comes up on my watch face saying it has disconnected. On the Android Wear app at the top it says, "attempting to connect" or "connecting" and just stays in limbo there without any updating and doesn't even get to the point where the time on the watch changes. Absolutely nothing happens. Even after turning off bluetooth and turning it back on, it will still stay disconnected. The only time it will attempt to connect again is if I restart my phone. It will pair briefly but then disconnect again with no change. And this is with all different Android Wear APK versions that I've downloaded and ran.

    Ive gone as far as doing all of the following:
    -Restarting my phone and my watch numerous times.
    -Factory resetting my watch numerous times.
    -Performing a total cache partition wipe of my phone.
    -Went into my bluetooth settings and "forgot" my watch so it attempts to sync up fresh.
    -Used the most current Android Wear version.
    -Downloaded and ran many different past Android Wear app update versions off those APK download sites. I downloaded as far back as to around the first few Android Wear versions that initially came out because of this new watch having the older build and OS installed in it from factory. I figured that would be best to use since it would be the most compatible version to my current watch OS.

    I am drawing an absolute blank with all of this and frankly its driving me nuts and to the point where I almost don't want this watch anymore. But because i have no way of getting a refund for it since the original was bought so long ago and i didn't pay for this replacement, i would essentially be throwing away 250 bucks and then spending almost 300 more on something else. I'm really needing to weigh out all my options here.

    Any help would be great!

    Todd C.
    06-30-2016 09:30 PM
  2. enesha's Avatar
    I have just redone my phone and needed to pair my watch (Asus Zenwatch) anyway so I thought I would give it a quick look and see what I can see. I didn't go very far (I'm actually doing a few things and need to have the phone doing other things, but when you first try and pair the watch to the phone it gives you an option to connect your watch to wifi. It seems like you were getting hosed after the initial pairing, so perhaps you can try again making sure that option is checked. Then after that - see if you can make the watch connect to your wifi. If you can, perhaps you can try and trigger the software update on it after that and hopefully it will update and not hate on you so much?
    06-30-2016 10:25 PM
  3. T79phoenix's Avatar
    Well amongst the numerous times before of attempting to sync this thing up, I've always checked the option to connect to wifi. I'm actually wondering now if I should deselect that option initially so it's not looking for a WiFi connection (which could be why it's disconnecting my Bluetooth because it's trying to find WiFi). It may be better for my phone and watch to work directly rather than using my router as a middle man. Then, if and when everything gets synced up, I'll then turn wifi sync on. And I haven't been able to activate any kind of software update trigger yet. There's not even a way I'm able to. Not that I've seen anyway.
    07-01-2016 05:37 AM
  4. kramer5150's Avatar
    Do you have anything else using bluetooth... or attempting to use it (perhaps without you knowing it)? Might want to go through your app permissions and settings and turn off all bluetooth activity. I have a couple generic smart watches (the cheap ones from China), in addition to my moto360. The generic ones use their own BT connection app on my phone and I have found those apps and their permissions conflict with android wear and all its permissions. So I have had to delete those generic apps so AW can function.

    Good Luck!! I hope you get it fixed.
    T79phoenix likes this.
    07-01-2016 12:50 PM
  5. T79phoenix's Avatar
    After many failed attempts, I actually broke down and got a great deal at Best Buy on a "like new" Moto 360 Sport. I love it so far. It still had the protective plastic covering the back of the watch where the heart rate sensor is. Since it was apparently a returned/opened box item and it was there for a while, I got it for $165. Seriously couldn't pass that up. Thanks for the help though!
    07-10-2016 07:39 PM
  6. kadmanMusic's Avatar
    So, I'm having the exact same issue right now. I had an Asus Zenwatch 2 which worked great until it refused to charge. Sent it back and got a replacement (warranty) and now it won't connect to Android Wear on my Droid Turbo 2. I don't know if it's a problem with the phone or the watch.
    08-31-2016 03:32 PM
  7. T79phoenix's Avatar
    There can be so many different factors causing the error. Just some tips...be sure that any Bluetooth watch you had saved in your Bluetooth settings has been "forgotten" and try it again. See if that helps. If not, to make sure your Android wear app "forgets" it too, I would say to go into your phone apps, clear cache and data in the Android wear app, uninstall Android Wear, and then reinstall it. Starting fresh is always a good idea. If that doesn't work, try doing a "wipe system cache partition" to freshen up any bugs on your phone and try again. In between each option above, I would factory reset your watch each time so it can always start from scratch. See what happens. Hopefully it works out!
    08-31-2016 05:37 PM
  8. T79phoenix's Avatar
    Here's the link for the wipe cache partition...
    08-31-2016 05:39 PM
  9. kadmanMusic's Avatar
    I've tried every one of those ideas except clearing the cache partition. I'm guessing it won't work, but it's worth a try. Might make my phone faster again by clearing dead weight though.
    08-31-2016 05:41 PM
  10. T79phoenix's Avatar
    Yeah I clear mine once a month. Has taken care if some standing bugs before too. Wouldn't hurt. If that doesn't do it, maybe it's the watch. Since it's warranty, having them send you another one would be cheaper than looking for another phone option.
    08-31-2016 06:52 PM

Similar Threads

  1. Replies: 3
    Last Post: 07-08-2016, 04:51 PM
  2. How can I reset my WiFi pass Word on Samsung S5 T-800
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 06-30-2016, 09:41 PM
  3. how can I unlock my HTC device?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-30-2016, 09:35 PM
  4. Replies: 0
    Last Post: 06-30-2016, 09:29 PM
  5. Replies: 1
    Last Post: 06-30-2016, 09:02 PM