1. Dan Sayers's Avatar
    Hello, everybody. Thank you for taking the time to read/help.

    Last night, when I set my watch on its charger, not all contacts were made or something. As a result, the watch completely discharged. When I finally got the issue resolved, the watch indicated that it was 1969 or something, and I had to re-pair it with my phone. Now, I'm no longer getting text message notifications on my watch.

    A bit of background: I use the "default" app simply called Messages. When I first got my watch, there was no interactivity with Android Wear. So I got a 3rd party suite of watch apps from appfour, including a text messaging app called Wear Messages.

    Since then, Android and/or Android Wear has gone through updates that allow the default Messages app to push notifications, as well as enable dictated replies (yay!). I've kept Wear Messages installed, but have allowed the default Messages app to mostly be the way in which I use text messaging on my watch.

    Back to today: I have checked out as many settings I can think of--both on the watch and my phone. I have also rebooted both devices twice. Still, when I receive a new text message, my phone will beep, flash, and have a notification for me. My watch no longer does.

    Since it worked yesterday, and I was forced to re-pair them today, I'm guessing the fix should be simple. I no longer have any guesses as to what else to look into. Does anybody have any ideas? I would really appreciate it as this is currently my primary reason for wearing the watch at all. If it matters, my phone is a Galaxy S6 and my watch is an LG Urbane. Thanks!
    10-25-2017 02:35 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Moved to the Urbane forum.

    Which Android Wear version is the watch running? Is it 2.0? If so, open the Play Store app on the watch, scroll down to "Apps on your phone," and see if there's a download icon next to Android Messages. If so, tap it to make sure the app is installed on the watch.
    10-26-2017 02:32 AM
  3. Dan Sayers's Avatar
    Welcome to Android Central! Moved to the Urbane forum.
    Thank you! Not sure why though; Is there any reason to suspect this issue would be indigenous to one model of watch?

    When I first read your reply, I was hesitant. I had never had to install anything on the watch for this purpose as it's a part of the OS. To my layman's eyes, it seems as if I was being asked to install Google on Google's OS.

    Still, I did as you recommended. Then it asked me to install it on my phone. But it's already on my phone. It's the app I've used for text messages from day one. Yet the Play Store page on my phone did not indicate it was installed.

    I'm not trying to install additional apps. I'm trying to restore functionality that is/was already present. I'm getting text messages just fine. They're just no longer getting pushed to the watch and I'd like to understand how to fix this.

    I've seen updates to software take things that work and break them. Seemingly way more often than the updates would serve me. So you can understand my apprehension at being asked to install even more, eh?

    Cool avatar, BTW. I consider this matter unresolved and am still in need of help. Thanks.
    10-26-2017 12:28 PM
  4. B. Diddy's Avatar
    Thank you! Not sure why though; Is there any reason to suspect this issue would be indigenous to one model of watch?
    I moved it since this is a more specific Android Wear question -- the general community is usually less likely to answer, since Android Wear is somewhat of a niche, and a question like this can get buried fairly quickly in the Ask A Question or General Help forums. If you'd like, I can move it to the more general Android Wear forum (or if you really prefer, back to Ask A Question).

    Have you already tried uninstalling Wear Messages temporarily, in case it's causing some kind of interference? Perhaps the devs for that app haven't quite optimized it yet for 2.0, or there might be some bugs they haven't yet ironed out.
    10-26-2017 03:16 PM
  5. Dan Sayers's Avatar
    I understand your reasoning for the move. I do think general Wear might be more appropriate.

    I wonder if my understanding of such things is limited, or if perhaps I'm not communicating my experience well enough. If I took my motherboard's battery out, I wouldn't lose my Windows or installed programs, though the system clock might be wrong. Similarly, my current issue is the result of the watch completely losing battery. Hence the date and time being off once power was restored.

    All my installed apps and everything else about the watch seems to have been preserved without issue. Other than the fact that I had to re-pair the devices. This is why I was skeptical that installing something new would do the trick, and now that uninstalling might as well. I'm reasonably convinced that it's a settings issue. I just don't seem to be able to find which settings to change.

    Keep in mind too that I never changed any settings to get text messages to push to the watch in the first place. There just came a day, after either a watch or phone software update, where the default Messages app started pushing texts to my watch. I was grateful for it, but never looked into why. Of course I wish I had now.
    10-26-2017 04:05 PM
  6. B. Diddy's Avatar
    Ok, moved this thread to the general Android Wear forum.

    Can you clarify -- did this problem start after the watch got updated to Android Wear 2.0? It sounds like you're not quite sure, but it might be an important piece of information. As I mentioned before, if this is the case, it might be due to a bug with Wear Messages in AW 2.0 that is interfering with the proper pushing of message notifications (from the Android Messages app) to the watch.
    10-27-2017 03:28 AM
  7. Dan Sayers's Avatar
    I've been on Wear 2.0 for quite some time now. The issue didn't show up until the battery completely discharged, leading to it displayed a VERY wrong date/time, and needing to be re-synced with the phone for the first time since they were initially paired.
    10-27-2017 07:20 PM
  8. B. Diddy's Avatar
    Have you also tried doing another factory reset of the watch?
    10-29-2017 04:43 PM
  9. Dan Sayers's Avatar
    No. The phone lost sync with the watch at one point. I expect the issue is with the phone not pushing messages because at one point, it lost sync.

    Please, while I appreciate your efforts, it seems like a shotgun approach instead of reading the cause and basing a diagnosis off of it.
    10-30-2017 12:38 AM
  10. B. Diddy's Avatar
    Ok, I understand your frustration. Android Wear can be a bit opaque, since there aren't many settings you can manipulate -- that's why I suggested a factory reset. After all, in order to pair the watch to a different phone, you actually have to do a factory reset on the watch (rather than simply switching devices within a setting).

    Good luck with finding the correct answer!
    10-30-2017 01:37 AM
  11. chrisz18's Avatar
    I too am having a similar issue. I don't get notifications at all on my watch. Whether it's texts, emails, or phone calls nothing comes up. This all happened over night. Watch was working great one night, woke up the next morning and realized I wasn't getting any notifications.

    I decided to do a disconnect and reset, and when the watch booted back up, it did not reset but now I'm getting vibrations from the app Feel The Wear, but no peek card. If I disable the Feel the Wear app, I get no vibrations.

    Not sure if something updated overnight since everything is on auto update. But I've searched all the settings. Changed watch faces to see if it was a setting in Watchmaker or Pujie but still nothing.
    11-17-2017 08:19 PM
  12. GEO1ER's Avatar
    I have a Blackberry Motion running Android 7.1.2 and two watches, a Moto 360 running Android Wear 1.4 and a Tic Watch E running Android Wear 2.0.

    I get all my notifications on my phone and I get all my notifications on both my watches, EXCEPT for text messages from "Android Messages" app, and e-mails from "Blackberry HUB" app. This problem is occurring on both watches, the Moto 360 and the Tic Watch. Prior to experiencing this problem I have always received notifications on my watches for both those apps.

    Here is what I have done. Reboot both phone and watches, deleted and re-downloaded the apps on Tic Watch (except HUB, no HUB app on Andorid Wear) checked to see if there were any restrictions on those apps in Wear OS app on my phone, there isn't. Check to see if those apps are muted on my phone, they are not, although I didn't expect they would be because I get the notifications on my phone just not on either of my watches. I have Unpaired both watches with my phone and started from scratch. None of these seem to solve the problem. Please help.

    George
    06-23-2018 12:34 PM

Similar Threads

  1. Punctuation suddenly missing in speech-to-text - how to fix?
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-17-2018, 01:32 AM
  2. Not receiving email notifications for subscribed threads.
    By everway9 in forum Site Feedback & Help
    Replies: 0
    Last Post: 10-25-2017, 02:21 PM
  3. Not receiving email notifications for subscribed threads.
    By everway9 in forum Ask a Question
    Replies: 0
    Last Post: 10-25-2017, 02:21 PM
  4. How to disable Andriod message+ notification sound while using the app
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 10-25-2017, 02:07 PM
LINK TO POST COPIED TO CLIPBOARD