1. sct-n's Avatar
    Hi people, I bought a Fossil Explorist Q gen 4 a few months back from TicTacArea.
    In general watch has been good, if a bit laggy. I basically bought the watch to allow me to leave my phone at home while I track my running and listen to music. Had a heap of trouble finding the right app for music I think I've got it now with "wearmedia"

    But for the life of me I can't get a fitness app to work with GPS. I've tried ghostracer, strava, nike run club.

    How do I know if the GPS on the watch is working? is there a simple way to test?

    thanks in advance.
    11-18-2019 07:41 PM
  2. Rukbat's Avatar
    Install GNSS (from WearOS on Play) or Wear GPS Status. Then you can see what the GPS receiver is doing.
    11-19-2019 04:37 PM
  3. Scienceguy Labs's Avatar
    Have you tried using Google Fit just to see if the built in fitness app works with gps?
    11-19-2019 05:06 PM
  4. sct-n's Avatar
    Thanks for the responses, I'm getting no data on GNSS. I guess that means the gps is not working?
    11-21-2019 05:57 PM

Similar Threads

  1. Backspace Key doesn't work in Portrait mode
    By RichPasco in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 6
    Last Post: 12-16-2019, 10:14 AM
  2. Why did Google make it so difficult to quickly use Maps?
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 11-19-2019, 04:23 PM
  3. Replies: 1
    Last Post: 11-19-2019, 04:18 PM
  4. Need to get my Motorola e6 unlock from MetroPCS?
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 11-19-2019, 04:14 PM
  5. Replies: 1
    Last Post: 11-18-2019, 05:10 PM
LINK TO POST COPIED TO CLIPBOARD