1. JamesMason580's Avatar
    Hello,

    I've got a Sonim XP8 that I'm trying to connect to my new Netgear CAX80 router. Got the router all setup, all other devices at home connect fine. Except my XP8. It won't even try. I click the network, type in the correct password, hit connect, then nothing. It just shows up as "Saved" now. It connects to a Wifi 5/AC network just fine. It connects to the Wifi 6/AX network fine when no password is used. However, as soon as a password is added, snake eyes.

    Has anyone run into this issue with any other phone or another Sonim?

    Went through troubleshooting with Sonim and AT&T to the point of a factory reset of both devices, reconfigured both, then AT&T decided to replace my XP8. The new one has the same issue. I feel as if it has something to do with the newer authentication methods that Wifi 6/AX is capable of, and Sonim/AT&T has not updated the XP8 Android version to work with it yet. I also did try to talk to Netgear about it... though after the third time of be told that I don't know that I'm actually connected to wifi, even though I wasn't, gave up with that route.

    Many thanks for any help.
    07-17-2020 07:36 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Is this your own personal phone, or is it managed by a company? Sonim seems to specialize in enterprise devices, as evidenced by their Sonim SCOUT app: https://play.google.com/store/apps/d...scout&hl=en_US. I'm wondering if their extra layer of security/management software might be interfering.
    07-17-2020 07:48 PM
  3. JamesMason580's Avatar
    It is my own personal device, I got it because it's about indestructible and on the FirstNet plan.
    07-18-2020 01:13 PM
  4. B. Diddy's Avatar
    But does the phone have the SCOUT app installed? If so, look through its options to see if there's anything related to network connectivity.
    07-18-2020 01:20 PM
  5. JamesMason580's Avatar
    Sorry, I never knew I got another reply. Yes, it is installed, and cannot be disabled or uninstalled.
    09-23-2020 09:10 PM
  6. B. Diddy's Avatar
    Right, but are there any options in the SCOUT app's menu that might be related, in terms of security?
    09-23-2020 11:16 PM
  7. JamesMason580's Avatar
    Not that I can find. Made in interesting discovery last night, if I drop the security to WPA-PSK [TKIP] + WPA2-PSK [AES] it'll connect fine, but the router warns it'll only by at up to 54 Mbps. If I put it back to WPA2-PSK [AES], it shows on the phone as Saved, and has the same behavior as before where it will not try to connect.
    09-24-2020 11:58 AM
  8. B. Diddy's Avatar
    This probably won't do much (and you've probably already tried it), but see if it helps to reset network settings: www.verizon.com/support/knowledge-base-224595/
    09-24-2020 12:40 PM
  9. JamesMason580's Avatar
    No luck there, AT&T even sent a new phone entirely, still has the same issue.
    09-30-2020 11:07 AM
  10. B. Diddy's Avatar
    Maybe it's a problem with Sonim's firmware, then. Try giving them a call: https://www.sonimtech.com/support/on...t/xp8-support/
    09-30-2020 11:50 AM
  11. Rukbat's Avatar
    It's probably Sonim's firmware. Remember, there was no WiFi6 when it was being developed, so they couldn't test it. (Samsung had a similar problem - around 2014, in the Note 3, TKIP stopped working and crawled like a dead turtle. AES worked fine. The next update fixed the problem.)
    Laura Knotek and B. Diddy like this.
    10-03-2020 02:05 PM
  12. JamesMason580's Avatar
    I'll try them again. I'd figured that was the case, however when I tried to address it with them, they told me since the phone was under a year old, all inquiries surrounding issues with it would be handled by AT&T, and their solution was a new phone, so back to square one.
    10-07-2020 10:12 PM

Similar Threads

  1. Recent Update Broke Wi-Fi!
    By pareto82 in forum Samsung Galaxy S10e
    Replies: 24
    Last Post: 07-22-2020, 10:07 PM
  2. Recent Update Broke Wi-Fi!
    By pareto82 in forum Samsung Galaxy S10e
    Replies: 0
    Last Post: 07-16-2020, 12:37 AM
  3. Charging issues after latest Android update!?
    By Keith70 in forum Samsung Galaxy S9 & S9+
    Replies: 3
    Last Post: 07-15-2020, 02:33 AM
  4. Charging issues latest android update
    By Keith70 in forum Ask a Question
    Replies: 0
    Last Post: 07-14-2020, 03:48 AM
  5. Android OS 9.0 , BLE 5.0 specific issue fetching list of services from BluetoothGatt
    By Android Central Question in forum Software Development and Hacking
    Replies: 1
    Last Post: 07-13-2020, 02:22 AM
LINK TO POST COPIED TO CLIPBOARD