1. Android Central Question's Avatar
    I have a 2020 Motorola Moto G Power which is running Android 10. I have mobile data turned off but the phone will continue to use mobile data anyway. I can be where there is no wifi, confirm there is no wifi connection, confirm mobile data is off and then open a browser and go to a site, and it works. I can also see data being used in the cellular counter area under mobile data. '

    After reading some forums I enabled developer options and confirmed that "Mobile data always active" was also off. I then disabled developer options again.

    Thanks for the help!
    08-19-2020 08:30 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Does this also happen in Safe Mode? https://support.motorola.com/us/en/solution/MS148713

    Please register on this forum, which will allow you to engage in discussion more easily, as well as post images. https://forums.androidcentral.com/as...community.html
    08-19-2020 09:03 PM
  3. odandroid15's Avatar
    Does this also happen in Safe Mode?
    Thank you B. Diddy. I restarted in safe mode, turned off mobile data, turned off wifi, went into chrome, and went to a website which loaded.

    So no, it was not fixed in safe mode.

    It does not use any mobile data in airplane mode.

    If it helps, I just got this phone and restored my setting from my older android. However, I never had this problem with my other phone and almost always had mobile data off.

    I've read I should try resetting network connections, but I don't want to have to put in all my wifi and Bluetooth settings again if possible.

    Thanks again for your help, please let me know if you have any other thoughts.
    08-19-2020 10:49 PM
  4. B. Diddy's Avatar
    Ok, and to be clear, you're turning off mobile data using the Quick Settings toggle?
    08-19-2020 10:55 PM
  5. odandroid15's Avatar
    Ok, and to be clear, you're turning off mobile data using the Quick Settings toggle?
    I've done it both from the Quick Settings (Pull down from the top and toggle "Mobile data") and also by going Settings-> Network & Internet -> Mobile Network -> Mobile data. Also, for the record, both of those options seem to be in sync as expected (If I toggle one on, the other also toggles on, and visa versa).

    P.S. I love your avatar! Long live MST3K! :-)
    08-19-2020 11:40 PM
  6. B. Diddy's Avatar
    Hmm, I don't have a good explanation for that. Sounds like a firmware glitch -- might be worth contacting Moto support about it.

    Always great to meet another MST3K fan!
    08-20-2020 12:23 AM
  7. mustang7757's Avatar
    Can also try reset network in settings, and reset your APN
    B. Diddy likes this.
    08-20-2020 12:29 AM
  8. odandroid15's Avatar
    might be worth contacting Moto support about it.
    Yeah, I might give that a try today. Last night all I could do was reach their worthless chatbot. LOL
    08-20-2020 08:12 AM
  9. odandroid15's Avatar
    Can also try reset network in settings, and reset your APN
    Thanks mustang7757. I was going to try that, but don't want to have to re-input all my wifi and bluetooth settings again. Do you know if there is a way to backup these settings so I can restore them after a network reset?
    mustang7757 likes this.
    08-20-2020 08:14 AM
  10. Mooncatt's Avatar
    I doubt I'll have any answers, but some clarification may help.

    You said you could go to websites. When you do that, are you actively able to use them and navigate at will, or are you just going to their home page (I.e. From a bookmark)? Have you tried multiple browsers? Have you tried other services like YouTube that require streaming?

    I ask because with no internet connection, Chrome will sometimes load a cached version of a web page, and it may not be immediately apparent it has done so. I get this a lot with Facebook, for example. It will show my feed from the time I was last there, but trying to go beyond that in the site would give me the offline errors. So are you 100% sure you still have an active data connection?
    B. Diddy likes this.
    08-20-2020 08:34 AM
  11. odandroid15's Avatar
    So are you 100% sure you still have an active data connection?
    Great question Mooncatt. Yes, I thought about caching as well. I can navigate sites. :-( If I use one browser and go look in the cellular counters it will show mobile usage for that one, then if I go to another browser, or a game, it will show mobile usage for the ones I used. I discovered this by accident when I was away from wifi and someone pinged me on hangouts. I was like "I thought mobile data was off!?!?!" And it was. :-( And my carrier's website is showing data usage. This is very strange. Like I said, on my previous phone I almost never have mobile data on, and never had this problem.

    Thanks for the thoughts and help!
    08-20-2020 08:49 AM
  12. mustang7757's Avatar
    Thanks mustang7757. I was going to try that, but don't want to have to re-input all my wifi and bluetooth settings again. Do you know if there is a way to backup these settings so I can restore them after a network reset?
    Welcome , on that phone I'm not sure , Google supposedly backs those up.
    08-20-2020 12:22 PM
  13. odandroid15's Avatar
    I believe resetting my APN fixed it. I will continue to monitor.
    mustang7757 and B. Diddy like this.
    08-21-2020 01:42 PM
  14. mustang7757's Avatar
    I believe resetting my APN fixed it. I will continue to monitor.
    Ok keep us posted
    08-21-2020 01:47 PM
  15. odandroid15's Avatar
    Ok, this issue still persists. I have was even able to reproduce it three times this morning and I've even capture a bug report. I believe the problem happens when I am on the very very edge of a wifi network and I'm just "barely connected". So, this morning, I turned on mobile data, set the mobile data limit just above the exiting usage, then turned mobile data off. I checked data saver was enable. While connected to a trusted wifi network, I walked away from it until I felt I was just on the edge of the range. I opened a browser and typed in a URL and immediately the hone notified me that I had exceeded my mobile data usage limit. Interestingly enough, the mobile data does not get used once this mobile data limit is reached. So, it seems Android is respecting the mobile data limit, but not the mobile data enabled/disabled toggle when on the edge of a wifi network.
    09-20-2020 10:17 AM
  16. odandroid15's Avatar
    I am not sure what to do with my bug report now that I have it saved. My phone is a mototrola, so I am also asking for help from Lenovo:
    https://forums.lenovo.com/t5/moto-g-...ed/m-p/5034279
    09-20-2020 10:18 AM

Similar Threads

  1. The Note 20 is a good buy (in my opinion)
    By Kendahl Titcomb in forum Samsung Galaxy Note 20 & Note 20 Ultra
    Replies: 3
    Last Post: 08-19-2020, 11:59 PM
  2. Beta program is full.
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 08-19-2020, 09:05 PM
  3. Why is my Figo phone acting so weird?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 08-19-2020, 03:39 PM
  4. Replies: 0
    Last Post: 08-19-2020, 03:01 PM
LINK TO POST COPIED TO CLIPBOARD