1. Android Central Question's Avatar
    Hey guys,
    I recently bought a Chinese Android car head unit from a pretty random AliExpress seller. The unit is based on a chip that doesn’t have a lot of info about it on the web: AC8257 (Probably some sort of a MediaTek). I know those Chinese units and ROMs can be pretty funky, but this one actually works pretty well, both on the car side and the Android/Google apps side. However, I do have one small, yet very annoying problem that I can’t seem to solve on my own: Google app (Which includes the assistant) did not come preinstalled with the device. I’ve manually installed it from the app store, and until my first reboot, everything seemed to work fine. The assistant could be called both by a keypress and by “OK/Hello Google”. So far so good. The problem first appeared upon restarting the machine. When I tried calling the assistant, I got a message saying that Google assistant is not set as my default assistant. I went to the settings, and guess what, it seemed to be set as the default (No other option other than “None” were available anyway). I chose it again anyway, and indeed, it started working properly again. However, 30 minutes later, even without a reboot, it happened again. And again… You get the idea.

    I did some googling (Both for the AC8257 and the assistant problem itself, contacted the seller and searched wherever I can, but the results were dull). I tried solving it by doing the following:

    Using adb and root rights (Through ADB, not a permanent root), I installed the apk in priv-app, didn’t work. I then tried moving the Play store installation the priv-app, also did not work. I also tried disabling something called DuraSpeed, which, as far as I understand, is a performance enhancing tool by MediaTek that can sometimes cause this kind of thing, but that ,sadly, also did not help. In addition, I also tried resetting the device completely, to no avail. The only thing I didn’t try is installing a clean ROM and then installing OpenGapps, but that’s not possible right now (Couldn’t find any ROM for this device and CPU).

    I know this might be a problem that is specifically related to my device/ROM, but as I can’t find a lot of info about it pretty much anywhere, I thought it might not be such a bad idea to ask this question in a more general forum.

    Many thanks to you all,
    Noam.
    10-12-2020 06:59 AM
  2. Rukbat's Avatar
    First, the SoC is by AutoChip - it's a Chinese company that makes chips for the auto industry (including SoCs for head unites).

    You don't need a new ROM to install OpenGapps. But I suspect that another app is set (and keeps setting) as the default assistant app. Once you find that app and clear defaults on it ("defaults" means it's the default app for whatever function), Google Assistant should start running normally again. (Should - that doesn't mean that it will.)
    10-12-2020 01:09 PM

Similar Threads

  1. How can i put the time & date on the front page of my galaxy tablet S5E please
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 10-12-2020, 01:06 PM
  2. Why can't i change my wallpaper it always say that I am restricted
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 10-12-2020, 03:04 AM
  3. Some streaming apps not going full screen on motorola edge +
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-12-2020, 12:05 AM
  4. Change default user on Asus ZenPad 3S
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 10-11-2020, 08:30 PM
  5. Replies: 1
    Last Post: 10-11-2020, 06:59 PM
LINK TO POST COPIED TO CLIPBOARD