1. Android Central Question's Avatar
    Hello everyone,

    I really hope somebody can help me with this.

    I have xperia z5 premium, power button stopped working a month ago or something, but the phone was working perfectly fine. Of course, I made a mistake and did not charge it in time and it turned off. Now I can't get it to turn back on because the button is not working.

    I explored all my options and I realized I can do fastboot reboot through fastboot and adb. However, I can't seem to get my phone to go into fastboot mode.

    I hold volume up button (which I know for a fact is working), I plugin usb, and instead of getting that blue led light everybody keeps talking about, I just get a red led and then a green one after the sony logo that signals the phone is charging.

    I installed ADB and xperia z5 premium drivers and I still can't get it to work. When I type fastboot reboot it says <waiting for device> when I try adb reboot or adb reboot bootloader it says "error: device not found".

    I've also installed xperia companion app and when I plugin my phone it shows a screen where it says: "Your device is locked

    1. Unlock require
    Unlock the device using password or fingerpint if needed

    2. Allow data access
    On your device, select the option to allow data access"

    I've tried doing the same thing with adb on two different pcs, always get the same result. Phone just gets to charging screen and keeps charging instead of going into any mode.

    I also tried holding volume down button and plugging in usb which is supposed to be recovery mode or something, but that doesnt work either, I also get charging screen. And I'm 100% sure both my volume up and volume down buttons are working.

    What am I doing wrong?

    P.S - Debugging mode is not on, im 100% sure since i never turned it on.

    Somebody please help!

    11-21-2020 04:56 PM
  2. belodion's Avatar
    Have you tried the simple attempted fix of flood-cleaning the Power button with alcohol? If successful, it would obviate the need for those complicated PC tethering procedures. https://forums.androidcentral.com/as...community.html
    11-21-2020 05:45 PM
  3. mustang7757's Avatar
    You sure the phone charged enough?
    11-21-2020 07:18 PM
  4. B. Diddy's Avatar
    Welcome to Android Central! Unless you're just trying to retrieve data from this phone and plan to get a new phone, I'd recommend bringing it to a repair shop to fix the power button.
    11-21-2020 09:27 PM

Similar Threads

  1. Cannot get Samsung S7 to work
    By Matty Reed in forum General Help and How To
    Replies: 6
    Last Post: 11-23-2020, 12:19 PM
  2. Xperia Xz1 Black screen
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 11-21-2020, 07:17 PM
  3. Quite often my My phone does not charge when I set it on my charging dock.
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 11-21-2020, 02:29 PM
  4. My dial pad wont work
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 11-21-2020, 01:04 PM
  5. SD card detected but not usable
    By Newbiedoo in forum General Help and How To
    Replies: 1
    Last Post: 11-21-2020, 12:48 PM