1. Android Central Question's Avatar
    I have a virgin media router and recently set up an old sky Q hub as a wireless access point. Everything went fine but all android based devices won't receive internet. They will connect and be assigned an IP, all looking fine, but not receive actual internet. One of the devices, a nvidia shield, is connected via ethernet to the virgin media router and also doesn't get internet.



    While this points to an android issue it's in conjunction with the sky Q hub as when the Q hub is disconnected all devices return to normal.



    I've tried all the obvious solutions like resetting network settings on the android devices and resetting both routers. Both routers have the same SSID and password, are not on the same IP address as the other router or any other device on the network. DHCP is turned off on the Q hub. They are on different channels, but as far as i'm aware that makes no difference (as i have tried putting the routers on the same channel).



    This points to a probable security setting that i need to change on the Q hub but i'm out of my knowledge depth and hard to search for answers on google.



    Any help much appreciated.
    01-08-2021 07:31 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Can you access the Sky Hub's settings using your computer browser? https://helpforum.sky.com/t5/Broadba...1/ba-p/2649511. If so, see what kind of security the hub is set for. If it's an obsolete security protocol (like WEP), that might be why your devices can't connect.

    Please register on this forum, which will allow you to engage in discussion more easily, as well as post images. https://forums.androidcentral.com/as...community.html
    01-08-2021 07:45 PM
  3. alistairbinley's Avatar
    I can connect and my security is wpa2. The devices can connect fine they just don't receive any internet. The connected android devices show up as UNKNOWN in the device list
    01-08-2021 09:58 PM
  4. B. Diddy's Avatar
    Try changing it so that each access point has a different SSID. When I used to have a secondary access point, I found that having the same SSID could cause confusion with the system. (Mesh wi-fi systems get rid of this problem altogether.)
    01-08-2021 10:08 PM
  5. Chuck Finley69's Avatar
    I can connect and my security is wpa2. The devices can connect fine they just don't receive any internet. The connected android devices show up as UNKNOWN in the device list
    I’m not a tech IT person, however I used to spend decent money paying technicians couple times a month for an office I setup years ago, then subletting. I had duplicate T1 lines into couple of 48 port switches. We ran wired, private and public WiFi for 25 people and lobby customers.

    Since there were about six different businesses, sometimes one would bring in cable TV with cable internet bundled. They’d plug in cable modems and routers, supposedly partitioned from the main switches traffic. It never failed, somebody would reboot or switch ports and generate IP conflicts. Sometimes the various devices themselves got confused attempting connection.

    Networking protocols are simply the purgatory of the internet and IoT has only exponentially made it worse.
    B. Diddy likes this.
    01-08-2021 10:14 PM
  6. alistairbinley's Avatar
    Seems ok now. There was a ' Enable ULA Router Prefix Advertisements ' setting that i turned off under IPv6 settings and is working now. not sure what it is or what it does and why there was a conflict.
    01-09-2021 10:41 AM

Similar Threads

  1. Watch3 Not Showing Phone Charge
    By DennisOS2 in forum Samsung Galaxy Watch
    Replies: 7
    Last Post: 01-21-2021, 11:23 AM
  2. Android 11 preference for 5ghz
    By Reinier van Beek in forum Android 11
    Replies: 3
    Last Post: 01-11-2021, 10:18 AM
  3. Remove photo tags in Android Gallery
    By Android Central Question in forum Samsung Galaxy S20 & S20+ & S20 Ultra
    Replies: 2
    Last Post: 01-09-2021, 01:31 AM
  4. Remove photo tags in Android Gallery
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 01-08-2021, 04:56 PM
  5. Android 11 preference for 5ghz
    By Reinier van Beek in forum Ask a Question
    Replies: 0
    Last Post: 01-08-2021, 11:31 AM
LINK TO POST COPIED TO CLIPBOARD