1. Remi_is_rockin's Avatar
    I just purchased a new LG Velvet, and I'm using Google Messages for SMS. All of the settings are the same as what they were on my old phone and I even went so far as to compare them to a friends android who can get/send MMS to iphones, and we're the same. I don't have issues when it's an android on the other end but for iphones, it's not happening. I can see that a picture was sent to me but it won't download the picture. The thingy just keeps spinning and no picture is downloaded. Everything has been updated, and I have no clue how or why this is happening.

    Any ideas???

    UPDATE: when I turn off the wifi, it works! I can send/receive MMS to iPhones, but as soon I am on wifi, it stops working. And not just my home wifi, any wifi network anywhere.
    04-05-2021 06:02 PM
  2. Mr Bojangles1's Avatar
    Does it do the same in safe mode?
    04-05-2021 06:31 PM
  3. Mr Bojangles1's Avatar
    You can try resetting your apn settings
    04-05-2021 06:32 PM
  4. mustang7757's Avatar
    I just purchased a new LG Velvet, and I'm using Google Messages for SMS. All of the settings are the same as what they were on my old phone and I even went so far as to compare them to a friends android who can get/send MMS to iphones, and we're the same. I don't have issues when it's an android on the other end but for iphones, it's not happening. I can see that a picture was sent to me but it won't download the picture. The thingy just keeps spinning and no picture is downloaded. Everything has been updated, and I have no clue how or why this is happening.

    Any ideas???
    Hi, welcome to AC!

    Your previous phone was a iPhone?
    04-05-2021 06:46 PM
  5. Morty2264's Avatar
    Welcome to Android Central! Does this same issue happen with all other contacts of yours, who also have iPhones, or is it one user? Is your mobile data turned on?
    04-05-2021 08:03 PM
  6. Remi_is_rockin's Avatar
    Does it do the same in safe mode?
    I haven't tried that.....need to search out how to do that, thanks
    04-06-2021 06:52 AM
  7. Remi_is_rockin's Avatar
    Hi, welcome to AC!

    Your previous phone was a iPhone?
    No, the previous phone was a Pixel 3 XL
    04-06-2021 06:53 AM
  8. Remi_is_rockin's Avatar
    Welcome to Android Central! Does this same issue happen with all other contacts of yours, who also have iPhones, or is it one user? Is your mobile data turned on?
    This happens with all of my iPhone contacts but not with any of the Android contacts. Yes, data is on. As I said, the settings are exactly the same, nothing has changed.
    04-06-2021 06:54 AM
  9. mustang7757's Avatar
    No, the previous phone was a Pixel 3 XL
    You can send pictures no problem?
    04-06-2021 09:04 AM
  10. Kizzy Catwoman's Avatar
    I haven't tried that.....need to search out how to do that, thanks
    The process for turning on Safe mode is as follows:

    Press and hold the Power button.

    Tap and hold Power off.

    When the Reboot to safe mode prompt appears, tap again or tap OK.

    Your device will then restart and it will say “Safe mode” in the bottom-left corner.
    04-06-2021 09:23 AM
  11. Remi_is_rockin's Avatar
    You can send pictures no problem?
    With the Pixel? Yup, all was fine.

    I can send MMS to Androids perfectly fine, but can't send nor receive MMs from iPhones, with my new Velvet.
    04-06-2021 12:03 PM
  12. mustang7757's Avatar
    With the Pixel? Yup, all was fine.

    I can send MMS to Androids perfectly fine, but can't send nor receive MMs from iPhones, with my new Velvet.
    Have you tried resetting the app by long press clearing data and force stop ?
    04-06-2021 12:06 PM
  13. B. Diddy's Avatar
    Try also Reset Network Settings.
    04-06-2021 12:53 PM
  14. newnewuser's Avatar
    I have the same phone. Bought it in November 2020. I live in Ontario, Canada. Provider is with Virgin Mobile. I never had any issues with sending MMS over wifi. A week or so ago LG did a system software update. Ever since then I cannot send MMS over wifi. Yes, mobile data is on. Yes, I have reset APN settings. Also did a factory reset. Tried things like removing the sim card, rebooting, re-inserting sim. I'm out of ideas. Tried different apps like Textra. Same issue. MMS won't send until i turn off wifi.
    04-09-2021 04:50 PM
  15. B. Diddy's Avatar
    Welcome to Android Central! When you say that you reset your APN settings, do you mean that you confirmed they're correct for Virgin Mobile? https://www.4gapn.com/ca/en/virgin
    04-09-2021 07:28 PM
  16. newnewuser's Avatar
    There's a "Restore Default Settings" under Access Point Names. I clicked on that and it removes any manually created APN settings and auto creates an APN with Virgin Mobile settings. The settings are similar to the website you provided. Minor changes. I have tried adding the settings on that site before and it still doesn't work.
    04-10-2021 02:56 PM
  17. mustang7757's Avatar
    I have the same phone. Bought it in November 2020. I live in Ontario, Canada. Provider is with Virgin Mobile. I never had any issues with sending MMS over wifi. A week or so ago LG did a system software update. Ever since then I cannot send MMS over wifi. Yes, mobile data is on. Yes, I have reset APN settings. Also did a factory reset. Tried things like removing the sim card, rebooting, re-inserting sim. I'm out of ideas. Tried different apps like Textra. Same issue. MMS won't send until i turn off wifi.
    What about google message app?
    04-10-2021 09:03 PM

Similar Threads

  1. Auto switch from 5GHz to 2.4GHz wifi not working
    By ROBESPIERRE61 in forum Samsung Galaxy S8 & S8+
    Replies: 6
    Last Post: 04-06-2021, 05:34 PM
  2. Can not get 'Galaxy Labs' from the Galaxy Store. What do I do?
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 04-05-2021, 08:04 PM
  3. How can i remove a shortcut shown on my samsung s10+ ?
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 04-05-2021, 01:47 PM
  4. I lost an sliding block puzzle game
    By Android Central Question in forum Google Play Games
    Replies: 3
    Last Post: 04-05-2021, 12:30 PM
  5. I lost an sliding block puzzle game
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 04-05-2021, 09:21 AM
LINK TO POST COPIED TO CLIPBOARD