1. Android Central Question's Avatar
    My Moto x4 is not recognized when I connect it to a Mac computer with a USB-C to USB-A connector, including the one that came with the phone.

    END GOAL: My objective is to get all data (mostly photos and videos) off the phone (about 32GB), so any solution that accomplishes this easily would be most appreciated. Given the amount of data that needs to be transferred, USB transfer seems the only viable option, but other viable suggestions are welcome.

    Details on the phone:
    - Moto X4 (Android One) originally purchased for use with Google Fi, but only using Verizon.
    - Product/Variant: payton XT1900-1 32GB P4
    - Android version 9
    - Build number PPWS29.69-39-6-13
    - Security patch level October 1, 2020.
    - USB debugging features enabled
    - USB default mode: File transfer

    Things I've tried:
    - Have tried to connect with Android File Transfer on 2 different Macs. In both cases, Android File Transfer does not recognize any device connected. One Mac is running Catalina, the other Big Sur.
    - Have tried with 3 different USB C-to-A cables including the one that came with the phone charger. None of them lead to Android File Transfer recognizing the device on either Mac.
    - I have tried using ADB via the Mac Terminal. When I run "adb devices", it returns no found devices.
    - On my Mac, with the phone plugged in, when I choose "Apple Menu > About This Mac > System Report" and click on "Hardware > USB", no device appears that would correspond to my phone.
    - The phone DOES charge when connected to my Mac using any of the three cables I tried.
    - I tried rebooting the phone into Android Recovery Mode, and when the USB cable is plugged into the computer, the phone will say "Transfer Mode: USB connected". And, it changes to "Connect USB Data Cable" whenever the cable is disconnected. Just above this message is says "oem_locked" in both cases, in case that's relevant.
    - With the phone in Android Recovery Mode and then choosing "Recovery Mode" from the menu, the phone just shows "No command". When I run an "adb devices" from the Mac terminal when the phone is in this state, no device is recognized from my Mac.
    - I've tried changing the default USB mode to other settings, with no apparent effect.

    Any help would be very much appreciated! Thank you in advance.
    11-30-2021 09:44 PM
  2. mustang7757's Avatar
    In safe mode when it works usually means 3rd party app or application on the phone is preventing it , Adb wont see the device if computer cant communicate with it , for OEM locked that just means your booloader locked but shouldn't say in Safe mode maybe u seen that in Adb screen? Cant comfirm because i dont have a mack , maybe need to download the drivers but can see if other members expirenced this


    I'll leave a Link to register so you can communicate here, As a guest account you can only post questions but can't reply
    https://forums.androidcentral.com/sh...d.php?t=409154
    11-30-2021 10:06 PM

Similar Threads

  1. Replies: 3
    Last Post: 12-04-2021, 02:35 AM
  2. Accelerometer not working
    By Travelholic35 in forum Google Pixel 6 & Pixel 6 Pro
    Replies: 16
    Last Post: 12-02-2021, 06:20 PM
  3. Replies: 2
    Last Post: 11-30-2021, 09:31 PM
  4. What is this icon on my phone
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 11-30-2021, 09:18 PM
  5. SMS on Joying Android 10 Head Unit
    By Android Central Question in forum Ask a Question
    Replies: 12
    Last Post: 11-30-2021, 07:52 PM
LINK TO POST COPIED TO CLIPBOARD