1. Julie Ramos Ybanez's Avatar
    I can't download.
    01-02-2015 01:53 AM
  2. Julie Ramos Ybanez's Avatar
    I can't download an apps
    01-02-2015 01:56 AM
  3. Charles Joynt's Avatar
    Was getting the same error on two devices trying to download an in-app upgrade purchase. Tried all sorts of fixes including contacting Google Play support. Turned out that this was a newbie error: I hadn't set up a wallet/credit card for the Google account I was using. Wish the error message had actually said that!

    Useful troubleshooting was to try to download a free app from the store successfully and then fail with a paid-for app.
    lailah david likes this.
    01-05-2015 06:22 AM
  4. lailah david's Avatar
    help me to solve the problem.please...
    01-20-2015 09:39 PM
  5. MUSA ahmad's Avatar
    Musa Cannot buy or download anything at all. There is a error from the reserver rpc:s-7 aec- o could you please help me with this[musa)]
    03-18-2015 01:04 AM
  6. Muhammad Anees's Avatar
    Please help me
    03-22-2015 03:05 AM
  7. Veera Mani's Avatar
    Can you help to. Fix rpc:7:aec-0 cannot download anything
    04-11-2015 08:52 AM
  8. lorena borja's Avatar
    Can you help to. Fix rpc:7:aec-0 cannot download anything
    04-28-2015 06:16 AM
  9. Barbara Lem's Avatar
    What do I do to fix this error message?
    05-02-2015 06:49 AM
  10. Regie Pamor's Avatar
    I can need download
    06-03-2015 02:42 AM
  11. Bonquiqui Wazhere's Avatar
    Why what does that mean
    06-06-2015 10:33 AM
  12. Bonquiqui Wazhere's Avatar
    Please help get rid of it
    06-06-2015 10:47 AM
  13. m inshaal's Avatar
    Error please close
    07-05-2015 07:15 AM
  14. m inshaal's Avatar
    Close of the error
    07-05-2015 07:18 AM
  15. Maurice Hilarius's Avatar
    I recently got an ASUS Cube Google TV device.
    After setup it tells me my apps are outdated and to update from the Play Store
    Problem is any app I try to install I get this same error message.
    "error retrieving information from server. [RPC:S-7:AEC-0 LUGJ-5AQC-3TSYS]"
    07-26-2015 12:49 AM
  16. zb011's Avatar
    I fixed problem in Android 3.2.1 by adding into settings>accounts & sync google account and gmail email?
    07-26-2015 06:47 PM
  17. Narayan Chouhan's Avatar
    How to solve erar rpc-s-7 aec
    09-09-2015 09:12 AM
  18. Narayan Chouhan's Avatar
    i can't download.
    how to solve erar rpc-s-7 aec
    please sent link
    09-09-2015 09:19 AM
  19. ethi rajan's Avatar
    Yes, i got it fixed...

    Settings>Accounts ---> sync and delete & recreate the google accounts and resolved the issue.
    11-05-2015 04:50 AM
  20. GHaustin's Avatar
    “””” A Fix For Not Being Able To Download Or Install Apps From The Google Play Store
    For People Who Have Tried EVERYTHING And It Still Doesn’t Work !!!!!!”””””””””

    To keep a long story short, I had decided to start using an older Android phone of\my wife’s. So I decided to factory reset it so I could start fresh on it. Well after it restarted it immediately began to ***** about not being able to connect to server. Then when I opened the play store everything I tried to download was Error retrieving information from server. I tried everything I could think of but nothing worked. Then hitting the forums and trying everything listed in them at least 10 times. So I was about to just give up then my little voice said try this one last thing and to my surprise it WORKED. Everything was working, updating and downloading. Here are the step to what I did.
    1. Remove all accounts and yes this means do a factory reset
    2. Restart the device
    3. After start up DO NOT and I mean DO NOT create, link or sign in using your google account info. Hit skip this step and let the device fully start up.
    4. After is has started and you have a data connection open the Play Store
    5. At this time NOW sign in with your google account info.
    6. Just sit back and enjoy watching the updates come zooming in.
    I don’t know why this worked or how but it worked. I am posting this so that others who are as frustrated as I was, might have a chance at PEACE. May this post save others and lead to calm.
    11-12-2015 07:51 PM
  21. Dennyi's Avatar
    Has a fix for the aforementioned error been addressed that actually works for my Android 4.4.2?
    02-29-2016 03:12 PM
  22. ymerej88's Avatar
    I tried everything (stuff like resetting phone, removing accounts/caches/application data from phone), but nothing seemed to work. After going to Google payments and noticing that my address wasn't fully filled in, I entered the required information. This seemed to help in my case. It might be smart to check that page and check if all your information is valid/entered
    belodion likes this.
    11-07-2016 02:56 PM
72 123

Similar Threads

  1. I need help with my LG Optimus L9 from T Mobile P769
    By Sbecerra407 in forum LG Optimus L
    Replies: 1
    Last Post: 04-13-2015, 03:29 AM
  2. 4g problems on Samsung galaxy s3 from boost
    By Unregistered in forum Ask a Question
    Replies: 1
    Last Post: 06-24-2014, 03:43 PM
  3. Can I unlock my phone from Kies 3?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-20-2014, 08:45 PM
  4. Replies: 1
    Last Post: 06-15-2014, 09:57 PM
LINK TO POST COPIED TO CLIPBOARD