1. AC Question's Avatar
    My Sprint GS3 shut down on me while watching the Mexico vs Brazil game. At the time I assumed it was due to low battery but I can't get it to turn on after being on the charger for a while.

    -If I take the battery out and plug in the charger I get the red light for a second before it turns off

    -If I put the battery in it vibrates and goes to the Samsung screen and no further without me pressing the power button

    -If I get the timing right when putting the battery back on and plugging the cable, I get the battery charging icon for a second and thats it. No light or symbol afterwards.

    -I'm running CM11(or whatever the newest version is) from about three days ago

    I have yet to try using another battery but I have tried:

    - Removing the battery for 10 minutes and putting it back in
    - Pressed the power button without the battery (saw it on an article of troubleshooting for gs3)
    - Tried booting into recovery and download with no success
    06-18-2014 01:30 PM
  2. Almeuit's Avatar
    It sounds like the battery may be shot. Try another if you can.

    Sent from my T-Mobile Note 3 using AC Forums.
    06-18-2014 04:11 PM

Similar Threads

  1. Replies: 1
    Last Post: 07-06-2014, 01:24 PM
  2. Can You Turn Off Triple Tap To Wake Feature?
    By AndroidXTC in forum HTC One M8
    Replies: 11
    Last Post: 06-24-2014, 09:31 PM
  3. To upgrade or not to upgrade? Kit Kat on my Note 2 (Sprint)
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-18-2014, 04:12 PM
  4. Replies: 3
    Last Post: 06-18-2014, 03:38 PM
  5. Replies: 3
    Last Post: 06-18-2014, 03:20 PM