1. Reagan Samuel's Avatar
    Hi guys,

    I'm sorry if you might find this answered somewhere else. But as far as my google searching skills go, I've exhausted all options.

    The rooted S3 (GT-I9300 on stock 4.3 ROM) I've been using was working perfectly fine until I decided to flash touch CWM. (Note: I had already installed the app through play store or blackmart). Now my phone is stuck in a weird download mode loop. It's weird because it's not the normal download mode that comes when you press the Volume Down+Home+Power buttons. It's almost the same, except that the other details on the top-left corner are not being displayed (such as Odin Mode, product name, custom binary download, custom binary ...).

    However, I can still access the normal download mode using the above key combinations, only that that phone isn't recognized in Odin. Thus, I couldn't flash the stock rom using the same. Secondly, I can also access the recovery mode, but it's not CWM; instead, it's the stock android system recovery <3e>

    Now, to make things worse, all my attempts at flashing custom recovery and stock rom through ADB were in vain. Every time I tried flashing a custom rom or recovery (using adb sideload filename), the phone gave me the following message (E:signature verification failed). I understand it's the case with stock recovery, but I just can't install custom recovery. And to top it all, my attempts at installing CWM and stock rom (I9300XWUGML4_I9300DDGML4_INU.zip) using the 'apply update from external storage' option (yes, I can access my extSDcard) yield me same results (E:signature verification failed).

    So there you are, I tried adb; I tried Odin; I tried applying an update through external storage; I tried removing the battering and reinserting it (after almost four hours); I even tried factory resetting the handset, yet no positive results. My phone still goes to the weird download mode when rebooted. Please help. I don't want to bother everyone with stupid questions. I'm ready to do my research and help my case, but for now I'm at a roadblock. Your help would be much appreciated.

    Was running on stock 4.3; no custom ROMs were installed; it was only rooted
    Kernel: 3.0.31-2363855
    se.infra@SEP-122 #1
    Fri Dec 27 20:00:26 KST 2013

    Build: JSS15J.I9300XWUGML4
    AP: I9300XWUGML4
    CP: I9300DUGNB1
    CSC: I9300DDGML4
    06-22-2014 12:01 AM
  2. erdeebee's Avatar
    I've got the same problem, did the same things. I only am on Cyanogenmod 11, so Kitkat 4.4.4

    Any sollutions?
    07-20-2014 04:34 PM

Similar Threads

  1. Samsung galaxy s3 mini gtl8190 memory problem, pls help
    By nelly boy in forum Ask a Question
    Replies: 5
    Last Post: 06-23-2014, 03:07 PM
  2. Stuck At booting screen!Help!
    By WeepingBat in forum Ask a Question
    Replies: 6
    Last Post: 06-22-2014, 03:00 AM
  3. I'm having trouble downloading apps on my Samsung Note 3
    By AC Question in forum Ask a Question
    Replies: 4
    Last Post: 06-21-2014, 11:46 PM
  4. Samsung Galaxy S3 won't turn on, help
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 06-21-2014, 07:34 PM
  5. Just Downloaded Kies. Auto Sync?
    By medellinpaisa in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 06-21-2014, 04:21 PM