1. Glenn Ward's Avatar
    I received an AT&T update a few weeks ago to Android 4.4.2. Ever since, my phone has worked horridly, with the screen sporadically going black, the screen not responding to swipes, or worse (phone rings and no display) and I've had the error "Touch Wiz has quit responding" pop up at least twice. Is there anyway to fix this or in the alternative revert to the previous version?
    06-23-2014 04:26 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! If you haven't tried already, clear the system cache partition: Reset: Samsung Galaxy S 4 | T-Mobile Support. This can sometimes improve various issues after a major system update.
    06-23-2014 04:54 PM

Similar Threads

  1. Samsung Galaxy S GT-i9000 [ NTT Docomo (SC-02B) ]
    By AC Question in forum Ask a Question
    Replies: 4
    Last Post: 08-29-2015, 01:03 PM
  2. Firmware upgrade encountered an issue on GALAXY GEAR
    By Roger Skepple in forum Ask a Question
    Replies: 2
    Last Post: 07-05-2014, 08:10 AM
  3. Replies: 11
    Last Post: 06-24-2014, 01:30 PM
  4. I have lost my samsung galaxy core
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-23-2014, 04:58 PM
  5. Samsung Galaxy S4 Black Edition flip cover
    By matteblack in forum Samsung Galaxy S4 Accessories
    Replies: 0
    Last Post: 06-23-2014, 03:25 PM