1. Android Kyocera's Avatar
    I tried to enable the download manager and tried researching how to solve this. I tried shutting it down every time I found a solution but nothing! It keeps quitting. Please help: (
    06-23-2014 05:46 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! What model of Kyocera do you have? Did it come with Google Play preinstalled, or did you have to install it yourself? If the latter, then the phone is not Google Play certified, so you may run into compatibility problems.

    If Google Play did come preinstalled, then go to Settings>Apps>All, select Google Play Store, and Clear Cache and Clear Data. Then open it again, and see if the problems persist.
    06-23-2014 06:27 PM

Similar Threads

  1. how to update to 4.4 android without sim card?
    By Eric The Duke in forum AT&T Galaxy S III
    Replies: 8
    Last Post: 06-27-2014, 10:40 AM
  2. Am I the only one who keeps their s3 really clean
    By 0pk in forum Samsung Galaxy S3
    Replies: 8
    Last Post: 06-25-2014, 12:26 AM
  3. SD Card keeps "Unexpectedly" removing itself
    By checcles in forum Virgin Mobile Optimus V
    Replies: 1
    Last Post: 06-23-2014, 09:29 PM
  4. android galaxy centura locking up
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-23-2014, 06:29 PM
  5. MP4's on web no longer play FF locks up
    By reb0957 in forum Samsung Galaxy Note 2
    Replies: 0
    Last Post: 06-23-2014, 03:28 PM