1. AC Question's Avatar
    So for 3 days i have been trying to update my galaxy s3 from 4.1.1, my family is all on 4.1.2 and upgraded to 4.1.3. I need mine to update but every time i go to settings, about device, and software update to check, is says "current software is up to date you may check again in 23 hours" so the next day i tried again. It said the same thing, and the next day. I tried turning off my phone also re-setting/ force stop google services framework and then checking but it stil said check back in 23 hours. Im stuck on 4.1.1 and it wont update what do I do?
    06-27-2014 10:07 PM
  2. RumoredNow's Avatar
    06-28-2014 03:17 PM

Similar Threads

  1. Replies: 5
    Last Post: 02-20-2015, 06:01 AM
  2. LG G2 Update Question
    By austriak in forum LG G2
    Replies: 22
    Last Post: 07-15-2014, 07:06 PM
  3. Replies: 2
    Last Post: 06-30-2014, 08:52 AM
  4. Files disappearing from Download folder
    By dagn11 in forum Ask a Question
    Replies: 1
    Last Post: 06-28-2014, 02:28 AM
  5. Replies: 1
    Last Post: 06-27-2014, 07:50 PM