1. AC Question's Avatar
    It is my first post here, so forgive me any mistakes. I'm a newbie to Android.

    I've been drifting throughout the Internet and XDA-developers forum to find a solution to my problem, but I can't find it. You are my only hope. Even original support can't help. I bought a non-branded Android device for my car in April 2014, specifically this one: (happyshoppinglife honda-civic-android-autoradio-dvd-navigation-with-dtv-wifi-3g-p-1168). Since then I can't connect to the Internet using 3G modem.

    It seems to have some tailor-made Android version, since normal tablets don't have a DVD or FM radio or wheel-buttons.

    Recently the manufacturer/developer upgraded the Android to a version 4.4.2 (chinabatemon cargpss android-update-442 rar)
    Precisely it is:
    - Model SNT-210
    - Android 4.4.2-0140516-sntb-HOMEMADE
    - Kernel 3.0101-gdaab9de-dirty
    - QDroid@DevServer #9
    - Build omnisntb-eng 4.4.2 KOT49H eng.QDroid.20140516.133512 test-keys
    - iGo

    Currently I have 3g modems: Huawei E220 (VID 12d1:1003, PID 12d1:1003), Huawei K3770 (VID 12d1:14d1, PID 12d1:14c9), ZTE MF626 (VID 19d2:2000, PID 19d2:0031), Huawei E230 (VID 12d1:1003, PID 12d1:1003)

    The device has one USB port in the front and one in the back. The support suggested I use only the back port. Normally I have a USB hub connected to the back port. Then when I connect each modem (SIM card without PIN, modems unlocked), all of them start to blink green, then blink blue, just as if they connected to GSM service. But nothing happens on the screen. PPP Widget shows "no modem found". In the previous version of Android usually a "3g reconnect" application started after plugging the modem.
    Today I tried to plug E230 directly to the back port. PP Widget seemed to recognize a modem, but after clicking "connection parameters are missing. please complete setup", but I already have put APN, user and password (I use "internet" as APN, user and password for polish ).

    I have a "3g reconnect" (was already installed), "3g auto connection", "3g watchdog" and "PPP Widget 1.3.4"

    They do not support command AT^U2DIAG=0
    I tried AT^SETPORT="A1,A2;1,2,3" and AT^SETPORT="A1,A2;3,2,1" without success (I run them from Windows laptop).

    Wifi works fine, but I need 3g..

    The device seems not to be rooted, so I can't even see what USB ports are available.

    The seller's support doesn't help anything and is almost useless and unable to reach (even one chat talk can last the whole day).

    I'm pretty much determined to do anything just to get it work and I have no further ideas what to do.
    07-01-2014 11:46 AM
  2. Golfdriver97's Avatar
    If you can, perhaps a factory reset?
    10-23-2014 10:28 PM
  3. Rukbat's Avatar
    You do have a data account with some phone carrier, right? And you do have the APN data set for that carrier's 3G service, right?

    If all that's correct, I'd contact the manufacturer. (If it were me, after running a car with in-dash nav for about 5 years, I'd get a Mountek mount and use my phone for navigation, which is what I do. My nav system, which cost about 2 grand, sits there never used. Google Maps, used with MyDirections-Google Map ext., is a better nav system IMO. [My wife prefers her Magellan - but she likes TouchWiz too - which is why there are two computer rooms in this house. Divorces are messy and expensive.)
    10-24-2014 05:30 PM

Similar Threads

  1. Android 4.3 on Samsung Galaxy S3 mini ??
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-01-2014, 06:22 PM
  2. Anyone else waiting for MS Office for Android Tablet?
    By SpookDroid in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 16
    Last Post: 07-05-2014, 02:03 PM
  3. download android mod games - mod apk - mod datafile.
    By Amazing Spiderman in forum The Android Central Lounge
    Replies: 0
    Last Post: 07-01-2014, 10:29 AM
  4. Problems with 3rd Party Messaging Apps
    By Nekoxii in forum Ask a Question
    Replies: 3
    Last Post: 07-01-2014, 09:50 AM