1. Mitesh Ganmukhi's Avatar

    I bought a Samsung Grand 2 in February this year. It has worked absolutely fine until last week when I noticed that the GPS was not working at all. The phone is on android 4.3 but I cannot be sure if the problem started after an update was applied - however I see many people complaining that 4.3 has affected their GPS in some or the other way.

    What happens is when I open any app that uses GPS (maps, fourquare etc) the blinking dot appears in the top left corner indicating that the phone is working on establishing a communication with the GPS satellites, but it will keep blinking to no end. I have let it sit for over 2 hours in the balcony and still nothing. I have used GPS navigation on this phone many times before and every time I would get a location lock in less than 20 seconds - so I am sure something has gone wrong here.

    Here's what I've tried already:
    - reboot phone
    - toggle gps
    - full factory reset
    - putting the phone in flight mode and then test the GPS connection using GPS Test app
    - toggling various other settings like google location services
    - tried using A-GPS using the app mentioned above
    - clearing all sorts of caches and app datas

    None of the above have worked and I am nearly tearing my hair apart over this stupid problem! Any help would be greatly appreciated!!
    07-01-2014 02:56 PM
  2. UJ95x's Avatar
    Sorry you are having issues with GPS. Is it not working at all? Or is it only at certain times?

    Make sure you have location services turned on, and that maps has access to it.

    Sent from my Galaxy S4 running SOKP 4.4.2
    07-01-2014 03:24 PM
  3. chiragvagh's Avatar
    Is your problem solved?

    Have you connected Samsung support?
    07-06-2014 05:05 AM
  4. Abhishek Dubey2's Avatar
    tighten all the screws on the back panel after removing the battery
    worked for me
    now my grand 2 is working fine
    07-06-2014 04:54 PM
  5. asim pa's Avatar
    Exactly had same complaints.many having same issues especially s3 model.so I went to local mobile repair shop and told them to check and tighten back panel of grand 2 just to try luck ..surprisingly its working..Samsung not concentrating on mobile build quality nowadays.planning to change phone
    07-10-2014 05:18 AM
  6. rohanviolin's Avatar
    I am having gps problems in kitkat...it's finding satellites but not locking the position...the strength goes up to 5-6 and then comes back down to 0...not locking at all...any solution?
    08-14-2014 07:22 AM
  7. Anish Lj's Avatar
    I am having the same problem with my grand 2 with KITKAT update. GPS locking works some times but most of the time the Icon keeps on blinking telling searching for GPS what to do..
    09-07-2014 01:25 AM
  8. contactravib's Avatar
    Exactly I am in same boat as Anish Lj.
    But am not sure if this is due to KitKat 4.4.2 update, but i believe it could be a problem with Jelly Bean as well.

    asim pa & Abhishek Dubey2 , Its been couple of months since you mentioned that you tightend the screws for GPS problem. Is it still working or did the problem resurface?

    I like this phone Grand2 as it works great in all aspects except for GPS. Any help is highly appreciated !

    09-27-2014 01:11 PM
  9. Alex Voronin's Avatar
    The same disaster, absolutelly the same! Just tried to tighten all the screws on the back panel, will check on the street...
    10-02-2014 08:36 AM
  10. contactravib's Avatar
    Folks, finally some relief. My Grand2 GPS issue got resolved and its working now.

    After taking backup in Kies software, I took the phone to Samsung service center in Bangalore this morning. They mentioned that the latest firmware updates for Kitkat via OTA/WiFi creates lot of trouble for multiple devices and hence the drivers are not loading properly in the underlying OS. They suggested to reinstall the OS through their own Server connected to Samsung central server. Though i was not confident, i agreed to give it a try. But surprisingly it worked. The GPS location gets fixed in less than or in about 20 seconds which is really good ! The service center guys suggested NOT to update any latest firmwares/updates pushed by Samsung, which will again create problem. I am not sure what will be the loss in not updating to latest firmware, which is a general thumbrule. Nevertheless, for now the GPS problem is solved and am happy with that.

    Generally, the phone was working fine the whole day. I couldn't test the Smart Stay functionality to see it working. Once i found that the phone complained "Not registered on network" error while trying to make outgoing calls. After reboot it went away. Hope it continues to work fine.

    So those who are still facing problem with GPS in Galaxy Grand2 , suggest to take your phone to service center and get the OS reimaged after backup. Hope your problem also gets resolved.

    10-06-2014 11:47 AM
  11. contactravib's Avatar
    Folks, sad news. My happiness was short lived. After some forceful updates by Samsung which i could not stop when connected to internet (even after disabling the auto-updates), GPS stopped working correctly. Since i have seen it working couple of times, i thought there is no hardware issue but am wondering what app/what setting is screwing up the GPS functionality. I've told the Samsung service center about the problem, they acknowledged but asked me to leave the phone for couple of days. I will have to do it post Diwali holidays !

    I used the "GPS Test" app which shows about 18 to 24 satellites in View, but 0 satellites in Use to fix the location.

    10-14-2014 01:22 AM
  12. contactravib's Avatar
    Okay, its been more than a month now. I continuously followed up with Samsung service centre and finally had success.
    The issue is root-caused to motherboard/chipset problem and the Service Center Manager agreed to replace it free of cost, as the device is still under warranty. I agreed and changed the motherboard/chipset and its been more than 10 days now.
    I am pretty sure the GPS is working now fantastically. Everyday, i am checking it whenever i step out and wherever possible, to ensure GPS location fixing is working or not. Yes, (touchwood) it works finally and the location gets locked usally in less than 10 seconds and remains the same and sometimes it takes about less than 30 seconds.

    I have also tested while driving my car and ensure that as the geographic location changes, the GPS connection is not lost and the location tag is fixed in phone all the time.

    Finally, some success !! Thanks and Kudos to the Service center manager who root caused it correctly and got it replaced with a new motherboard which totally resolved the problem. !!!

    11-26-2014 12:29 PM
  13. wizzrah's Avatar
    Glad you got it fixed!
    11-26-2014 12:36 PM
  14. Rukbat's Avatar
    Everyday, i am checking it whenever i step out and wherever possible
    With the receiver and antenna that Samsung uses, you should get a good fix indoors too, unless the building is pretty well shielded. Just watch GPS Status & Toolbox and you'll know what's happening. (If it receives a satellite but doesn't lock to it [yellow while it's trying to receive the initial transmission, green once it locks], the signal is too weak where you are - not uncommon, even in a dense forest. It's when no satellites even go yellow that there's a problem. That means "the satellite should be over there, but I don't hear it".)
    11-26-2014 04:46 PM
  15. Mallick Choppa's Avatar
    I too had this problem from last 3 months, Thanks to this forum.... I unscrewed and screwed it back and tight.. I checked it today on to my office it worked perfectly..
    06-15-2015 11:51 PM
  16. arun kashyap's Avatar
    my phn galaxy grand2 .my phn is no on plz help me .all data my losss.
    06-23-2016 05:58 AM
  17. arun kashyap's Avatar
    hi jjkk
    06-23-2016 05:59 AM
  18. arun kashyap's Avatar
    my phn galaxy grand2 .my phn is no on plz help me .all data my losss.
    06-23-2016 06:00 AM

Similar Threads

  1. Replies: 2
    Last Post: 11-14-2014, 05:10 PM
  2. samsung question
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 07-02-2014, 07:35 AM
  3. moto x speaker not working
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-01-2014, 03:16 PM
  4. Installed Nova Launcher...now OK Google doesn't work?? Why?
    By Jon Jackson in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 07-01-2014, 03:00 PM