1. AC Question's Avatar
    So I got my tablet about 6 months ago and it stopped working for a little bit. But now it is working, so I did l the steps to log into it but when I go to download any app what so ever n the Play Store it just has the blue download bar under it that tells me it is downloading but after clicking install and waitng 4-7 hours my tablet still has not downloaded one app. It does not come up with any error codes or anything. So I went to another solution and tried downloading Amazon App store from the website, but my tablet popped up a window saying "Appstore couldn't be installed. Free up some space and try again." Yet I have no apps downloaded. It would be amazing if someone could help me out. Thank you
    07-01-2014 05:39 PM
  2. belodion's Avatar
    It would be quite fantastically incredible if I could help you out. But have you ever been able to download apps on the device?

    Posted via Android Central App
    07-01-2014 06:53 PM
  3. Rob Kemp1's Avatar
    Having the same problem here. When we first bought the tablet it worked fine. Hadn't used it in a while but when we tried again the apps like Google browser and others that had downloaded before and had updated properly before were not updating...kept saying "Downloading" but never would give a percentage of how much was downloaded and would never finish...even when left for DAYS updating.

    My wife and I both tried doing factory resets but even that does not resolve the issue.
    07-06-2014 04:23 AM

Similar Threads

  1. Does my home screen look too busy?
    By Jon Jackson in forum Samsung Galaxy S5
    Replies: 83
    Last Post: 09-05-2014, 11:32 AM
  2. Replies: 3
    Last Post: 07-01-2014, 06:18 PM
  3. What photo progams are using up my phones space??
    By Ed Ke6bnl in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 07-01-2014, 06:04 PM
  4. Problems with the Wifi on my Galaxy S4
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-01-2014, 04:22 PM