1. AC Question's Avatar
    As of late, my 60 Buck Trio tablet will no longer display any media whatsoever from the super hd play app, and I can't download any apps at all from the amazon app store. This is the first tablet I've ever had, so I feel pooped right now. I'm sure that nothing's wrong with the sd card. I can use acrobat reader and view pdf files on the tablet just fine.

    I tried going to the file manager to open the pictures there, but could not. This the tablet said "no external storage available." This happened even though I could see the picture right behind the alert sign. For some reason, it's now bugged that way. I've even done factory resets on the device maybe 3 times already.

    I can't send anything from my windows 7 to the device itself via usb, as windows says that it found all the drivers except the Android driver (that's odd for me). I have a mac and pc on the same computer, so I flipped to the mac side, and successfully installed an app called "android file transfer" for my mac. All went well until I tried sending media from my computer to the tablet with the program, using the drag and drop method. It never worked.

    So what's wrong with this picture? Did I buy a piece of junk and got ripped off at BestBuy, or could this be fixed? Maybe it needs a software update? Please help ***asap***, Any constructive input would be appreciated. Thanks.
    07-02-2014 10:06 PM
  2. B. Diddy's Avatar
    Welcome to Android Central, and sorry for the delay! Trios are pretty low end, and as such, are more likely to have problems with their system software or hardware. Support is also likely to be minimal or nonexistent. If the tablet is fairly new, see if you can return it or exchange it at Best Buy. Otherwise, check the company's website (Trio Tablets) and look if there are any firmware updates available for your model.
    07-08-2014 03:52 PM

Similar Threads

  1. Samsung Galaxy Tablet 8.9 locked out
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-27-2014, 10:56 PM
  2. s3 and gps with bluetooth
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-01-2014, 01:09 AM
  3. S5 apps dont load even if I have wifi and 4G
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-01-2014, 01:08 AM
  4. Android L keyboard on DNA
    By dnafog in forum Verizon Droid DNA
    Replies: 1
    Last Post: 07-24-2014, 08:33 PM
  5. Replies: 1
    Last Post: 07-02-2014, 10:46 PM