1. AC Question's Avatar
    All of a sudden my S4 stopped communicating with my Epson printer. I printed some things from it earlier today, went shopping, came home and now it cannot communicate with the printer. I keep getting a message that just says "cannot communicate with printer." Does anyone have any idea why within the last few hours I can't print from my phone? I haven't changed any settings. Please help!
    07-10-2014 08:41 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Are you using Samsung Mobile Print or Google Cloud Print? Or something else?
    07-10-2014 08:42 PM
  3. ohpgoil's Avatar
    I'm not using Google cloud print. The phone came loaded with Samsung and Google Print. Both worked earlier today; now neither is working. Printer communicates with laptop, just not the phone.
    07-10-2014 08:46 PM
  4. B. Diddy's Avatar
    Have you tried rebooting the phone? Turning the printer off and on?

    If those steps don't help, go to Settings>Apps>All, and see if you have an app called Print Spooler. Select it, and Clear Cache/Clear Data. Then try printing again.
    07-10-2014 09:04 PM
  5. ohpgoil's Avatar
    There is an app button at the bottom of the home screen. I can't find a print spooler at all. I found the Samsung printer app and cleared the cache. I can't seem to be able to find the google print app.

    When it's sending the info to the printer through the Samsung printer app, it looks as if it's looking for the Epson 420 and NOT the Epson 420 (Network) Geesh, how do I fix that?
    07-10-2014 09:11 PM
  6. B. Diddy's Avatar
    I'm sorry, I forgot that you have a Samsung device. Go to the App Manager, and in the list for All Apps, look for a Print Spooler app or something similar. System apps don't necessarily show up in your App Drawer, but they should be in the full app list in the App Manager.
    07-10-2014 09:13 PM
  7. ohpgoil's Avatar
    Nothing that says Print spooler. I can see a Samsung Print service plugin, which I've cleared. I can see the Epson Print enabler, which I just tried turning on to see if it helped. I DO NOT see the google print app, but it's available when sending files to the printer. Still cannot communicate with the printer.

    I found 3 apps that say Mobile Print. Cleared the caches in those. I did find the print spooler also. Cleared it. Still cannot print.

    I got it!! I started the printing, when the printer page popped up, I noticed that there was a settings option (small gear icon) I selected it, and it brought up the printers, I selected the printer, saved it and it works again. I have NO idea how it got UNselected. Thanks for your help.
    07-10-2014 09:35 PM
  8. B. Diddy's Avatar
    Is the printer wi-fi enabled, or is it connected to a router or computer via USB cable? If the printer is wi-fi enabled, check the printer's manual to see if there is a troubleshooting guide. If it's connected to a router, try rebooting the router (by unplugging the router's power, waiting 10 seconds, and plugging it back in).
    07-10-2014 09:41 PM

Similar Threads

  1. Galaxy S3 Mini Factory Reset Using Mobile Settings
    By Unregistered in forum Ask a Question
    Replies: 5
    Last Post: 07-12-2014, 12:22 AM
  2. Bricked my Galaxy S3. Help?
    By System in forum Legacy Android & Other OS's
    Replies: 9
    Last Post: 07-11-2014, 07:34 PM
  3. Your opinion on your Note 3 camera vs Galaxy S4
    By stephanie85 in forum Samsung Galaxy Note 3
    Replies: 9
    Last Post: 07-11-2014, 04:22 PM
  4. s4 multiwindow
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-10-2014, 10:16 PM
  5. samsung s4 mini
    By maxbloggs in forum Samsung Galaxy S4 Mini
    Replies: 1
    Last Post: 07-10-2014, 07:06 PM